LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-01-2011, 09:21 AM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Rep: Reputation: 57
How to disable nouveau


I want to install the Nvidia drivers because I suspect nouveau to be responsible for some system freezes. It seems that I need to disable nouveau before I can get nvidia working. How do I do this?

Thanks
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 05-01-2011, 09:24 AM   #2
The Seeker 11
Member
 
Registered: Apr 2004
Location: Buxton, UK
Distribution: Slackware
Posts: 48

Rep: Reputation: 18
xf86-video-nouveau-blacklist.
 
2 members found this post helpful.
Old 05-01-2011, 09:25 AM   #3
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 86

Rep: Reputation: 14
when you install binary driver from nvidia: NVIDIA.xxx.run that will automate blacklist nouveau
 
Old 05-01-2011, 09:40 AM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
Thanks.

The Seeker 11. That worked fine

kkady32 I noticed that but I was not sure exactly what that was going to do.
 
Old 05-01-2011, 09:45 AM   #5
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 86

Rep: Reputation: 14
Quote:
Originally Posted by arubin View Post
Thanks.

The Seeker 11. That worked fine

kkady32 I noticed that but I was not sure exactly what that was going to do.
and for automatic update (to latest version) just use this command:
Code:
nvidia-installer --update
 
Old 05-02-2011, 10:47 AM   #6
qweasd
Member
 
Registered: May 2010
Posts: 486

Rep: Reputation: Disabled
I also had stability problems with the nv driver (I think). It is laggy, draws artifacts, and locks up X randomly. Replaced the driver by running the (evil) nvidia installer, and the problems went away. My adapter is
Code:
01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GT] (rev a2)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
F15, Disable Nouveau driver in prep to install Nvidia drvr toddbailey Fedora 7 04-30-2011 07:33 PM
nouveau Pedroski Fedora - Installation 5 06-15-2010 09:11 AM
LXer: Nouveau Companion 30 LXer Syndicated Linux News 0 11-10-2007 05:10 PM
LXer: Nouveau Companion 26 LXer Syndicated Linux News 0 08-23-2007 07:30 AM
LXer: Nouveau: A First Look LXer Syndicated Linux News 0 12-25-2006 05:54 PM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration