LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-04-2013, 05:46 PM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Rep: Reputation: 57
How to disable HP Device Manager Autostart


On a fresh install of 14.1 the HP Device manager appears on in the system tray on the right in kde. I do not use HP devices, have no requirement for this and am surprised that it seems to be autostarting by default.

I can find no easy way to disable this. Googling suggests that removing /etc/xdg/autostart/hplip-systray.desktop would do it. Is that so? Or does it just remove the icon but I would still have some unwanted process running in the background?
 
Old 12-04-2013, 05:48 PM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,275

Rep: Reputation: 187Reputation: 187
What desktop are you using?
In Xfce go to Settings > Session & Startup > Applications > Auto Start and remove the check mark to the left of the HP utility.

Last edited by cwizardone; 12-04-2013 at 05:51 PM.
 
Old 12-04-2013, 05:59 PM   #3
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
kde I have already looked in System Settings/ Startup and Shutdown/ and I cannot see it there. Unless it is 'Printer Manager'.
 
Old 12-04-2013, 07:35 PM   #4
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 262

Rep: Reputation: 29
I've moved it to /etc/xdg/autostart/hplip-systray.desktop-DISABLED and it doesn't startup.
 
Old 12-04-2013, 08:08 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
PITA huh, the presumption that everyone needs or wants that service running? Kind of like Windows....

* Create $HOME/.config/autostart/hplip-systray.desktop

* In that text file add this:

[Desktop Entry]
Hidden=true

In addition to that, because I don't want the service running at all, I delete /etc/xdg/autostart/hplip-systray.desktop. I delete the file because the file gets updated every time hplip gets updated.
 
Old 12-04-2013, 08:30 PM   #6
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
Quote:
Originally Posted by glorsplitz View Post
I've moved it to /etc/xdg/autostart/hplip-systray.desktop-DISABLED and it doesn't startup.
Or change the permission to 640 to prevent the startup for ordinary users.
 
Old 12-04-2013, 10:01 PM   #7
hernanmedellin
LQ Newbie
 
Registered: Mar 2006
Location: Monterrey, México
Distribution: Slackware-current
Posts: 14

Rep: Reputation: 2
If you don't need it ...

removepkg hplip
 
Old 12-05-2013, 05:08 AM   #8
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
Thanks for all that. It seems to me that there is no reason to keep the package at all.
 
Old 12-05-2013, 11:15 AM   #9
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 908

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
HPLIP was auto-started since it was added to Slackware 12.0, but the taskbar notification icon was hidden by default. So maybe they changed the default configuration.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] disable blank cd autostart izghitu Linux - Newbie 2 01-27-2011 02:05 PM
How do I disable HP device manager? damgar Slackware 11 05-03-2010 01:31 AM
How to disable noatun autostart dohpaz Slackware 3 10-20-2007 01:07 PM
How to disable scim autostart? windz Linux - Software 1 07-17-2005 08:43 AM
Disable CD Creator Autostart? fortezza Linux - Software 1 08-07-2004 04:49 PM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration