LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How to disable HP Device Manager Autostart (http://www.linuxquestions.org/questions/slackware-14/how-to-disable-hp-device-manager-autostart-4175486888/)

arubin 12-04-2013 05:46 PM

How to disable HP Device Manager Autostart
 
On a fresh install of 14.1 the HP Device manager appears on in the system tray on the right in kde. I do not use HP devices, have no requirement for this and am surprised that it seems to be autostarting by default.

I can find no easy way to disable this. Googling suggests that removing /etc/xdg/autostart/hplip-systray.desktop would do it. Is that so? Or does it just remove the icon but I would still have some unwanted process running in the background?

cwizardone 12-04-2013 05:48 PM

What desktop are you using?
In Xfce go to Settings > Session & Startup > Applications > Auto Start and remove the check mark to the left of the HP utility.

arubin 12-04-2013 05:59 PM

kde I have already looked in System Settings/ Startup and Shutdown/ and I cannot see it there. Unless it is 'Printer Manager'.

glorsplitz 12-04-2013 07:35 PM

I've moved it to /etc/xdg/autostart/hplip-systray.desktop-DISABLED and it doesn't startup.

Woodsman 12-04-2013 08:08 PM

PITA huh, the presumption that everyone needs or wants that service running? Kind of like Windows....

* Create $HOME/.config/autostart/hplip-systray.desktop

* In that text file add this:

[Desktop Entry]
Hidden=true

In addition to that, because I don't want the service running at all, I delete /etc/xdg/autostart/hplip-systray.desktop. I delete the file because the file gets updated every time hplip gets updated.

tux_dude 12-04-2013 08:30 PM

Quote:

Originally Posted by glorsplitz (Post 5075574)
I've moved it to /etc/xdg/autostart/hplip-systray.desktop-DISABLED and it doesn't startup.

Or change the permission to 640 to prevent the startup for ordinary users.

hernanmedellin 12-04-2013 10:01 PM

If you don't need it ...
 
removepkg hplip

arubin 12-05-2013 05:08 AM

Thanks for all that. It seems to me that there is no reason to keep the package at all.

jtsn 12-05-2013 11:15 AM

HPLIP was auto-started since it was added to Slackware 12.0, but the taskbar notification icon was hidden by default. So maybe they changed the default configuration.


All times are GMT -5. The time now is 05:54 AM.