LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-06-2011, 07:55 AM   #1
wubai
Member
 
Registered: Dec 2009
Posts: 103

Rep: Reputation: 20
how to disable alps touchpad on laptop which not found ?


Hi,
I have a touchpad with two buttons (if I'm not mistaken it's an Alps,dell inpiron M511*).
it works very slowly, and when i typing it becomes anoying,
Is there any option to disable it?

Driver: synaptics
Os: Slackware 13

$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=7 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=9 [slave pointer (2)]
⎜ ↳ USB OPTICAL MOUSE id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=6 [slave keyboard (3)]
↳ Dell WMI hotkeys id=8 [slave keyboard (3)]
↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
↳ Sleep Button id=12 [slave keyboard (3)]
↳ Power Button id=13 [slave keyboard (3)]
↳ Video Bus id=14 [slave keyboard (3)]
↳ Power Button id=15 [slave keyboard (3)]
 
Old 11-08-2011, 07:35 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
On laptops usually blacklisting the 'psmouse' module will disable the touchpad.

So in '/etc/modprobe.d/blacklist.conf' you would add:

Code:
blacklist psmouse
then restart. You had better have a mouse plugged in tho, because otherwise you can't move the pointer.
 
1 members found this post helpful.
Old 11-08-2011, 08:41 AM   #3
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-C ML
Posts: 883

Rep: Reputation: 78
Thanks H_TeXMeX_H !!
I was about to put a hammer through mine. lol
 
Old 11-12-2012, 07:12 PM   #4
wubai
Member
 
Registered: Dec 2009
Posts: 103

Original Poster
Rep: Reputation: 20
thanks very much !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to disable Alps touchpad when USB mouse is present? Totoro-kun Slackware 14 05-27-2011 01:21 AM
ALPS touchpad: EVEREX laptop 2.6.9RH brigo Linux - Laptop and Netbook 2 09-04-2007 12:03 PM
DISCUSSION: Slackware 10.2 on a laptop: ACPI and even the Alps Touchpad. Part 1 cwwilson721 LinuxAnswers Discussion 1 04-04-2006 11:02 AM
laptop touchpad - how to disable 'tap to click'?? Adrian Baker Linux - Laptop and Netbook 2 01-17-2006 05:15 PM
laptop touchpad disable?? linuxhippy Slackware 4 03-13-2005 07:01 PM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration