LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-13-2013, 02:12 PM   #1
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Rep: Reputation: 16
how to control notebook fan speed?


Hi all,

When I use Slackware on my laptop, the CPU fan is from right about 5 minutes of use onward, seemingly maxed out. On other OS's (Windows 7 or LinuxMint) I don't get this behavior.

I've ran
Code:
# sensors-detect
and it asked me to put in /etc/rc.d/rc.local the lines:
modprobe coretemp
/usr/bin/sensors -s

But it's still very noisy.

How can I work this out?
 
Old 04-13-2013, 02:17 PM   #2
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Rep: Reputation: 46
Any strange messages in dmesg?
 
Old 04-13-2013, 03:31 PM   #3
jprzybylski
Member
 
Registered: Apr 2011
Location: Canada
Distribution: Slackware
Posts: 98

Rep: Reputation: 23
The laptop model would also be useful to know. Sometimes particular models have strange parts that don't have drivers yet. <EDIT> And in the case of Mint, sometimes Canonical uses patches on the kernel that have not yet made it to the mainline kernel.</EDIT>

Last edited by jprzybylski; 04-13-2013 at 03:39 PM.
 
Old 04-13-2013, 10:35 PM   #4
ill323
LQ Newbie
 
Registered: Jul 2010
Posts: 17

Rep: Reputation: 3
If your laptop is thinkpad, you may try this:

http://sourceforge.net/projects/thinkfan/

It works really well.
 
1 members found this post helpful.
Old 04-14-2013, 06:31 PM   #5
yenn
Member
 
Registered: Jan 2011
Location: Czech Republic
Distribution: Slackware, Gentoo, FreeBSD
Posts: 160

Rep: Reputation: 21
Quote:
Originally Posted by ill323 View Post
If your laptop is thinkpad, you may try this:

http://sourceforge.net/projects/thinkfan/

It works really well.
I just tried it on my Thinkpad T60, because fan is always running (http://www.thinkwiki.org/wiki/Proble...ays-on_problem). Version 0.9_beta2 doesn't work at all
Code:
WARNING: Using default fan control in /proc/acpi/ibm/fan.

WARNING: Using default temperature inputs in /proc/acpi/ibm/thermal.
Segmentation fault
but 0.8.1 works and finally my fan stopped spinning. Thanks!

Is there some safe values table for thinkpads? Because I'm not sure if I have to worry about this warning:
Code:
WARNING: You're using simple temperature limits without correction values, and your fan will only start at 55 C. This can be dangerous for your hard drive.
By the way, I also tried ThinkPad-Fan-Control and it lets you control the fan speed, although fan never stop spinning in automatic mode. So I'll stick with thinkfan.
 
Old 04-14-2013, 07:30 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,619
Blog Entries: 2

Rep: Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076
On many laptops it is not possible to directly control the fanspeed. To help you we need more information:
- Manufacturer/model of the laptop
- Is the power-management of the CPU working correctly?
- In case of AMD/ATI or Nvidia graphics, are you using the free or the proprietary drivers?
- Have you measured the temperatures (since you already are using the lm_sensors package)?
 
Old 04-14-2013, 07:36 PM   #7
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
If this is a Toshiba L305D series, you may as well forget it. I had(ve) one and it constantly overheated from the fan not turning on. I searched everywhere for a way to control the fan, but evidently Toshiba has some really bad BIOS software.
 
Old 04-15-2013, 02:31 AM   #8
ill323
LQ Newbie
 
Registered: Jul 2010
Posts: 17

Rep: Reputation: 3
Quote:
Originally Posted by yenn View Post
but 0.8.1 works and finally my fan stopped spinning. Thanks!

Is there some safe values table for thinkpads? Because I'm not sure if I have to worry about this warning:
These warnings are harmless, but you should monitor your machine for some time to make sure that the config is safe.

Thinkfan 0.8.x added support for other laptop.
For thinkpad, 0.7.3 is enough.

My config is(thinkfan: 0.7.3; laptop: thinkpad R61i):

(0, 0, 45)
(1, 45, 55)
(7, 55, 32767)

R61i has only 2 levels(1/7)fan speed.
 
Old 04-15-2013, 02:38 AM   #9
pan64
Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 5,028

Rep: Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324Reputation: 1324
probably you only need a vacuum cleaner and 10 minutes....
 
Old 04-15-2013, 07:25 AM   #10
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
Hi all,

I guess that when I posted this thread I was too tired and forgot to mention a few details.

@ottavio, I haven't searched for anything in dmesg, what kind of warning should I have in mind?

As @jprzybylski and @TobiSGD inquired, the laptop is a Dell Inspiron 15R Special Edition (7520).

Following up on @TobiSGD's questions:
It's almost a pristine installation. Today's Monday and I believe I have installed Slackware64-current last Wednesday night. Haven't touched any power-management settings.
The laptop has a hybrid graphics card (AMD Radeon HD 7730M and Intel 4000HD), but I couldn't install proprietary video drivers - it just wouldn't start X after the "aticonfig --initial -f" command to create a proper /etc/X11/xorg.conf file.
Nope, haven't measured the temperatures, but as far as I've noticed, this high spinning fan behaviour only happens on X. Yesterday I turned the laptop on runlevel 3 and I didn't fired up X and haven't noticed any fan high speed, so it might be related to the AMD video driver on X.

Also, @pan64's idea is worth a try!

Last edited by gtludwig; 04-15-2013 at 07:47 AM.
 
Old 04-15-2013, 09:07 AM   #11
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,533

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
Quote:
Originally Posted by gtludwig View Post
The laptop has a hybrid graphics card (AMD Radeon HD 7730M and Intel 4000HD), but I couldn't install proprietary video drivers - it just wouldn't start X after the "aticonfig --initial -f" command to create a proper /etc/X11/xorg.conf file.
Nope, haven't measured the temperatures, but as far as I've noticed, this high spinning fan behaviour only happens on X.
As you l know, hybrid graphics is supposedly a mean of adjusting power consumption to laptop's usage,

But that assume that you can disable the RADEON GPU when you don't need it.

Si I'd check if there is a way to switch it off, either with a physical switch, a BIOS setting or a user space command.

Last edited by Didier Spaier; 04-15-2013 at 09:08 AM.
 
Old 04-15-2013, 09:52 AM   #12
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
It would require a user space command of some sort, there's no physical switch and no BIOS setting to toggle the Radeon GPU.
 
Old 04-15-2013, 05:55 PM   #13
jprzybylski
Member
 
Registered: Apr 2011
Location: Canada
Distribution: Slackware
Posts: 98

Rep: Reputation: 23
Looking at a Ubuntu question here:

http://askubuntu.com/questions/19238...-inspiron-7520

The solution they gave was also to install AMD's catalyst drivers. However, they seem to require x86 support - have you installed multilib?

Also looking here:

https://www.linuxquestions.org/quest...3/#post4695040

TobiSGD suggested passing nomodeset to the kernel during boot (in that post). Does that help at all?

Also see if there are any solutions here:

http://docs.slackware.com/howtos:hardwareroprietary_graphics_drivers
 
Old 04-16-2013, 05:14 AM   #14
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Rep: Reputation: 46
Quote:
Originally Posted by gtludwig View Post
Hi all,


@ottavio, I haven't searched for anything in dmesg, what kind of warning should I have in mind?
Grep something meaningful, like fan, sensors, error, warning, or just read it all.

Dmesg should be the first line of resolution when troubleshooting a Unix-like system.
 
Old 04-16-2013, 07:39 AM   #15
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,619
Blog Entries: 2

Rep: Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076
Your problem most likely is caused by incomplete power-management in the free radeon driver, this driver defaults to the highest clockspeed and fan settings. You can try if manually setting a lower powersetting with
Code:
echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile
Since you have two videocards in that system it may be possible that you have to change card0 to card1 in those commands.
 
  


Reply

Tags
fan, temperature control


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cutting fan yellow wire to disable fan speed control Mr. Alex General 2 07-30-2011 06:48 PM
How to control cpu fan speed? no fan control with BIOS, acpi, lm-sensors startover Linux - Hardware 20 01-08-2011 04:18 AM
ACPI or lm-sensors fan control on Sony Vaio (fan runs at full speed) roanm Linux - Hardware 7 11-14-2009 08:37 PM
chassis fan speed control (case fan) wastingtime Linux - Hardware 12 12-02-2007 08:08 PM
howto: control CPU fan speed and Northbridge fan speed? hedpe Linux - Software 2 04-18-2005 03:18 AM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration