LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-31-2014, 11:10 AM   #1
xeveri
LQ Newbie
 
Registered: Mar 2014
Location: Shandong,China
Distribution: slackware,win7
Posts: 12

Rep: Reputation: Disabled
how to connect to wlan


I can not connect to China CMCC WLAN in slackware. So i have to use windows7.
To connect to wlan , i use wpa_supplicant and wpa_cli and it works well for the case that only passwd is needed. However,for CMCC wlan, you should first connect to it(this is the point i don't know how to do). Then, in the web browser for any one website,it jumps to the authorization site where you supply you cellphone number and password.
When i used ubuntu before,it was very easy.You just need to connect to it in gonme desktop. But i have no idear in slackware.

Last edited by xeveri; 05-31-2014 at 11:12 AM.
 
Old 05-31-2014, 11:49 AM   #2
ndc85430
Member
 
Registered: Apr 2014
Distribution: Slackware
Posts: 77

Rep: Reputation: Disabled
If you want an application with a GUI, install Wicd. You can find it in /extra on your Slackware media or on any Slackware mirror. Make sure to read the README.SLACKWARE file in the directory in which you find the package (i.e. /extra/wicd), as it contains useful information.

If you're using Slackware 14.1, you also have the option of NetworkManager, but I don't know much about that.
 
Old 05-31-2014, 12:08 PM   #3
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,283

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
rc.wicd is installed in /etc/rc.d/rc.wicd

If wicd does not start-up for you then issue this command: chmod +x rc.wicd

Then

/etc/rc.d/rc.wicd start

When your PC starts up you will have a nice GUI you can use to join your wireless networks.
 
1 members found this post helpful.
Old 05-31-2014, 12:14 PM   #4
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,582

Rep: Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806
If I am understanding the question correctly connecting to this wireless network requires logging in using a web browser? If that is the case then you should be able to log in using your web browser in Slackware as you did with Ubuntu. You would have to start X11 for this though by running "startx" on the command prompt. If you don't have any kind of desktop environment installed you may be able to join the wireless network but it will be a long process of writing small scripts which use curl or wget.

Last edited by 273; 05-31-2014 at 12:16 PM.
 
Old 05-31-2014, 10:43 PM   #5
ymf331
Member
 
Registered: May 2014
Posts: 38

Rep: Reputation: Disabled
not sure if this answers your question, but from a terminal you can set up your wireless connection with iwconfig, and then "ifconfig wlan0 up". after that probably "dhcpcd wlan0".
 
Old 06-01-2014, 03:34 AM   #6
xeveri
LQ Newbie
 
Registered: Mar 2014
Location: Shandong,China
Distribution: slackware,win7
Posts: 12

Original Poster
Rep: Reputation: Disabled
snapshot1.png

Screenshot2.png
this is the case.
In ubuntu ,there is icon showing all the wlans on lefttop of desktop. I just need to connect to CMCC,then in web browser i can connect to it use nameand passwd.So how to connect to CMCC wlan in command line(with what commands?).
 
Old 06-01-2014, 05:18 AM   #7
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,582

Rep: Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806
As I mentioned, it could be a long process but this tells you where to start:
https://superuser.com/questions/1323...-an-http-login
 
Old 06-01-2014, 06:33 AM   #8
xeveri
LQ Newbie
 
Registered: Mar 2014
Location: Shandong,China
Distribution: slackware,win7
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
As I mentioned, it could be a long process but this tells you where to start:
https://superuser.com/questions/1323...-an-http-login
Obviously you don't catch the point(still need to thank you ).You should at first connect to the wlan,then you can get the page you want.Next steps can be done in kde desktop.And my only problem is with what commands i can connect to it in command line.
 
Old 06-01-2014, 06:35 AM   #9
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,582

Rep: Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806
You should be able to connect in exactly the same way you connect to a conventional password-protected WLAN but you just won't be asked for a password.
 
Old 06-01-2014, 06:40 AM   #10
ndc85430
Member
 
Registered: Apr 2014
Distribution: Slackware
Posts: 77

Rep: Reputation: Disabled
Why can't you use iwconfig to connect to the network? You can also use Wicd on the command line - run wicd-curses.
 
Old 06-01-2014, 07:50 AM   #11
xeveri
LQ Newbie
 
Registered: Mar 2014
Location: Shandong,China
Distribution: slackware,win7
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
You should be able to connect in exactly the same way you connect to a conventional password-protected WLAN but you just won't be asked for a password.
i use wpa_supplicant to connect to wlan.

Code:
#ifconfig wlan0 up
#wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -B
 suceessfuly...
#wpa_cli
 >add_network
 ok 0
 >set_network 0 ssid "wlan_id"
 ok 
 >set_network 0 psk "passwd"
 ok
 >enable_network 0
 ok...
 >q
#dhclient wlan0 
#ping www.sina.com
....
it works well. I just delete the line containing psk and dhclient wlan0 do not work. I also tested #iwconfig wlan0 essid "CMCC". They both do not work.Because the web page was not response.I think the card doesn't connect to wlan.
I have two interfaces,wlan0,wlan1(usb wireless card) on my laptop. The usb card should be wlan1(i used it on this machine).
Don't know what's wrong. The diffrence of "IE" lines in two pactures above should be reason ?
 
Old 06-01-2014, 09:32 AM   #12
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
What in the blue blazes are you trying to do?

Your screen shots in post #6 show that wlan1 is seeing:
Cell 02 ESSID:"CMCC" with Encryption key:off
Cell 04 ESSID:"CMCC-AUTO" with Encryption key:on
both with Address: B0:75:D5:5C:D5:50
as well as
Cell 05 ESSID:"CMCC" with Encryption key:off
at Address: B0:75:D5:5C:E2:10

yet in post#11 you show connecting using wpa_supplicant using wlan0

You have not shown the contents of /etc/wpa_supplicant.conf

What interface do you want to use (wlan0 or wlan1)?
What connection do you want to use (CMCC or CMC-AUTO at which Address)?
Do you want a GUI solution or a command line solution?

If you have a Windows7 and Ubuntu solution, perhaps you could post those to inform the settings for a Slackware solution?

Last edited by allend; 06-01-2014 at 09:33 AM. Reason: added noparse tags
 
Old 06-01-2014, 11:02 AM   #13
xeveri
LQ Newbie
 
Registered: Mar 2014
Location: Shandong,China
Distribution: slackware,win7
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
What in the blue blazes are you trying to do?

If you have a Windows7 and Ubuntu solution, perhaps you could post those to inform the settings for a Slackware solution?
I want use wlan1,CMCC and command line solution. I used ubuntu befoe but now my slackware can not connect to wlan. This is why i use win7. My question is very clear in #8. You'd better see them carefully.And it is the real situation of CMCC** wlans in China! Like my android phone, for the wlan on campus you should also first connect to it,then in browser you can log in. How to connect to it in slackware really make me confused.
 
Old 06-01-2014, 11:19 AM   #14
ymf331
Member
 
Registered: May 2014
Posts: 38

Rep: Reputation: Disabled
did you consider trying dhcpcd to request ip? like:

iwconfig wlan1 essid CMCC
iwconfig wlan1 channel auto
ifconfig wlan1 up
dhcpcd wlan1

should work assuming the essid is right.

Last edited by ymf331; 06-01-2014 at 11:24 AM.
 
Old 06-01-2014, 07:54 PM   #15
xeveri
LQ Newbie
 
Registered: Mar 2014
Location: Shandong,China
Distribution: slackware,win7
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ymf331 View Post
did you consider trying dhcpcd to request ip? like:

iwconfig wlan1 essid CMCC
iwconfig wlan1 channel auto
ifconfig wlan1 up
dhcpcd wlan1

should work assuming the essid is right.
Yes, it really works!Thank you!

I am using my slackware14.1 now,but this website does not recognise it.

Last edited by xeveri; 06-01-2014 at 07:58 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect WLAN with encryption sisk Linux - Wireless Networking 1 09-07-2008 07:01 PM
Cant connect through WLAN in SuSE 10.2 riba43 Suse/Novell 10 07-04-2007 02:31 AM
Can connect or see my WLAN Yoda3114 Linux - Wireless Networking 0 04-10-2007 11:18 PM
can connect to wlan when WEP is off, but when WEP is off cannot join wlan teknoratti Fedora 1 09-01-2006 03:56 AM
unable to connect to internet with wlan Dooberdoink Linux - Wireless Networking 2 03-28-2005 08:22 AM


All times are GMT -5. The time now is 06:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration