LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-19-2009, 08:14 AM   #31
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86

Hello everybody !
Going back to work !

Switching to a more recent kernel (from 2.6.25.10 to 2.6.28) on both server and client, an error appears during rc.S execution on the client:

Remounting root device with read-write enabled.
mount.nfs: timeout set for (current date)
mount.nfs: text-based options 'nfsvers=3,rsize=8192,wsize=8192,tcp,addr=10.0.0.254'
mount.nfs: an incorrect mount option was specified

Attempt to remount root device as read-write failed! This is going to cause serious problems.
 
Old 10-15-2009, 04:37 AM   #32
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Quote:
Originally Posted by Linux.tar.gz View Post
Right ! Always helping around, Alien Bob, isn't it ?

I wrote this little script in order to ease the installation of a new kernel (same for host/guest) :

You need to create a /root/tmp, and and a /root/new-kernel-kit

Place two packages in /root/new-kernel-kit : portmap and glibc
These packages are needed for nfs mount.

You need to place a modified init (found in an initrd's root) in /root/new-kernel-kit : just add /sbin/rpc.portmap below the mdev -s line
This modification is needed for nfs mount too.

Of course, you have to modify some locations, according to your settings !!!

Install a new kernel and reboot, then :

emacs /root/new-kernel.sh

#!/bin/sh

rm -rf /root/tmp/*
#modify kernel version corrrectly
mkinitrd -c -F -k 2.6.25.8-smp
cp /boot/initrd.gz /root/tmp
cd /root/tmp
gzip -dc < ./initrd.gz | cpio -i
rm initrd.gz
cp ../new-kernel-kit/init ./
installpkg -root /root/tmp/ ../new-kernel-kit/*.tgz
find ./ | cpio -H newc -o > /tftpboot/slack/initrd.img

#modify kernel version corrrectly
rm -rf /srv/exports/slack/lib/modules/2.6.24.5-smp/*
cp -r /lib/modules/2.6.25.8-smp/ /srv/exports/slack/lib/modules/

cp /boot/vmlinuz /tftpboot/slack/
/srv/exports/slack/boot/
I continue the work on a Slack64-13.0, and i can't add .t?z anymore because the initrd won't boot, even if i remove locales, which takes approx. 300M.

So i copied manually rpc.portmap into it, but (of course) it don't work !!!

My initrd is built with busybox.

1- in my /etc/mkinitrd.conf, busybox is set to no. But my initrd uses it. Why ?
2- why the init in the initrd can't launch executables anymore ?
 
Old 10-15-2009, 04:50 AM   #33
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Found a trick !

In the initrd's init, #Switch to real partition
add the nolock option to the mount line.

Now i can't remount as rw. Looking at this. I will edit the post.


EDIT :##################
I edited /etc/rc.d/rc.S, and i added nolock at the / remount command, because adding "/etc/rc.d/rc.rpc start" just before changed nothing...
Now i can boot, but cat /proc/mount shows me that / was mounted with wrong nfs options (it should use tcp, nfsv4 etc...).

EDIT :##################
I don't understand why it can't remount as nfsv4 (worst, i have the message : bad mount option value specified: nfsvers=4), because when the boot finishes, i can mount the nfs4 export without any problem...

Last edited by Linux.tar.gz; 10-15-2009 at 08:11 AM.
 
Old 12-19-2012, 08:52 PM   #34
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Question

How can i modify the initrd in order to accept the rootdev with the tftp APPEND parameter ?

Do i simply have to remove the ROOTDEV=$(cat /rootdev) inside /init ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pxe boot "PXE-T01 file not found" ssharma_02 Linux - Networking 16 05-18-2011 03:21 PM
PXE boot a Live CD zael Linux - Networking 1 11-26-2008 07:23 AM
Unable to boot with PXE managed.service Linux - Enterprise 1 10-18-2005 11:28 AM
PXE no client boot ACID25 Linux - Networking 0 05-31-2005 05:36 AM
SuSE 9.1 PXE boot greentara Linux - Distributions 1 06-09-2004 02:16 AM


All times are GMT -5. The time now is 03:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration