LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-23-2007, 03:25 PM   #16
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53

Congrats. All your posts made a howto.
 
Old 05-26-2007, 06:06 AM   #17
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Well some questions stays unanswered (see above). For example, the / filesystem is mounted as umsdos, not as nfs... Strange, isn't it ?
And i wonder if it's possible to install a Slackware on a nfs root partition. I mean like we do with the install CD, but instead of selecting /dev/hda1 or /dev/sda8 as /, we select 192.168.231.2:/exports/pxeslack. Then the installer continues as usual.
 
Old 05-29-2007, 08:06 AM   #18
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
I just suceeded in booting on a non-zipslack. I installpkg'ed basic Slackware packages inside a directory.
Then i used the same procedure, except i had to create an /etc/fstab in the nfs filesystem. This is the content :

192.168.223.1:/exports/slack / nfs nfsvers=3,rsize=8192,wsize=8192,tcp
proc /proc proc defaults
ramfs /tmp ramfs defaults 0 0
ramfs /var/tmp ramfs 0 0
ramfs /var/run ramfs 0 0
ramfs /var/log ramfs 0 0
ramfs /var/lock ramfs 0 0
ramfs /var/state ramfs 0 0
ramfs /media ramfs 0 0



As you can see i changed the root path from /var/clients/default to /exports/slack

This is more like i wanted it to be and i thank everyone who helped.

Last edited by Linux.tar.gz; 05-29-2007 at 08:12 AM.
 
Old 05-31-2007, 06:46 AM   #19
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Alien Bob, i detected something that can be problematic with Slackware on nfs : ramfs /var/log ramfs 0 0
As /var/log is mounted in ram, we don't have access to /var/log/packages. So we can't perform upgrades because packages aren't listed in, and upgradepkg doesn't work with the -root switch.
Of course, we can't suppress the ram mount, because all clients station will write in the nfs /var/log.

I tried that but it didn't worked :

ramfs /var/log ramfs 0 0
192.168.223.1:/exports/slack/var/log/packages /var/log/packages nfs nfsvers=3,rsize=8192,wsize=8192,tcp
 
Old 05-31-2007, 07:47 AM   #20
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
It works with these lines added to /etc/rc.d/rc.local :

mkdir /var/log/packages
mount -t nfs 192.168.223.1:/exports/slack/var/log/packages /var/log/packages

Maybe there's a better workaround.
 
Old 05-31-2007, 11:17 AM   #21
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
I have some stability issues with X crashes. But as i test the client on a vmware player for now, don't consider this as definitive.
 
Old 05-31-2007, 11:40 AM   #22
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Quote:
Originally Posted by Linux.tar.gz
Alien Bob, i detected something that can be problematic with Slackware on nfs : ramfs /var/log ramfs 0 0
As /var/log is mounted in ram, we don't have access to /var/log/packages. So we can't perform upgrades because packages aren't listed in, and upgradepkg doesn't work with the -root switch.
Of course, we can't suppress the ram mount, because all clients station will write in the nfs /var/log.

I tried that but it didn't worked :

ramfs /var/log ramfs 0 0
192.168.223.1:/exports/slack/var/log/packages /var/log/packages nfs nfsvers=3,rsize=8192,wsize=8192,tcp
You should be aware that with this kind of setup, you would not want any user to start using upgradepkg when running Slackware off the NFS mount.
For one, you should give the root account to no one but yourself. Second, any change you make to the NFS content will be available immediately on every computer that runs this PXE-booted Slackware.

So, it would be best to upgrade packages on the NFS server, using the command
Code:
chroot <your_NFS_rootdirectory>
upgradepkg <your packages>
exit
Cheers, Eric
 
Old 06-01-2007, 11:03 AM   #23
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Roger that !
But in some case, i will have to log as root on clients (ie.: nvidia drivers install)

Btw i just booted a true PC with a PXE capable network card, and it works (of course ).
 
Old 06-01-2007, 12:53 PM   #24
lord-fu
Member
 
Registered: Apr 2005
Location: Ohio
Distribution: Slackware && freeBSD
Posts: 676

Rep: Reputation: 30
This is really cool, I just got a laptop(for free!) that has a bad hard disk, but it can pxe boot.. looks like I have something to do over the weekend :]
Thanks for ALL the info.
 
Old 06-27-2008, 12:50 PM   #25
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
(time : tic tac tic tac tic tac tic tac tic tac ...)

One year has past since i did all this walkthrough.
And i'm afraid things has changed and i can't boot on nfs anymore !

All the tftp + dhcp is really easy to enable.

Now, making a working initrd is a pain !

I wonder why there's a pxe installer, but no pxe loader in the 12.X Slack !

Let's go back to work ...
 
Old 06-27-2008, 01:50 PM   #26
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
I did the same errors about kernel config :
NFS must be build INSIDE the kernel, in order to get the nfsroot option available.
And IP kernel level autoconfiguration for dhcp and bootp must be enabled (in networking).

I got ip, but i can't mount nfs.

rpcbind: server not responding, timed out
Now RPC: failed to contact local rpcbind server ...

Last edited by Linux.tar.gz; 06-27-2008 at 01:54 PM.
 
Old 06-30-2008, 05:08 AM   #27
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Seems that there's no rpc on the client.
Did someone knows how to install it in the initrd ?
 
Old 06-30-2008, 08:35 AM   #28
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Just copy the relevant files and libraries to your initrd. Hint: look at /sbin/rpc.portmap

Eric
 
Old 06-30-2008, 09:51 AM   #29
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
Right ! Always helping around, Alien Bob, isn't it ?

I wrote this little script in order to ease the installation of a new kernel (same for host/guest) :

You need to create a /root/tmp, and and a /root/new-kernel-kit

Place two packages in /root/new-kernel-kit : portmap and glibc
These packages are needed for nfs mount.

You need to place a modified init (found in an initrd's root) in /root/new-kernel-kit : just add /sbin/rpc.portmap below the mdev -s line
This modification is needed for nfs mount too.

Of course, you have to modify some locations, according to your settings !!!

Install a new kernel and reboot, then :

emacs /root/new-kernel.sh

#!/bin/sh

rm -rf /root/tmp/*
#modify kernel version corrrectly
mkinitrd -c -F -k 2.6.25.8-smp
cp /boot/initrd.gz /root/tmp
cd /root/tmp
gzip -dc < ./initrd.gz | cpio -i
rm initrd.gz
cp ../new-kernel-kit/init ./
installpkg -root /root/tmp/ ../new-kernel-kit/*.tgz
find ./ | cpio -H newc -o > /tftpboot/slack/initrd.img

#modify kernel version corrrectly
rm -rf /srv/exports/slack/lib/modules/2.6.24.5-smp/*
cp -r /lib/modules/2.6.25.8-smp/ /srv/exports/slack/lib/modules/

cp /boot/vmlinuz /tftpboot/slack/
/srv/exports/slack/boot/

Last edited by Linux.tar.gz; 06-30-2008 at 10:40 AM.
 
Old 07-01-2008, 09:47 AM   #30
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
could not open default font fixed

This is what i got when i try to launch X.

I'm searching around, but if you have any idea...

EDIT : ------------------------------------------------------------------

Solved with :

mkfontdir /usr/share/fonts/*
mkfontscale /usr/share/fonts/*

Last edited by Linux.tar.gz; 07-01-2008 at 09:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pxe boot "PXE-T01 file not found" ssharma_02 Linux - Networking 16 05-18-2011 04:21 PM
PXE boot a Live CD zael Linux - Networking 1 11-26-2008 08:23 AM
Unable to boot with PXE managed.service Linux - Enterprise 1 10-18-2005 12:28 PM
PXE no client boot ACID25 Linux - Networking 0 05-31-2005 06:36 AM
SuSE 9.1 PXE boot greentara Linux - Distributions 1 06-09-2004 03:16 AM


All times are GMT -5. The time now is 04:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration