LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2006, 05:39 AM   #1
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Rep: Reputation: 30
How to autologin on console (no kdm) and how to start with different resolution?


I have two questions.

First, how can i make slack autologin on console. Some distros use mingetty but i did not found anything about this on slackware.

I try to put vga=788 on lilo but it ALWAYS ask me to choose resolution. I really don't now what i can do. I always choose 9 (because is the bigger) but i want to make it automatic. How can i do this?
 
Old 03-20-2006, 06:10 AM   #2
p0f
Member
 
Registered: Feb 2006
Distribution: slackware-current
Posts: 36

Rep: Reputation: 15
Quote:
Originally Posted by stormrider_may
I have two questions.

First, how can i make slack autologin on console. Some distros use mingetty but i did not found anything about this on slackware.

I try to put vga=788 on lilo but it ALWAYS ask me to choose resolution. I really don't now what i can do. I always choose 9 (because is the bigger) but i want to make it automatic. How can i do this?

Hi

try vga=773 in your /etc/lilo.conf


autologin; you need to edit /etc/inittab, change id:3:initdefault: to id:4:initdefault:

Regards
 
Old 03-20-2006, 06:28 AM   #3
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
Assume you're using LiLo.

You may want to check for a line in /etc/lilo.conf like "vga = ask" (and remove it). If you're booting using the standard framebuffer console, are you sure your card can support 64k colours at 800*600 (what 788 specifies). Better to try vga = 771 (800*600 @ 256 cols.) or "vga = normal" for the most basic console.

If you follow p0f's recommendation, you will be taken to an X login prompt (which requires you have X11 installed and configured), not a console, nor an "auto-login". Just a warning.

Last edited by odevans; 03-20-2006 at 06:30 AM.
 
Old 03-20-2006, 06:29 AM   #4
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Hi,

even with vga=773 it asks me to choose the resolution.

and changing to 4 on inittab makes slack boot in graphical mode, but i donīt have graphical mode. I only use console.
 
Old 03-20-2006, 06:42 AM   #5
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Thatīs what happen when i try to put vga=773 or 771

http://nerfando.no-ip.org/fernando/ftp/vga.jpg
 
Old 03-20-2006, 07:20 AM   #6
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
Stormrider, do you have a space between vga, = and 771? eg "vga = 771" as opposed to "vga=771" (not sure if it matters, but LiLo can often be sensitive to spaces).
 
Old 03-20-2006, 09:32 AM   #7
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
tried with and without spaces but did not worked.
 
Old 03-21-2006, 05:01 AM   #8
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
anyone????
 
Old 03-21-2006, 06:56 AM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
Qingy : http://qingy.sourceforge.net can do autologin as well as a lot more (like, locking your console when you're idle).
I have a Slackware package at http://www.slackware.com/~alien/slackbuilds/qingy/ and I just saw there is a newer release out, which I am going to build right now.

Btw> Qingy needs the directfb package, also found on my site. DirectFB might require a little tweaking of /etc/fb.modes.
This is what I put in my /etc/fb.modes as the first entry:
Code:
# My output of "fbset" pasted as first entry:
# In "/etc/lilo.conf" I have this as well:
# append="video=vesa:ywrap,mtrr"
# # VESA framebuffer console @ 1024x768x256
# vga = 791
mode "1024x768-76"
    # D: 78.653 MHz, H: 59.949 kHz, V: 75.694 Hz
    geometry 1024 768 1024 768 16
    timings 12714 128 32 16 4 128 4
    rgba 5/11,6/5,5/0,0/0
endmode
Definitely worth to try out.

Eric
 
Old 03-21-2006, 11:56 PM   #10
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
This may be a silly question, but are you re-running lilo after you make changes to the conf so the changes stick?
 
Old 03-28-2006, 05:34 AM   #11
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
yes i was running. It seens to be a bug with that old Trident TGUI440 video card. I changed the video card and everything worked. Iīll install qincy. It seens to be really cool

Alien Bob

I have slack 11.1, just installing your package should work or i have to install an library or something like that? I could now make it work only installing your package.

Last edited by stormrider_may; 03-28-2006 at 06:15 AM.
 
Old 03-28-2006, 08:00 AM   #12
MariuszK
LQ Newbie
 
Registered: Jan 2006
Location: Brooklyn, NY
Distribution: Slackware 12.0
Posts: 18

Rep: Reputation: 0
About autologin...

I've read about autologin on my national slackware forum, so I will try to suggest some solutions.

1. Modify inittab so there will be such line:
c3:1235:respawn:/sbin/mingetty --noclear --autologin stormrider tty3
and remove first "x" from your /etc/passwd in stormrider user line

^^^ Unsafe, because you will have no password for user stormrider

2. Or check /etc/login.defs where you can set up logging without password.

3. I haven't tried any of these "tricks"
 
Old 03-28-2006, 08:17 AM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
Quote:
Originally Posted by stormrider_may
I have slack 11.1, just installing your package should work or i have to install an library or something like that? I could now make it work only installing your package.
You did install the directfb package too, as I indicated in my post?
You will also have to read the manual to see what you have to change in /etc/inittab.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't autologin with kdm because it requires password mcgoon Linux - General 3 03-20-2006 04:42 PM
Setting DSL for autologin and forcing a better resolution on console stormrider_may DamnSmallLinux 4 02-06-2006 03:42 AM
autologin to console? the_woelf Slackware 2 07-04-2004 04:01 AM
KDE wont start with autologin petermcp Linux - Software 5 07-03-2004 07:19 AM
From kdm to Console SilenceX Linux - Newbie 1 09-02-2003 11:52 AM


All times are GMT -5. The time now is 07:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration