LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-28-2012, 01:11 PM   #1
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 349

Rep: Reputation: 28
How to *completely* disable all power saving features?


Slackware 14 64 bit, xfce.

How would I go about disabling *ALL* power saving features? I need to ensure that the screen never blanks, and the system never tries to suspend or hibernate. I potentially access the box remotely 24/7, and it needs to be available at all times.

In Power Manager, I have On AC setting set to Never put computer to sleep. Monitor is set to never put display to sleep, and never switch off display. I have screensaver disabled. In rc.local I have:

setterm -blank off
setterm -powerdown 0

(cause it annoys me when the terminal blanks)

And yet - if I leave it for a while, the screen blanks. If I leave it long enough, it tries to go into some sort of powersave mode, the screen blanks, I can't ssh into it, and it does not respond.

What am I missing? Is there yet some setting somewhere that needs to be set?
 
Old 12-28-2012, 02:52 PM   #2
slouchfuzz
LQ Newbie
 
Registered: May 2009
Distribution: Slackware, Mythbuntu
Posts: 13

Rep: Reputation: 5
Have you checked if there some Power Management settings in your BIOS maybe? I've noticed a number of newer, 'Green' PCs with relatively more intrusive power controls buried in a BIOS menu.
 
Old 12-28-2012, 03:14 PM   #3
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 349

Original Poster
Rep: Reputation: 28
Quote:
Originally Posted by slouchfuzz View Post
Have you checked if there some Power Management settings in your BIOS maybe? I've noticed a number of newer, 'Green' PCs with relatively more intrusive power controls buried in a BIOS menu.
It's a Dell, an older one - but I'll check the bios and see if something there is over riding the OS settings (can it do that?).
 
Old 12-28-2012, 03:22 PM   #4
Beelzebud
Member
 
Registered: Oct 2010
Distribution: Arch & Slackware
Posts: 95

Rep: Reputation: 22
For the monitor try putting this in the xorg.conf under the "ServerLayout" section.

Code:
    Option	   "BlankTime" "0"
    Option	   "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"

Last edited by Beelzebud; 12-28-2012 at 03:23 PM.
 
Old 01-03-2013, 03:48 PM   #5
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 349

Original Poster
Rep: Reputation: 28
So I checked the bios - this is an older dell computer and there is nothing in the bios even remotely related to power saving features.

In rc.local I have:

setterm -blank off
setterm -powerdown 0
setterm -powersave off

In xorg.conf I have:

Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"

In the Power Manager applet:

There is a checkbox for "Monitor power management control". Doesn't matter if this is checked or not.
I have "Put the computer to sleep when inactive.." set to Never.
The two sliders for Minotor sleep and off are set to Never.
Lock screen when going for suspend/hibernate is deselected (I don't hibernate or suspend).

Screen saver is disabled.

And yet after a while, it still turns the monitors off. Fortunately it doesn't try to suspend or hibernate, it just blanks the monitors. I had one person tell me that when they tried to access box, it was locked as if xflock4 had been run, but I haven't seen that for myself.
 
Old 01-04-2013, 03:58 AM   #6
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Rep: Reputation: Disabled
in /etc/rc.d/rc.M comment that line /bin/setterm -blank 15 -powersave powerdown -powerdown 60
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: PowerTOP 2.1 Presents New Power-Saving Features LXer Syndicated Linux News 0 08-21-2012 12:00 PM
Disable power saving? Matt42 *BSD 2 09-29-2008 06:20 PM
Power-saving power extension cables? (UK) neocookie General 3 03-28-2007 02:53 PM
Enabling power save/power management/cpu freq scaling features for a Debian system zero79 Debian 0 12-19-2004 01:17 PM
How to disable firewall completely zyzyis Linux - Newbie 2 09-21-2004 08:23 AM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration