LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How to *completely* disable all power saving features? (http://www.linuxquestions.org/questions/slackware-14/how-to-%2Acompletely%2A-disable-all-power-saving-features-4175443277/)

Ook 12-28-2012 01:11 PM

How to *completely* disable all power saving features?
 
Slackware 14 64 bit, xfce.

How would I go about disabling *ALL* power saving features? I need to ensure that the screen never blanks, and the system never tries to suspend or hibernate. I potentially access the box remotely 24/7, and it needs to be available at all times.

In Power Manager, I have On AC setting set to Never put computer to sleep. Monitor is set to never put display to sleep, and never switch off display. I have screensaver disabled. In rc.local I have:

setterm -blank off
setterm -powerdown 0

(cause it annoys me when the terminal blanks)

And yet - if I leave it for a while, the screen blanks. If I leave it long enough, it tries to go into some sort of powersave mode, the screen blanks, I can't ssh into it, and it does not respond.

What am I missing? Is there yet some setting somewhere that needs to be set?

slouchfuzz 12-28-2012 02:52 PM

Have you checked if there some Power Management settings in your BIOS maybe? I've noticed a number of newer, 'Green' PCs with relatively more intrusive power controls buried in a BIOS menu.

Ook 12-28-2012 03:14 PM

Quote:

Originally Posted by slouchfuzz (Post 4858655)
Have you checked if there some Power Management settings in your BIOS maybe? I've noticed a number of newer, 'Green' PCs with relatively more intrusive power controls buried in a BIOS menu.

It's a Dell, an older one - but I'll check the bios and see if something there is over riding the OS settings (can it do that?).

Beelzebud 12-28-2012 03:22 PM

For the monitor try putting this in the xorg.conf under the "ServerLayout" section.

Code:

    Option          "BlankTime" "0"
    Option          "StandbyTime" "0"
    Option        "SuspendTime" "0"
    Option        "OffTime" "0"


Ook 01-03-2013 03:48 PM

So I checked the bios - this is an older dell computer and there is nothing in the bios even remotely related to power saving features.

In rc.local I have:

setterm -blank off
setterm -powerdown 0
setterm -powersave off

In xorg.conf I have:

Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"

In the Power Manager applet:

There is a checkbox for "Monitor power management control". Doesn't matter if this is checked or not.
I have "Put the computer to sleep when inactive.." set to Never.
The two sliders for Minotor sleep and off are set to Never.
Lock screen when going for suspend/hibernate is deselected (I don't hibernate or suspend).

Screen saver is disabled.

And yet after a while, it still turns the monitors off. Fortunately it doesn't try to suspend or hibernate, it just blanks the monitors. I had one person tell me that when they tried to access box, it was locked as if xflock4 had been run, but I haven't seen that for myself.

tuxbg 01-04-2013 03:58 AM

in /etc/rc.d/rc.M comment that line /bin/setterm -blank 15 -powersave powerdown -powerdown 60


All times are GMT -5. The time now is 01:27 PM.