LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-24-2014, 06:39 AM   #1
freakTux
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 26

Rep: Reputation: Disabled
How KDE Network manager manage the connection at boot time?


Hi all!I have slackware64 14.1 and I'm tryng KDE after a long time with fluxbox!
In KDE I have configured the Network manager for my internet connection...Today I decided to configure a static IP for my wireless interface (just for testing), so I have opened /etc/rc.d/rc.init1.conf but all the settings of my wlan0 are commented.
So, I am wandering how the network manager manage the connection at boot time?
There is another configuration file that I don't know?Please clarify my doubts...
 
Old 01-24-2014, 06:59 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
well when you use network manager you make the /etc/rc.d/rc.neworkmanager executable. if you have your computer set up to dhcpcd with rc.init1 you need to make that non-executable. you really don't use both because you will run into problems.
http://docs.slackware.com/slackware:beginners_guide scroll down to the bottom here ok and you will see choose one.
and if you do use the rc.init1 and for all make sure the user has net device in users groups.
now when that user starts or logs into the desktop it will run the connection he has set up.
remember if you connect as root first then the connection is owned by root.

Last edited by Drakeo; 01-24-2014 at 07:03 AM.
 
Old 01-24-2014, 08:10 AM   #3
freakTux
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Drakeo View Post
well when you use network manager you make the /etc/rc.d/rc.neworkmanager executable. if you have your computer set up to dhcpcd with rc.init1 you need to make that non-executable. you really don't use both because you will run into problems.
http://docs.slackware.com/slackware:beginners_guide scroll down to the bottom here ok and you will see choose one.
and if you do use the rc.init1 and for all make sure the user has net device in users groups.
now when that user starts or logs into the desktop it will run the connection he has set up.
remember if you connect as root first then the connection is owned by root.
...It seems like I have both rc.inet1 and rc.networkmanager executable...and even rc.wicd is executable...But this should be the default configuration, because I haven't change it after installing slackware 14.1...Now I am a little bit confused...
I would know how the system set up the connection at boot time...my system execute both rc.inet1, rc.networkmanager and rc.wicd, right?...it seems strange...and then, how networkmanager stores the wifi pwd and essid?I have the /etc/wpa_supplicant.conf that has these information...but I can remember I create that file with wpa_passphrase manually...God, when I was with fluxbox I used to execute wpa_supplicant manually for the connection...now everything is so automatic and this confuse me...
 
Old 01-24-2014, 08:56 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,681

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
Well, I think that the beginners guide is slightly outdated as nowadays NetworkManager can handle wifi connections as well as wired ones.

Just run netconfig as root, choose 'loopback', input your hostname and domain name, confirm and you're all set.

Then, if you don't see the NetworkManager widget, just run as regular user "nm-applet" and it will show.

BTW, this works under Fluxbox as well, I'm using it right now
 
Old 01-24-2014, 09:25 AM   #5
freakTux
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Well, I think that the beginners guide is slightly outdated as nowadays NetworkManager can handle wifi connections as well as wired ones.

Just run netconfig as root, choose 'loopback', input your hostname and domain name, confirm and you're all set.

Then, if you don't see the NetworkManager widget, just run as regular user "nm-applet" and it will show.

BTW, this works under Fluxbox as well, I'm using it right now
Yes...but my question is not about how to make connection work, but is about what files are involved when the connection is managed from NetworkManager...In what file are stored information about the pwd and essid?What file I have to edit if I would to set things like dhcp or other wireless card related options?
Anyway, thanks for the interesting suggestions
 
Old 01-25-2014, 11:19 AM   #6
lems
Member
 
Registered: May 2004
Distribution: Slackware x86/x86_64/ARM, NetBSD
Posts: 165

Rep: Reputation: 57
On my laptop it's /etc/NetworkManager/system-connections, then there is a filed named after my router's SSID. No idea if editing it works.

Last edited by lems; 01-25-2014 at 11:20 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Super boot manager - Great tool to Manage Burg, Grub2 and Plymouth in Ubuntu LXer Syndicated Linux News 0 05-24-2011 08:20 AM
Network Manager Says There's A Network Connection When I Can't Ping Anything Bradj47 Linux - Laptop and Netbook 3 06-11-2010 08:25 AM
LXer: Debian Lenny: Letting a network-time server manage your clock LXer Syndicated Linux News 0 12-31-2009 04:00 AM
wireless connection problems & now lost lan connection & network manager wont work Rainbowserpant Linux - Wireless Networking 2 09-02-2009 05:00 AM
KDE Network Manager doesn't load on boot kbgraveson Suse/Novell 1 03-22-2007 04:55 AM


All times are GMT -5. The time now is 05:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration