LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-14-2006, 05:26 PM   #1
mixtr
Member
 
Registered: Jul 2004
Location: Ottawa
Distribution: Arch, OpenBSD
Posts: 123

Rep: Reputation: 17
Thumbs up How I solved the wireless 'ipw2200 kill switch' problem


I had this kill switch problem with the ipw2200 driver on my Dell laptop. The kill switch is hardware so no software can change it.
Searching the net I found:
- Doing 'echo > 0 rf_kill', doesn't work.
- I read that I should boot in Windows turn the wireless card off and then boot linux.
- Use a software, which doesn't work!

But here is what I found accidently...

Pressing Fn + F2 is suppose to turn the wireless card on/off but it wouldn't work on linux. I set conky to tail dmesg every minutes and I got an error message saying to use setkeycodes e008. To stop the annoyance I put setkeycodes e008 172 in my rc.local and just like that the wireless kill switch works. Pressing Fn + F2 change /sys/bus/pci/drivers/ipw2200/*/rf_kill to 0 or 2.
I don't know why but I have a few guesses. What is important now is that the wireless card works, Fn + F2 works and I'm a happy camper

Info:
Slackware-current
ipw2200 driver from kernel 2.6.17
firmware v3.0 from ipw2200.sourceforge.net
 
Old 09-15-2006, 06:26 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
I have one of those wireless on/off keys. And also a screen brightness one. They work fine right out of the box in suse, but never work under other distros. This is probably the fix, but I find it annoying the other distro's don't have this enabled by default.
 
Old 11-20-2006, 12:21 PM   #3
elektronaut
LQ Newbie
 
Registered: Nov 2006
Distribution: Ubuntu Edgy
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by mixtr
Pressing Fn + F2 is suppose to turn the wireless card on/off but it wouldn't work on linux. I set conky to tail dmesg every minutes and I got an error message saying to use setkeycodes e008. To stop the annoyance I put setkeycodes e008 172 in my rc.local and just like that the wireless kill switch works. Pressing Fn + F2 change /sys/bus/pci/drivers/ipw2200/*/rf_kill to 0 or 2.
Being still some kind of a newbie, I could need some additional information on this. I could enable/disable my wireless card in Ubuntu Edgy with
Code:
echo 0 > /sys/bus/pci/drivers/ipw3945/*/rf_kill
respectively
echo 1 > /sys/bus/pci/drivers/ipw3945/*/rf_kill
and I'm able to add a setkeycode command in rc.local. But which value should I assign it? I don't want to overwrite some other key. I'd like to use the special wifi switch at the front of my laptop, it's got keycode e055. How did you know that you have to use '172'? And how can I assign those two commands to one switch?
 
Old 11-20-2006, 05:00 PM   #4
mixtr
Member
 
Registered: Jul 2004
Location: Ottawa
Distribution: Arch, OpenBSD
Posts: 123

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by elektronaut
Being still some kind of a newbie, I could need some additional information on this. I could enable/disable my wireless card in Ubuntu Edgy with
Code:
echo 0 > /sys/bus/pci/drivers/ipw3945/*/rf_kill
respectively
echo 1 > /sys/bus/pci/drivers/ipw3945/*/rf_kill
If you can put 1 in the rf_kill file it means your kill switch is software based, see http://ipw3945.sourceforge.net/README.ipw3945 for more detail on your card

Quote:
and I'm able to add a setkeycode command in rc.local. But which value should I assign it? I don't want to overwrite some other key. I'd like to use the special wifi switch at the front of my laptop, it's got keycode e055. How did you know that you have to use '172'? And how can I assign those two commands to one switch?
You can set any number to your key, the general rules is translate your keycode from hex to dec and add 128 [055 = 85 + 128 = 213]. If you want to know if that number is assign, do dumpkeys | grep 213. Or you can just do dumpkeys and take an available number for setkeycode.
 
Old 11-21-2006, 10:41 AM   #5
elektronaut
LQ Newbie
 
Registered: Nov 2006
Distribution: Ubuntu Edgy
Posts: 12

Rep: Reputation: 0
Thank you for answering, mixtr! I have another thread going on about this at ubuntuforums as I didn't want to get OT here. I would be glad if you could also give me some advice over there. Unfortunately, being an new member, I'm not allowed to post the URL to the thread. I will send it to you via PN, may be you can add it here for future solution seekers.

[EDIT:] The problem is solved, hopefully mixtr will paste the link to the thread here. You can read there how to activate your card if you have a software switch using a little script.

[EDIT2]: As I can post URL's now, comes the link to the thread.

Last edited by elektronaut; 12-03-2006 at 05:30 AM.
 
  


Reply

Tags
ipw3945, wifi, wireless, wlan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
acer 4100lmi wireless kill switch problem zalis Linux - Laptop and Netbook 18 11-21-2007 04:57 AM
ipw2200, wireless extension driver problem kellinjar Linux - General 2 07-10-2006 10:25 AM
Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless kmierle Linux - Laptop and Netbook 2 09-22-2005 11:11 PM
Problem with wep encryption on ipw2200 intel wireless card. dmh11686 Linux - Wireless Networking 1 03-20-2005 08:47 AM
problem installing wireless drivers ipw2200 avimd Linux - Wireless Networking 1 10-18-2004 08:00 AM


All times are GMT -5. The time now is 08:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration