LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-27-2011, 11:36 AM   #1
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 48
How I installed LAMP & then Drupal 7.7 on my Slackware 13.37 system.


Moderator: Please move or delete this post if it is inappropriate for this forum.

NB: I am an inexperienced Slackware user and I know even less about Apache, Mysql & php.

I finally was able to install Drupal 7.7 on my Slackware 13.37 PC. Note: When I installed Slackware, I did a full, complete install.

I was unable to get any where when I tried to install XAMPP from www.apachefriends.org but that is probably because I don’t know what I am doing – a real newbie to linux etc.

So, I followed a link to manually set up LAMP on my PC and then another link to install Drupal 7.7.

I did have to do things a little differently at certain points.

Here is how I did it:

To manually install LAMP, I followed this link: http://www.linuxquestions.org/questi...12-2-a-693708/... to the point where it says: “#### install phpMyAdmin 3.1.1”.

At this point, I went to Slackbuilds.org and downloaded and installed ‘phpmyadmin’.

I did not do any of the steps following ‘#### install phpMyAdmin 3.1.1’ - I do not know if I should have or not. I just assumed that using the Slackbuild took care of all that was required – and, I could be very wrong.

Next, I followed this link to install Drupal 7.7:
http://www.basicconfig.com/linuxsoft...linux-tutorial

At the point where the tutorial say to do this:

root@slackware:/var/www/htdocs/testdrupal# mv sites/default/default.settings.php sites/default/settings.php
I had to use the linux copy command (cp) instead of mv. So, I did:

root@slackware:/var/www/htdocs/testdrupal# cp sites/default/default.settings.php sites/default/settings.php
It seems that the Drupal 7.7 installer requires that the original ‘default.settings.php’ file to exist as well.

At the point where the tutotial says to add the following lines to the httpd.conf file:
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
I got errors, so I removed the lines, i.e. I did not add them to the httpd.conf file.

I then followed the rest of the tutorial and was successful in installing Drupal 7.7.

I cannot attest to the 'correctness' of what I did as I simply do not know.

HTH,

Last edited by Robert.Thompson; 08-27-2011 at 03:26 PM. Reason: Fixed links
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 08-27-2011, 12:59 PM   #2
Hannes Worst
Member
 
Registered: Jul 2008
Location: Tilburg, The Netherlands
Distribution: Antix, Slackware, NetBSD
Posts: 90

Rep: Reputation: 37
I am glad you've got it working. Congratulations!
 
Old 08-27-2011, 03:29 PM   #3
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Fixed the links for LAMP & Drupal tutorials.
 
Old 08-28-2011, 02:22 AM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Here is my simple routine for setting up the LAMP system on a full install of Slackware (assuming 13.37 or current)

As root of course :-
1. Setup mysql

# mysql_install_db --user=mysql
# cp /etc/my-small.cnf /etc/my.cnf
# chmod a+x /etc/rc.d/rc.mysqld
# /etc/rc.d/rc.mysqld start
# mysqladmin -u root password 'new-password'

2. Setup apache
# chmod a+x /etc/rc.d/rc.httpd
# editor-of-choice /etc/httpd/httpd.conf
-> Uncomment this line "#Include /etc/httpd/mod_php.conf"
-> Uncomment & configure this line "#ServerName www.example.com:80"
-> Append index.php to this line "DirectoryIndex index.html"
# /etc/rc.d/rc.httpd start

3. For drupal installation
# mv /var/www/htdocs /var/www/htdocs-dist
# mkdir /var/www/htdocs
-> extract drupal to /var/www/htdocs
# chown apache.apache -R /var/www/htdocs
# mysqladmin -p create drupal-database-name
-> Point web browser at http://localhost/install.php
-> Follow drupal install instructions in web browser

NB Items in red need user input for what they should be.

Last edited by wildwizard; 08-28-2011 at 02:24 AM.
 
4 members found this post helpful.
Old 08-28-2011, 03:16 AM   #5
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Extra features enableing drupals .htaccess file

edit /etc/httpd/httpd.conf

and go to line 216 and change
AllowOverride None
to
AllowOverride All
 
1 members found this post helpful.
Old 08-28-2011, 07:29 AM   #6
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by wildwizard View Post
Extra features enableing drupals .htaccess file

edit /etc/httpd/httpd.conf

and go to line 216 and change
AllowOverride None
to
AllowOverride All
wildwizard, thanks for the posts!
 
Old 08-28-2011, 09:22 AM   #7
SeRi@lDiE
Member
 
Registered: Jun 2006
Location: /dev/null
Distribution: Slackware 13.1, Slackware 13.37, aptosid, rhel
Posts: 538
Blog Entries: 7

Rep: Reputation: 54
Robert,

I would harden as much as I can a LAMP setup. If you dont know what you are doing they can be very burnable to exploits and if you have it facing to the public it wont be long before you get hacked.

Please finish the phpmyadmin install by going to http://localhost/phpmyadmin given that you have phpmyadmin in your web srv root dir. If you leave it without finishing the setup you will get hack 100% guaranteed. disable dir listing, I would be careful with AllowOverride, understand your options and what you are doing with your srv... learn how to apply patches and keep up with them specially in php/drupal/mysql.

My 2 centavos:

Do not become like most of the people out there I called them robots because all they do is just copy and paste what they read in a forum, blog, tutorial and they do not understand what they are doing all they care and know is that it worked.
Please take the time and learn.

Dont become a victim.

Take Care.
 
3 members found this post helpful.
Old 08-28-2011, 07:09 PM   #8
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
@ SeRi@lDiE,

++
Good advice =)
 
Old 08-29-2011, 11:59 AM   #9
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by SeRi@lDiE View Post
Robert,

I would harden as much as I can a LAMP setup. If you dont know what you are doing they can be very burnable to exploits and if you have it facing to the public it wont be long before you get hacked.

Please finish the phpmyadmin install by going to http://localhost/phpmyadmin given that you have phpmyadmin in your web srv root dir. If you leave it without finishing the setup you will get hack 100% guaranteed. disable dir listing, I would be careful with AllowOverride, understand your options and what you are doing with your srv... learn how to apply patches and keep up with them specially in php/drupal/mysql.

My 2 centavos:

Do not become like most of the people out there I called them robots because all they do is just copy and paste what they read in a forum, blog, tutorial and they do not understand what they are doing all they care and know is that it worked.
Please take the time and learn.

Dont become a victim.

Take Care.
Hi SeRi@lDiE:

In this case, I am most certainly a 'robot'.

I do not see a option to 'disable dir listing' in the phpmyadmin menu system - is there a different terminology?

Thanks,

(a victim in-waiting)

Last edited by Robert.Thompson; 08-29-2011 at 12:02 PM.
 
Old 08-29-2011, 12:37 PM   #10
SeRi@lDiE
Member
 
Registered: Jun 2006
Location: /dev/null
Distribution: Slackware 13.1, Slackware 13.37, aptosid, rhel
Posts: 538
Blog Entries: 7

Rep: Reputation: 54
Robert,

To disable dir listing you have to edit your httpd.conf

http://httpd.apache.org/docs/1.3/misc/FAQ.html#indexes

Code:
How do I turn automatic directory listings on or off?
If a client requests a URL that designates a directory and the directory does not contain a filename that matches the DirectoryIndex directive, then mod_autoindex can be configured to present a listing of the directory contents.

To turn on automatic directory indexing, find the Options directive that applies to the directory and add the Indexes keyword. For example:

<Directory /path/to/directory>
   Options +Indexes
</Directory>
To turn off automatic directory indexing, remove the Indexes keyword from the appropriate Options line. To turn off directory listing for a particular subdirectory, you can use Options -Indexes. For example:

<Directory /path/to/directory>
   Options -Indexes
</Directory>
By the way phpmyadmin is really not need it unless you need a gui/web page interface to manage your mysql instances or create new DB's etc....
phpmyadmin by no means is used to work or configure apache.
Just thought I let you know.

Last edited by SeRi@lDiE; 08-29-2011 at 12:52 PM.
 
Old 08-30-2011, 08:52 AM   #11
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by SeRi@lDiE View Post
Robert,

To disable dir listing you have to edit your httpd.conf

http://httpd.apache.org/docs/1.3/misc/FAQ.html#indexes

Code:
How do I turn automatic directory listings on or off?
If a client requests a URL that designates a directory and the directory does not contain a filename that matches the DirectoryIndex directive, then mod_autoindex can be configured to present a listing of the directory contents.

To turn on automatic directory indexing, find the Options directive that applies to the directory and add the Indexes keyword. For example:

<Directory /path/to/directory>
   Options +Indexes
</Directory>
To turn off automatic directory indexing, remove the Indexes keyword from the appropriate Options line. To turn off directory listing for a particular subdirectory, you can use Options -Indexes. For example:

<Directory /path/to/directory>
   Options -Indexes
</Directory>
By the way phpmyadmin is really not need it unless you need a gui/web page interface to manage your mysql instances or create new DB's etc....
phpmyadmin by no means is used to work or configure apache.
Just thought I let you know.
Hi SeRi@lDiE:

My httpd.conf does not contain the lines that you have indicated, i.e. there is neither 'Options -Indexes' nor 'Options +Indexes'.

Should I just add 'Options -Indexes' to the area started by:
DocumentRoot "/srv/httpd/htdocs"

or should it be placed somewhere else?

Thanks,
 
Old 08-30-2011, 09:23 AM   #12
SeRi@lDiE
Member
 
Registered: Jun 2006
Location: /dev/null
Distribution: Slackware 13.1, Slackware 13.37, aptosid, rhel
Posts: 538
Blog Entries: 7

Rep: Reputation: 54
Robert,

All httpd.conf files have it by default.

root@oscuridad:~# cat /etc/httpd/httpd.conf | grep Indexes
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
Options -Indexes FollowSymLinks
root@oscuridad:~#

Just do a search on your httpd.conf file for "Indexes"
 
Old 08-30-2011, 09:36 AM   #13
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by SeRi@lDiE View Post
Robert,

All httpd.conf files have it by default.

root@oscuridad:~# cat /etc/httpd/httpd.conf | grep Indexes
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
Options -Indexes FollowSymLinks
root@oscuridad:~#

Just do a search on your httpd.conf file for "Indexes"
Sorry SeRi@lDiE, I when I saw 'FollowSymLinks' on the same line, I thought that I was not in the correct place.

I added '-' to the word 'Indexes.

Thank you!
 
  


Reply

Tags
drupal, lamp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I need all three (desktop,pae,&default) kernels installed on my system? marinegundoctor Linux - Kernel 2 02-22-2010 12:50 AM
LXer: Enterprise LAMP Summit & Big LAMP Camp LXer Syndicated Linux News 0 09-21-2009 01:51 AM
How to identify Slackware version by examining an installed system? beyondPCs Slackware 1 09-15-2008 07:38 PM
Newly installed slackware system will not boot yelo Slackware - Installation 5 05-11-2004 06:01 AM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration