LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How do you change card# of multi multi-media cards. (http://www.linuxquestions.org/questions/slackware-14/how-do-you-change-card-of-multi-multi-media-cards-253158/)

Nichole_knc 11-10-2004 06:33 AM

How do you change card# of multi multi-media cards.
 
Kernel=Custom 2.6.7
alsa 1.0.6 local build
with udevs running

Heres my problem...
I have a SoundBlaster sound card in pci slot #3
I have a ATI TV Wonder card in pci slot #5

The TV card always loads first ??? and is set by alsa as card 0. There by everything tries to "play" through it.
The sound card loads as card 1. Even though modprobe.conf is set for card slot 0 ID.

I have looked over every aspect and yet to find why.
Here is an interesting note.. I have a second install on a second HD which was the first primary install for this machine. The above problem did not appear on that version. The only difference was DL gnome on the former.

modprobe.conf

Quote:

# tvcard
alias char-major-81 bttv
options bttv card=1 autoload=0 tuner=2 radio=0 info=ntsc/stereo

# Video Card
alias char-major-195* nvidia

# sensors
# alias char-major-89 i2c-dev
# options w83781d ignore=1,0x2d

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias snd-card-0 snd-ens1371
alias sound-slot-0 snd-ens1371
# --- END: Generated by ALSACONF, do not edit. ---

Ok so how do I set the configuration to make the sound card card #0 and the TV card card #1 which really does not need any controls at all.

Nichole_knc 11-11-2004 08:27 PM

Seems nobody has an answer...
Oh well I figured out that funky udev thingy and bent it to my will. I don't think I will have a problem bending the cards my way either... Eventually...
Right now my `fixsound` script dandys it up.

rizzah 12-01-2004 01:19 PM

could you post it or has anyone figured out how to change this?

Cedrik 12-01-2004 01:49 PM

For my part, I compile the kernel with just CONFIG_SOUND as module, I don't enable alsa or OSS.
Then I download the alsa-driver package from alsa.org and configure it with my audio card driver
only. After alsa set up, I plug an audio cable from the output of my TV card to the input line of the
sound card. I set the capture gain in alsamixer. All work fine and the sound card is seen as #0 by
alsaconf.


All times are GMT -5. The time now is 08:54 AM.