LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2013, 04:18 PM   #1
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,684

Rep: Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441
How do I stop the screen from blanking when I watch 1 hour Youtube movies?


How do I stop the screen from blanking when I watch 1-hour Youtube movies? Moving the mouse every few minutes works, but I shouldn't have to do that.
 
Old 09-27-2013, 04:40 PM   #2
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
kde settings --> power manager --> screen energy saver
 
1 members found this post helpful.
Old 09-27-2013, 04:44 PM   #3
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: Fedora
Posts: 1,544

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
I have the same problem that I don't want to turn off the settings for when the system is really not in use, but it would be nice if it could recognize that a video player is running and disable the screen blanking. I'm thinking of buying one of those bobbing duck toys to hit the space bar periodically.
 
Old 09-27-2013, 05:10 PM   #4
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
problem is
it is the browser that is running the flash player

so what to do?

have the browser keep the display awake?
have flash keep the display awake?
 
Old 09-27-2013, 11:58 PM   #5
MadMaverick9
Member
 
Registered: Aug 2010
Location: Here
Distribution: Slackware 14.0
Posts: 137

Rep: Reputation: Disabled
Copy the youtube url into a media player like SMPlayer.

And then look up the "heartbeat-cmd" option for MPlayer.

And - luckily webbrowsers and adobe flash do not know about disabling the screen saver. Let's keep it that way!
 
Old 09-28-2013, 01:17 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
I use
Code:
killall -9 xscreensaver
then I relaunch it after.

I use a shell wrapper (in ~/.bashrc) for mplayer (I took it from the gentoo wiki years ago)
Code:
#requires xset
function mplayerwrap {
        xscreensaver-command -exit
        xset -dpms
        mplayer "$@"
        xset +dpms
        xscreensaver &
}
#make wrapper execute by default
alias mplayer="mplayerwrap"

Last edited by ponce; 09-28-2013 at 01:41 AM. Reason: added "(in ~/.bashrc)"
 
2 members found this post helpful.
Old 09-28-2013, 01:38 AM   #7
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
SIGKILL seems a little overkill , please pardon the pun.

use SIGTERM ( -15 ), which gives things a chance to close gracefully

screensaver and screen poweroff/suspend are different things


I always forget about YouTube plugins for media players
I think smplayer has a 'browser' for it and lets you login.
 
Old 09-28-2013, 01:58 AM   #8
speck
Member
 
Registered: Nov 2001
Location: California
Distribution: Slackware 14.1
Posts: 272

Rep: Reputation: 54
At times I've used a rather non-elegant solution with xautomation from the SlackBuilds repository. I put the following in a script and run it from an xterm whenever I don't want screen blanking/screen savers to initiate, then just ctrl-c to terminate the script when the video has finished.

Code:
while true
do
    xte 'mousermove 3 3'
    xte 'mousermove -3 -3'
    sleep 590
done
 
Old 09-28-2013, 03:04 AM   #9
MadMaverick9
Member
 
Registered: Aug 2010
Location: Here
Distribution: Slackware 14.0
Posts: 137

Rep: Reputation: Disabled
~/.mplayer/config:
Code:
heartbeat-cmd="/usr/bin/xscreensaver-command -deactivate > /dev/null 2>&1"
This tells xscreensaver to pretend that there has just been user activity.

Last edited by MadMaverick9; 09-28-2013 at 03:06 AM.
 
3 members found this post helpful.
Old 09-28-2013, 03:12 AM   #10
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
thanks MadMaverick9, I missed that option in the newest mplayers.
I had a look at the man page and by that I found also -stop-xscreensaver
 
Old 09-28-2013, 01:44 PM   #11
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,684

Original Poster
Rep: Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441
Thanks all.

I found the power management option in Xfce, and I can see that xset -dpms is the equivalent command-line option.

Last edited by dugan; 09-28-2013 at 01:45 PM.
 
Old 09-28-2013, 03:02 PM   #12
Lennie
Member
 
Registered: Aug 2012
Location: Sweden
Distribution: LFS, built with pacman
Posts: 302

Rep: Reputation: 60
I use lightsOn.sh
 
1 members found this post helpful.
Old 09-28-2013, 06:14 PM   #13
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 803

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
Originally Posted by MadMaverick9 View Post
And - luckily webbrowsers and adobe flash do not know about disabling the screen saver. Let's keep it that way!
On other platforms a running plugin video disables the screen saver or screen lock, while a paused video doesn't do that. And that's exactly what the user expects. So let's fix that bug! Oh wait! the Linux plugin is closed source and in EoL maintenance mode. So the Linux desktop is screwed...

BTW: The same happens to game controllers. Although they're just /dev/input devices, like keyboard and mouse, they're not recognized by xscreensaver. So it blanks the screen while the user is using a controller exclusively without touching keyboard and mouse...
 
Old 09-29-2013, 08:44 PM   #14
Geist
LQ Newbie
 
Registered: Jul 2013
Distribution: Slackware 14 / current
Posts: 28

Rep: Reputation: Disabled
It's also possible to set this up (I think globally/DE/WM independent) in the xorg.conf ServerLayout section.
Here's mine:

Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
    Option         "BlankTime" "0" 
    Option         "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"
EndSection
The last four entries are relevant ones, especially BlankTime, and OffTime. The latter turning the monitor off, the former blanking it.
 
Old 09-29-2013, 10:55 PM   #15
michaelslack
Member
 
Registered: Feb 2013
Location: Sydney
Distribution: slackware
Posts: 83

Rep: Reputation: 34
What about MPlayer "Stop XScreenSaver" option?

Dear slackers,

Please excuse me for probably being a bit thick about this, but why is all this extra stuff necessary when there is a ``Stop XScreenSaver'' checkbox in the ``Misc'' tab of the Preferences one can access through the MPlayer gui? It has not worked for me in the past and I was too lazy to try to fix it (I used AlienBOB's VLC package instead, just for that reason). Is this an MPlayer bug?


Michael

Last edited by michaelslack; 09-29-2013 at 10:55 PM. Reason: typo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't stop screen from blanking EDDY1 Debian 7 09-18-2013 12:25 AM
[SOLVED] How to stop screen blanking during inactivity Stephen Morgan Slackware 1 01-04-2012 01:35 PM
how to stop the screen blanking on crunchbang linux samsearcher Linux - Newbie 8 06-16-2009 01:23 PM
watch your widescreen movies more full screen shanenin Linux - Software 3 08-02-2005 12:30 AM
Can't stop KDE/Mandrake 9.2 from blanking screen themusk Linux - Software 1 03-20-2004 08:49 PM


All times are GMT -5. The time now is 05:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration