LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-03-2008, 10:54 AM   #1
oranyelik
LQ Newbie
 
Registered: Jul 2008
Posts: 11

Rep: Reputation: 1
How do I start LXDE on Slackware 12.1?


How do I start KDM or GDM (I don't know which I have, if I even have either because I don't know what they are) so that I can select my newly installed LXDE?

Since I installed Linux, my computer runs REALLY slow. At first I thought this was just how Linux was, so I was ready to give up. But I did some research and discovered that it's really just KDE, the bloated desktop environment that I'm using. I did some research and I've decided to go with LXDE (http://www.lxde.org/).

I downloaded all of the packages from http://saxenos.com/lxde/ and installed using the method it said. The installation seemed to go okay, but now I just can't figure out how to get it started.

All of the google research has told me "select it directly from the GDM or KDM"... but I have no idea what a KDM or GDM is or how to select it. I did a little bit of research again, and discovered that KDM presents a gui login screen or something of the sorts (I had one of these in ubuntu), but I never see this when I log into KDE. My login to my slackware system is all text-based until I type 'startx' as root or a user.

I suspect I do have something like KDM or GDM and I just don't use it, because I can select 'Login Manager' from my [start menu]->[system]->[login manager].

I've tried doing update-alternative --config x-session-manager but it tells me that the update-alternative command cannot be found. Doing xwmconfig only lets me choose from KDE and Tab Window Manager. KDE is TOO bloated but Tab Window Manager is too basic.

Please help me figure out how to get LXDE started, whether it has to be through KDM or not.

Thanks!
 
Old 08-03-2008, 11:25 AM   #2
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,138

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
To get a graphical log-in screen fire-up a text editor /etc/inittab

For example: # nano /etc/inittab

change:

id:3:initdefault:

to:

id:4:initdefault:

PS: If you don't like KDE then I suggest that you give XFce a try. XFce is relatively feature-rich and runs lighter than KDE.
In run level 4 you'll be able to select the graphical environment that you want with your mouse.

Last edited by hitest; 08-03-2008 at 11:40 AM.
 
Old 08-03-2008, 02:14 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,189

Rep: Reputation: Disabled
The packages at saxenos.com were created using the dumbed-down approach: by using src2pkg.
While src2pkg does produce working packages in a lot of cases, it does not work all that well for LXDE (but that is my own opinion) and without a build script you can only guess how the packager wants them to function. LXDE is a complete lightweight desktop environment with a series of packages that have to interact properly.

I have a similar set of packages for LXDE here: http://www.slackware.com/~alien/slackbuilds/lxde/ and for these, you get all the SlackBuilds too so that you can see how they are built. The README at http://www.slackware.com/~alien/slackbuilds/lxde/ explains what packages you need as a minimum (they are all in my repository) and how you can configure LXDE to be your default desktop environment in runlevel 3 (console login) as well as in runlevel 4 (graphical login).

Runlevel 4 is where your computer would run KDM (part of KDE) or GDM (part of Gnome) as the graphical login manager. But since you don't want KDE because of it's sluggishness, and Slackware has no Gnome, it may be good to install a lightweight graphical login manager to accompany LXDE. Get a package and SlackBuild here: http://www.slackware.com/~alien/slackbuilds/slim/

Eric
 
1 members found this post helpful.
Old 08-03-2008, 03:04 PM   #4
oranyelik
LQ Newbie
 
Registered: Jul 2008
Posts: 11

Original Poster
Rep: Reputation: 1
Thanks a lot! Between the two of your pieces of advice, I got LXDE working and the system seems to be soooooo much faster now. I really appreciate the help!

For anyone else ever viewing this thread, hitest's suggestion to change the /etc/inittab file got my to my gui login manager, but this manager still didn't have an option for LXDE. I suspected that maybe I didn't figure it correctly the first time, so I figured I would take advantage of Alien Bob's links and try his sources.

I downloaded the files that were were required as listed in the readme from the pkg directory on his repository (and I found openbox and pcmanfm by navigating to http://www.slackware.com/~alien/slackbuilds/) and unpacked those using installpkg *.tgz. Then all I had to do was reboot my computer, and when the GUI login came up (I don't think my install for slim worked quite right, because it looked like the KDM as it was before I downloaded his .tgz files), I just went to menu->session->lxde.

Now LXDE is working correctly... I just need to figure out how to do some of the things on this box all over again.

Thanks again for the help!
 
1 members found this post helpful.
Old 08-03-2008, 03:11 PM   #5
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,138

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
You're welcome; I'm glad I was able to help you a bit:-)

Last edited by hitest; 08-03-2008 at 03:15 PM.
 
Old 08-03-2008, 04:03 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,189

Rep: Reputation: Disabled
Quote:
Originally Posted by oranyelik View Post
when the GUI login came up (I don't think my install for slim worked quite right, because it looked like the KDM as it was before I downloaded his .tgz files), I just went to menu->session->lxde.
Checkout this bit on http://www.slackware.com/~alien/slackbuilds/slim/ -
Code:
Note:
You can add SLiM as the login manager to use in runlevel 4, as follows:

Open /etc/rc.d/rc.4 in an editor and add these lines:

# --- 8< --------------------------------------------------------------------
# Try to use SLiM login manager.  This comes first because if
# SLiM is on the machine then the user probably installed it and wants
# to use it by default:
if [ -x /usr/bin/slim ]; then
  exec /usr/bin/slim
fi

# --- 8< --------------------------------------------------------------------

...just above the line in rc.4 that goes like:

# Try to use GNOME's gdm session manager.  This comes first because if


When you restart the computer in runlevel 4, you will be greeted by the SLiM 
login screen.
To select LXDE as the session type in the SLiM login window, press <F1> key a few times until you see "lxde" appear. Then enter username/password.

Eric
 
Old 10-04-2008, 12:04 PM   #7
nymusicman
Member
 
Registered: Jun 2004
Location: Aurora, IL
Distribution: Slackware Current
Posts: 162

Rep: Reputation: 30
Helpful hint. Next time you install a new graphical login manager you do not have to reboot the whole system. Just restart X. If you can't find a button to do that: Ctrl+Shift+Backspace ought to do the trick.

I've never heard of slim but I'm going to give it a try, thanks for the suggestion.
 
Old 11-17-2008, 11:12 PM   #8
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
lxrandr failed with this message:

make[1]: *** [lxrandr.o] Error 1
make[1]: Leaving directory `/tmp/build/tmp-lxrandr/lxrandr-0.1/src'
make: *** [install-recursive] Error 1
./lxrandr.SlackBuild FAILED at line 169

All the other packages did fine. What am I missing?
I downloaded these files again in case of a bad download. That didn't work either.
 
Old 11-17-2008, 11:20 PM   #9
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Quote:
Originally Posted by nymusicman View Post
Just restart X. If you can't find a button to do that: Ctrl+Shift+Backspace ought to do the trick.
Or telinit 3 followed by telinit 4 if you're using a graphical login manager.
 
Old 11-17-2008, 11:59 PM   #10
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
I don't think anybody mentioned this... However, slackware by default uses the vesa frame buffer driver in the xorg.conf. You will definitely want to change this to load the proper driver for your card (assuming you have anything remotely capable of anything other than a framebuffer i.e. open gl support). This will greatly increase performance in KDE (or any window manager for that matter) and allow you to play 3d games.

try:
/sbin/lspci | grep VGA
or just:
/sbin/lspci

look for your graphics card. Then find out what default xorg driver supports that card. If you have an nvidia card you should think about installing the manufacture's drivers.


CHANGING THE XORG DEFAULT DRIVER:
edit /etc/X11/xorg.conf with any editor that makes sence to you.

Find the section
Code:
Section "Device"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
    Identifier     "VESA Framebuffer"
    Driver         "vesa"
EndSection
and change Driver "vesa" to whatever xorg driver supports your card.

If you cange the Identifier, you need to change the matching text in Section "Screen". You don't need to change the Identifier, just the driver.



MANUFACTURES DRIVERS:
Here are some links to some scripts that will package the drivers for you that you can then install with '/sbin/installpkg'. Or you can go to the Manufacturer's webpage and install their linux drivers in whatever way they want you to. These may or may not be the correct drivers for your card. Just because you have an NVIDIA or ATI card, do not assume these are correct.

NVIDIA slackbuild packaging scripts.
http://slackbuilds.org/repository/12...nvidia-driver/
http://slackbuilds.org/repository/12...nvidia-kernel/

ATI slackbuild packaging scripts.
http://slackbuilds.org/repository/12.../fglrx-driver/
http://slackbuilds.org/repository/12.../fglrx-module/


EDIT: damn it... Posted to another old thread... Either way... this information is still useful to the original intentions of the Thread... just not the title.

Last edited by lumak; 11-18-2008 at 12:02 AM.
 
Old 11-18-2008, 02:30 AM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,189

Rep: Reputation: Disabled
Quote:
Originally Posted by mlangdn View Post
lxrandr failed with this message:

make[1]: *** [lxrandr.o] Error 1
make[1]: Leaving directory `/tmp/build/tmp-lxrandr/lxrandr-0.1/src'
make: *** [install-recursive] Error 1
./lxrandr.SlackBuild FAILED at line 169

All the other packages did fine. What am I missing?
I downloaded these files again in case of a bad download. That didn't work either.
The real error messages are before those final lines. What you posted does not tell me anything about what really happened.

Also. What version of Slackware, and are you using the versions of all LXDE package sources found in my repository , or did you download and try to build newer releases?

Eric
 
Old 11-18-2008, 05:55 AM   #12
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
I used all the LXDE packages from your repository, and I am using 12.0. This is the entire make sequence:

[michael:~/downloads/LXDE]$ su
Password:
bash-3.1# ./lxrandr.SlackBuild
++
|| lxrandr-0.1
++
Extracting the source archive(s) for lxrandr...
lxrandr-0.1/
lxrandr-0.1/po/
lxrandr-0.1/po/zh_TW.po
lxrandr-0.1/po/hu.po
lxrandr-0.1/po/POTFILES.in
lxrandr-0.1/po/hu.gmo
lxrandr-0.1/po/lxrandr.pot
lxrandr-0.1/po/zh_TW.gmo
lxrandr-0.1/po/ChangeLog
lxrandr-0.1/po/Makefile.in.in
lxrandr-0.1/src/
lxrandr-0.1/src/lxrandr.c
lxrandr-0.1/src/Makefile.am
lxrandr-0.1/src/Makefile.in
lxrandr-0.1/NEWS
lxrandr-0.1/data/
lxrandr-0.1/data/lxrandr.desktop.in
lxrandr-0.1/depcomp
lxrandr-0.1/aclocal.m4
lxrandr-0.1/README
lxrandr-0.1/configure
lxrandr-0.1/configure.in
lxrandr-0.1/install-sh
lxrandr-0.1/autogen.sh
lxrandr-0.1/missing
lxrandr-0.1/mkinstalldirs
lxrandr-0.1/Makefile.am
lxrandr-0.1/Makefile.in
lxrandr-0.1/config.h.in
lxrandr-0.1/AUTHORS
lxrandr-0.1/INSTALL
lxrandr-0.1/ChangeLog
lxrandr-0.1/COPYING
Building ...
checking for a BSD-compatible install... /bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for catalogs to be installed... zh_TW hu
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating po/Makefile.in
config.status: creating data/lxrandr.desktop
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing default-1 commands
make all-recursive
make[1]: Entering directory `/tmp/build/tmp-lxrandr/lxrandr-0.1'
Making all in src
make[2]: Entering directory `/tmp/build/tmp-lxrandr/lxrandr-0.1/src'
gcc -DHAVE_CONFIG_H -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/share"\" -DPACKAGE_LOCALE_DIR=\""/usr/share/locale"\" -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -O2 -march=i486 -mtune=i686 -MT lxrandr.o -MD -MP -MF .deps/lxrandr.Tpo -c -o lxrandr.o lxrandr.c
lxrandr.c: In function 'monitor_free':
lxrandr.c:55: warning: passing argument 1 of 'g_strfreev' from incompatible pointer type
lxrandr.c: In function 'get_xrandr_info':
lxrandr.c:75: error: 'GRegex' undeclared (first use in this function)
lxrandr.c:75: error: (Each undeclared identifier is reported only once
lxrandr.c:75: error: for each function it appears in.)
lxrandr.c:75: error: 'regex' undeclared (first use in this function)
lxrandr.c:76: error: 'GMatchInfo' undeclared (first use in this function)
lxrandr.c:76: error: 'match' undeclared (first use in this function)
lxrandr.c:100: warning: initialization makes pointer from integer without a cast
lxrandr.c:106: warning: assignment makes pointer from integer without a cast
lxrandr.c: In function 'on_res_sel_changed':
lxrandr.c:172: warning: passing argument 1 of 'gtk_list_store_clear' from incompatible pointer type
lxrandr.c: In function 'on_about':
lxrandr.c:201: warning: passing argument 1 of 'gtk_about_dialog_set_url_hook' from incompatible pointer type
lxrandr.c: In function 'set_xrandr_info':
lxrandr.c:236: warning: passing argument 1 of 'gtk_toggle_button_get_active' from incompatible pointer type
lxrandr.c: In function 'on_quick_option':
lxrandr.c:279: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:286: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:293: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:299: warning: passing argument 1 of 'gtk_dialog_response' from incompatible pointer type
lxrandr.c: In function 'on_response':
lxrandr.c:312: warning: passing argument 1 of 'gtk_toggle_button_get_active' from incompatible pointer type
lxrandr.c:317: warning: passing argument 1 of 'gtk_message_dialog_new' from incompatible pointer type
lxrandr.c:318: warning: passing argument 1 of 'gtk_dialog_run' from incompatible pointer type
lxrandr.c: In function 'main':
lxrandr.c:354: warning: passing argument 1 of 'gtk_dialog_set_alternative_button_order' from incompatible pointer type
lxrandr.c:357: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:358: warning: passing argument 1 of 'gtk_button_box_set_child_secondary' from incompatible pointer type
lxrandr.c:368: warning: passing argument 1 of 'gtk_container_set_border_width' from incompatible pointer type
lxrandr.c:372: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:376: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:380: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:382: warning: passing argument 1 of 'gtk_notebook_append_page' from incompatible pointer type
lxrandr.c:386: warning: passing argument 1 of 'gtk_notebook_set_show_tabs' from incompatible pointer type
lxrandr.c:390: warning: passing argument 1 of 'gtk_container_set_border_width' from incompatible pointer type
lxrandr.c:391: warning: passing argument 1 of 'gtk_notebook_append_page' from incompatible pointer type
lxrandr.c:394: warning: passing argument 1 of 'gtk_misc_set_alignment' from incompatible pointer type
lxrandr.c:395: warning: passing argument 1 of 'gtk_label_set_markup' from incompatible pointer type
lxrandr.c:398: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:407: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:410: warning: passing argument 1 of 'gtk_container_set_border_width' from incompatible pointer type
lxrandr.c:414: warning: assignment from incompatible pointer type
lxrandr.c:418: warning: passing argument 1 of 'gtk_widget_hide' from incompatible pointer type
lxrandr.c:420: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:422: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:425: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:427: warning: assignment from incompatible pointer type
lxrandr.c:429: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:429: warning: passing argument 2 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:432: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:434: warning: assignment from incompatible pointer type
lxrandr.c:435: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:435: warning: passing argument 2 of 'gtk_box_pack_start' from incompatible pointer type
make[2]: *** [lxrandr.o] Error 1
make[2]: Leaving directory `/tmp/build/tmp-lxrandr/lxrandr-0.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/build/tmp-lxrandr/lxrandr-0.1'
make: *** [all] Error 2

INFO : Using a default root directory : /var/tmp/kWOZaYReqHoBVnGFmGog

Making install in src
make[1]: Entering directory `/tmp/build/tmp-lxrandr/lxrandr-0.1/src'
gcc -DHAVE_CONFIG_H -I. -I.. -DPACKAGE_DATA_DIR=\""/usr/share"\" -DPACKAGE_LOCALE_DIR=\""/usr/share/locale"\" -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -O2 -march=i486 -mtune=i686 -MT lxrandr.o -MD -MP -MF .deps/lxrandr.Tpo -c -o lxrandr.o lxrandr.c
lxrandr.c: In function 'monitor_free':
lxrandr.c:55: warning: passing argument 1 of 'g_strfreev' from incompatible pointer type
lxrandr.c: In function 'get_xrandr_info':
lxrandr.c:75: error: 'GRegex' undeclared (first use in this function)
lxrandr.c:75: error: (Each undeclared identifier is reported only once
lxrandr.c:75: error: for each function it appears in.)
lxrandr.c:75: error: 'regex' undeclared (first use in this function)
lxrandr.c:76: error: 'GMatchInfo' undeclared (first use in this function)
lxrandr.c:76: error: 'match' undeclared (first use in this function)
lxrandr.c:100: warning: initialization makes pointer from integer without a cast
lxrandr.c:106: warning: assignment makes pointer from integer without a cast
lxrandr.c: In function 'on_res_sel_changed':
lxrandr.c:172: warning: passing argument 1 of 'gtk_list_store_clear' from incompatible pointer type
lxrandr.c: In function 'on_about':
lxrandr.c:201: warning: passing argument 1 of 'gtk_about_dialog_set_url_hook' from incompatible pointer type
lxrandr.c: In function 'set_xrandr_info':
lxrandr.c:236: warning: passing argument 1 of 'gtk_toggle_button_get_active' from incompatible pointer type
lxrandr.c: In function 'on_quick_option':
lxrandr.c:279: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:286: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:293: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:299: warning: passing argument 1 of 'gtk_dialog_response' from incompatible pointer type
lxrandr.c: In function 'on_response':
lxrandr.c:312: warning: passing argument 1 of 'gtk_toggle_button_get_active' from incompatible pointer type
lxrandr.c:317: warning: passing argument 1 of 'gtk_message_dialog_new' from incompatible pointer type
lxrandr.c:318: warning: passing argument 1 of 'gtk_dialog_run' from incompatible pointer type
lxrandr.c: In function 'main':
lxrandr.c:354: warning: passing argument 1 of 'gtk_dialog_set_alternative_button_order' from incompatible pointer type
lxrandr.c:357: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:358: warning: passing argument 1 of 'gtk_button_box_set_child_secondary' from incompatible pointer type
lxrandr.c:368: warning: passing argument 1 of 'gtk_container_set_border_width' from incompatible pointer type
lxrandr.c:372: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:376: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:380: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:382: warning: passing argument 1 of 'gtk_notebook_append_page' from incompatible pointer type
lxrandr.c:386: warning: passing argument 1 of 'gtk_notebook_set_show_tabs' from incompatible pointer type
lxrandr.c:390: warning: passing argument 1 of 'gtk_container_set_border_width' from incompatible pointer type
lxrandr.c:391: warning: passing argument 1 of 'gtk_notebook_append_page' from incompatible pointer type
lxrandr.c:394: warning: passing argument 1 of 'gtk_misc_set_alignment' from incompatible pointer type
lxrandr.c:395: warning: passing argument 1 of 'gtk_label_set_markup' from incompatible pointer type
lxrandr.c:398: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:407: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:410: warning: passing argument 1 of 'gtk_container_set_border_width' from incompatible pointer type
lxrandr.c:414: warning: assignment from incompatible pointer type
lxrandr.c:418: warning: passing argument 1 of 'gtk_widget_hide' from incompatible pointer type
lxrandr.c:420: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:422: warning: passing argument 1 of 'gtk_toggle_button_set_active' from incompatible pointer type
lxrandr.c:425: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:427: warning: assignment from incompatible pointer type
lxrandr.c:429: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:429: warning: passing argument 2 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:432: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:434: warning: assignment from incompatible pointer type
lxrandr.c:435: warning: passing argument 1 of 'gtk_box_pack_start' from incompatible pointer type
lxrandr.c:435: warning: passing argument 2 of 'gtk_box_pack_start' from incompatible pointer type
make[1]: *** [lxrandr.o] Error 1
make[1]: Leaving directory `/tmp/build/tmp-lxrandr/lxrandr-0.1/src'
make: *** [install-recursive] Error 1
./lxrandr.SlackBuild FAILED at line 169
bash-3.1#
 
Old 11-18-2008, 07:00 AM   #13
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,323

Rep: Reputation: 71
'GRegex' is declared in /usr/include/glib-2.0/glib/gregex.h
The compilation options include : '-I/usr/include/glib-2.0'

Check if this line is present in lxrandr-0.1/src/lxrandr.c :
#include <glib/gregex.h>
 
Old 11-18-2008, 07:30 AM   #14
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
That line is not present. Since I can't write to tar, how do I tar it back after including that line? I'm gonna read the tar man page now.

Edit: Got that figured out quickly, but there is no file in glib - gregex.h

Time for more research

Last edited by mlangdn; 11-18-2008 at 07:36 AM.
 
Old 11-18-2008, 07:35 AM   #15
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,323

Rep: Reputation: 71
You could move temporarly gregex.h, this way you don't have to change anything

just try (as root):
Code:
cd /usr/include/glib-2.0/glib
mv gregex.h ..
(so gregex.h is now in /usr/include/glib-2.0)
Then try the slackbuild script, after that don't forget to put gregex.h back in /usr/include/glib-2.0/glib

Last edited by keefaz; 11-18-2008 at 07:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXDE Hanging on desktop rightclick yah0m Linux - Desktop 0 07-21-2008 06:14 PM
LXer: LXDE - Lightweight X11 Desktop Environment for Ubuntu LXer Syndicated Linux News 0 07-06-2008 01:42 PM
XDG menus, LXDE, and menu entries kdulcimer Grafpup 3 11-10-2007 01:14 AM
How do I start Slackware 10.0? greentooth Linux - Software 4 06-23-2005 02:58 PM
Why can't I get X to start in Slackware 9.0 Superdude Linux - Software 4 10-11-2003 07:32 PM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration