LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-10-2006, 05:19 AM   #1
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 188

Rep: Reputation: 30
how do I set the default resolution? (resolved)


The default resolution on startup (when kdm loads) is 1152 x 900. I can't actually see the whole screen. I need to move the mouse around to view a different section. It's hard for me to explain. Anyways, only once I've logged into my window manager I can enter the command “xrandr -s 0” which then changes the resolution to 1024 x 768. I hate having to enter that xrandr command every singly time I log in. What command do I enter to permanently set the resolution to 1024 x 768?

edit: grammar

Last edited by Drone4four; 11-24-2006 at 06:49 PM.
 
Old 08-10-2006, 05:29 AM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Edit your /etc/X11/xorg.conf so the 'largest' resolution is 1024x768. (The first one on the list would be your default)
 
Old 08-10-2006, 05:32 AM   #3
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by Drone4four
The default resolution on startup (when kdm loads) is 1152 x 900. I can't actually see the whole screen. I need to move the mouse around to view a different section. It's hard for me to explain. Anyways, only once I've logged into my window manager can I enter the command “xrandr -s 0” which then changes the resolution to 1024 x 768. I hate having to enter that xrandr command every singly time I log in. What command do I enter to permanently set the resolution to 1024 x 768?
It's the virtual desktop feature where the desktop size > screen size. You need to disable it. Run xorgconfig and manually reconfigure with the resolution of your choice and disable virtual desktop. Or alternatively, just edit your /etc/X11/xorg.conf
 
Old 08-10-2006, 05:48 AM   #4
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 188

Original Poster
Rep: Reputation: 30
I removed all references to 1152x768 in my xorg.conf. For some reason, 1152x900 is still an xrandr option.
Code:
invert@314:~$ xrandr 
 SZ:    Pixels          Physical       Refresh
*0   1024 x 768    ( 390mm x 305mm )  *85  
 1    800 x 600    ( 390mm x 305mm )   85  
 2    640 x 480    ( 390mm x 305mm )   85  
 3   1152 x 900    ( 390mm x 305mm )   85  
Current rotation - normal
Current reflection - none
Rotations possible - normal 
Reflections possible - none
invert@314:~$
Here is the screen section of my xorg.conf:
Code:
# **********************************************************************
# Screen sections
# **********************************************************************
        
# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option. 
Section "Screen"
    Identifier  "Screen 1"
    Device      "i845G" 
    Monitor     "SyncMaster 700NF"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1024x768" "1280x1024" "800x600" "640x480"
        ViewPort    0 0
        Virtual     1600 1280
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1024x768" "1280x1024"  "800x600" "640x480"
        ViewPort    0 0
        Virtual     1280 1024
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "1280x1024" "800x600" "640x480"
        ViewPort    0 0
        Virtual     1024 768
    EndSubsection
EndSection
 
Old 08-10-2006, 05:49 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Did you restart X after changing the file?
 
Old 08-10-2006, 05:53 AM   #6
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 188

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Nylex
Did you restart X after changing the file?
Restarting x did the trick. The problem is solved. Thanks cwwilson721, Harishankar, Nylex.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 01:33 AM
Hoary -- can't set a default vid resolution harrkev Ubuntu 3 08-21-2005 04:24 PM
X: using larger resolution for games than default desktop resolution Jamo Linux - Games 2 04-10-2005 03:16 AM
how to know what is the current resolution ttilt Linux - Software 3 11-28-2004 10:38 AM
How can I set the default resolution? DFrey Linux - Newbie 5 11-19-2001 02:33 AM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration