LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How do I restore notifications from nm-applet (http://www.linuxquestions.org/questions/slackware-14/how-do-i-restore-notifications-from-nm-applet-4175429852/)

xflow7 10-01-2012 05:40 AM

How do I restore notifications from nm-applet
 
Hi all,

I'm using XFCE in Slackware 14.0. I accidentally clicked "Don't show this message again" or whatever it is on the network connected notification message. Now I can't for the life of me figure out how to get the notifications back.

Can anyone help?

Thanks,

Dave

smallpond 10-01-2012 03:59 PM

From the command line run: nm-connection-editor
Edit a managed configuration and save. This should get nm-applet to be auto-started. If not try running nm-applet from the commmand line and see if it gives an error.

xflow7 10-03-2012 09:09 AM

Thanks for replying.

For clarification, the problem isn't that nm-applet isn't running - it is. The problem is that it no longer displays the pop-up notification messages when it connects to the wireless network. I am trying to find out how to get the notification messages back.

Thanks,

Dave

allend 10-03-2012 10:33 AM

I had your problem but I am not exactly sure how I fixed it.
Check the contents of the ~/.gconf/apps/nm-applet directory.
I seem to recall some extra lines in the %gconf.xml file.

BobSwi 10-03-2012 12:16 PM

Also maybe if you go into the Panel preferences and edit the Notification Area, there are checkboxes for hidden.

xflow7 10-03-2012 05:30 PM

Quote:

Originally Posted by allend (Post 4796119)
I had your problem but I am not exactly sure how I fixed it.
Check the contents of the ~/.gconf/apps/nm-applet directory.
I seem to recall some extra lines in the %gconf.xml file.

Gold star for you! That was it.

Thanks much.

ETA: This suggestion gave me +5 Google Fu and allowed me to discover a higher-level way to do this. I'm adding it here for the benefit of anyone who comes across this in the future. You can also use the gconftool-2 command as follows:

Code:

$ gconftool-2 --type bool --set /apps/nm-applet/disable-connected-notifications false
Dave


All times are GMT -5. The time now is 06:11 AM.