LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2006, 05:56 PM   #1
darkhatter
Member
 
Registered: Dec 2005
Distribution: Slackware 12.1/Current
Posts: 159

Rep: Reputation: 30
How do I get sound to work when using flash in web browser


I'm running firefox 1.5 and I can't get sound to work, it worked when i used suse so I know that it is possible can someone tell we what to do. I've been using slackware for a couple years so I know my way around it.
 
Old 01-26-2006, 06:43 PM   #2
tomj88
Member
 
Registered: Apr 2005
Location: Wolverhampton, England
Distribution: Ubuntu
Posts: 334

Rep: Reputation: 30
I have the same problem - worked in Mandriva, doesn't work in Debian (sarge/etch/sid). Is this a problem with the FireFox packages for certain distributions?
 
Old 01-26-2006, 06:48 PM   #3
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
try it on konqueror
 
Old 01-26-2006, 07:01 PM   #4
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 441

Rep: Reputation: 51
Maybe a problem with exclusive access to sound device requirement ? Stop/kill any running sound daemon like artsd or esd and try it again.
 
Old 01-26-2006, 07:01 PM   #5
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
the first thing you should try is a search in this forum, as this is a very popular question which has been answered in a countless number of threads... having said that, what have you tried so far?? did you look at the permissions for your relevant /dev files such as /dev/dsp0 for example?? are you using any sound daemons??

Last edited by win32sux; 01-26-2006 at 07:03 PM.
 
Old 01-27-2006, 10:27 AM   #6
kriton12
Member
 
Registered: Oct 2002
Posts: 81

Rep: Reputation: 16
Are you a member of the audio group?

Does any sound work or is it specific to using firefox?
Also, have you installed the flash plugin?

Basic questions i know, but sometimes they are the ones you forget.
 
Old 01-27-2006, 10:44 AM   #7
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
Are you using kde? There are settings in Control center to change so that artsd releases /dev/dsp directly after its been used so that apps that dont depend on artsd can use it.
 
Old 01-27-2006, 04:40 PM   #8
darkhatter
Member
 
Registered: Dec 2005
Distribution: Slackware 12.1/Current
Posts: 159

Original Poster
Rep: Reputation: 30
not sure about the audio group, sound works in every other program, I have disabled arts I have searched the forum, can you give me a link to where this was solved, I'm using firefox so it installs the plugin the second I go to a web site that needs it. I'm using kde 3.5
 
Old 01-27-2006, 04:44 PM   #9
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
what permissions do you have set for /dev/dsp0??
Code:
ls -l /dev/dsp0
 
Old 01-27-2006, 04:46 PM   #10
darkhatter
Member
 
Registered: Dec 2005
Distribution: Slackware 12.1/Current
Posts: 159

Original Poster
Rep: Reputation: 30
that was fast

crwxrwxrwx is what I have it set as
 
Old 01-27-2006, 04:49 PM   #11
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
owner?? group??

also, have you tested using a window manager such as fluxbox or blackbox or something to determine if it's a kde-specific issue??

BTW: AFAIK there's no reason why your /dev/dsp0 should have executable permissions...

Last edited by win32sux; 01-27-2006 at 04:50 PM.
 
Old 01-27-2006, 04:54 PM   #12
darkhatter
Member
 
Registered: Dec 2005
Distribution: Slackware 12.1/Current
Posts: 159

Original Poster
Rep: Reputation: 30
it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!

all I did was change the permissions on dsp0,dsp1 and dsp and everything started working

thanks!!!!!!
 
Old 01-27-2006, 04:55 PM   #13
Bourdieu
LQ Newbie
 
Registered: Jan 2006
Location: Paris
Distribution: Slackware current
Posts: 27

Rep: Reputation: 2
It's a known problem, use: #aoss firefox

It should work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound while playing flash in web browsers greentooth Linux - Software 6 06-24-2006 04:04 PM
no sound from flash web sites kkempter Linux - Software 2 08-30-2005 01:13 PM
Flash Web Browser Pop up Alert ixus_123 Linux - Software 2 04-12-2004 11:11 AM
Browser(s) sound problem (related to Flash) Edric Linux - Software 4 10-10-2003 01:07 PM
Web browser not detecting my Flash plug in moy Linux - Newbie 4 06-23-2003 01:33 PM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration