LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How do I get sound to work when using flash in web browser (http://www.linuxquestions.org/questions/slackware-14/how-do-i-get-sound-to-work-when-using-flash-in-web-browser-408374/)

darkhatter 01-26-2006 05:56 PM

How do I get sound to work when using flash in web browser
 
I'm running firefox 1.5 and I can't get sound to work, it worked when i used suse so I know that it is possible can someone tell we what to do. I've been using slackware for a couple years so I know my way around it.

tomj88 01-26-2006 06:43 PM

I have the same problem - worked in Mandriva, doesn't work in Debian (sarge/etch/sid). Is this a problem with the FireFox packages for certain distributions?

raska 01-26-2006 06:48 PM

try it on konqueror

dunric 01-26-2006 07:01 PM

Maybe a problem with exclusive access to sound device requirement ? Stop/kill any running sound daemon like artsd or esd and try it again.

win32sux 01-26-2006 07:01 PM

the first thing you should try is a search in this forum, as this is a very popular question which has been answered in a countless number of threads... having said that, what have you tried so far?? did you look at the permissions for your relevant /dev files such as /dev/dsp0 for example?? are you using any sound daemons??

kriton12 01-27-2006 10:27 AM

Are you a member of the audio group?

Does any sound work or is it specific to using firefox?
Also, have you installed the flash plugin?

Basic questions i know, but sometimes they are the ones you forget.

con 01-27-2006 10:44 AM

Are you using kde? There are settings in Control center to change so that artsd releases /dev/dsp directly after its been used so that apps that dont depend on artsd can use it.

darkhatter 01-27-2006 04:40 PM

not sure about the audio group, sound works in every other program, I have disabled arts I have searched the forum, can you give me a link to where this was solved, I'm using firefox so it installs the plugin the second I go to a web site that needs it. I'm using kde 3.5

win32sux 01-27-2006 04:44 PM

what permissions do you have set for /dev/dsp0??
Code:

ls -l /dev/dsp0

darkhatter 01-27-2006 04:46 PM

that was fast

crwxrwxrwx is what I have it set as

win32sux 01-27-2006 04:49 PM

owner?? group??

also, have you tested using a window manager such as fluxbox or blackbox or something to determine if it's a kde-specific issue??

BTW: AFAIK there's no reason why your /dev/dsp0 should have executable permissions...

darkhatter 01-27-2006 04:54 PM

it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!it works!!!!!

all I did was change the permissions on dsp0,dsp1 and dsp and everything started working

thanks!!!!!!

Bourdieu 01-27-2006 04:55 PM

It's a known problem, use: #aoss firefox

It should work


All times are GMT -5. The time now is 06:00 PM.