LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2010, 05:59 AM   #1
Olaus
Member
 
Registered: Apr 2006
Location: Sweden
Distribution: Slackware64 14.1 multilib
Posts: 112

Rep: Reputation: 16
How do I get rtsp:// in firefox to work? (adding entries in :config does not work)


I have followed the instructions at http://www.vcn.bc.ca/~dugan/setting-up-slackware.html (under "Making Firefox Perfect"), but I still get the error message
"Firefox doesn't know how to open this address, because the protocol (rtsp) isn't associated with any program."
So, any further tips?
 
Old 02-02-2010, 06:36 AM   #2
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
What is your exact entry in the about:config for rtsp?
 
Old 02-02-2010, 06:42 AM   #3
Olaus
Member
 
Registered: Apr 2006
Location: Sweden
Distribution: Slackware64 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by affinity View Post
What is your exact entry in the about:config for rtsp?
According to the web site I quoted (of course I edited the path to realplay for my installation)
 
Old 02-02-2010, 06:50 AM   #4
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
I was hoping you would copy and paste the exact line to check for errors, but assuming there are no typos have you enabled rtsp in the player you are pointing to?
 
Old 02-02-2010, 07:27 AM   #5
Olaus
Member
 
Registered: Apr 2006
Location: Sweden
Distribution: Slackware64 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by affinity View Post
I was hoping you would copy and paste the exact line to check for errors, but assuming there are no typos have you enabled rtsp in the player you are pointing to?
In RealPlayer's preferences, under the "transport" tab, "Automatically select best transport" is chosen. Is this the right choice, or/and are there any other places where I should enable rtsp in RealPlayer?
 
Old 02-02-2010, 07:38 AM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
I do not run slackware, but this work for me in debian:

user_pref("network.protocol-handler.app.rtsp", "/usr/bin/realplayer");
user_pref("network.protocol-handler.external.rtsp", true);
 
Old 02-02-2010, 07:46 AM   #7
Olaus
Member
 
Registered: Apr 2006
Location: Sweden
Distribution: Slackware64 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by craigevil View Post
I do not run slackware, but this work for me in debian:

user_pref("network.protocol-handler.app.rtsp", "/usr/bin/realplayer");
user_pref("network.protocol-handler.external.rtsp", true);
I guess you didn't check out the link I provided in the first post, which also tells me to do those settings. Which don't work for me.
 
Old 02-02-2010, 01:22 PM   #8
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
I'm not sure about the realplayer options, I have never used it. However if you set the rtsp string to false in Firefox it will prompt you for a player when accessing an rtsp file. If it does prompt for a player that means that Firefox is set up correctly, if it still gives you an error it means something is not right in Firefox. If you do get the prompt I would search the real player site for information on using rtsp, you may have to set it as the default player for that type of file as well.
 
Old 02-03-2010, 02:33 AM   #9
Olaus
Member
 
Registered: Apr 2006
Location: Sweden
Distribution: Slackware64 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by affinity View Post
I'm not sure about the realplayer options, I have never used it. However if you set the rtsp string to false in Firefox it will prompt you for a player when accessing an rtsp file. If it does prompt for a player that means that Firefox is set up correctly, if it still gives you an error it means something is not right in Firefox. If you do get the prompt I would search the real player site for information on using rtsp, you may have to set it as the default player for that type of file as well.
Unfortunately, Firefox does not prompt for a player even though I set network.protocol-handler.external.rtsp to false
 
Old 02-03-2010, 08:09 AM   #10
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
I did a Google search and the first result was this blog entry about editing the user.js file in your Firefox profile directory, the post says the information was taken from the Gentoo wiki. Another post on the Mozilla Zine forums says that in the about:config to add /usr/bin/realplay to the rtsp string.
 
Old 02-03-2010, 11:28 AM   #11
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,771

Rep: Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468
Hmm... did the Firefox updates break it? I'm going to do some tests...

Last edited by dugan; 02-03-2010 at 11:30 AM.
 
Old 02-03-2010, 12:45 PM   #12
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,771

Rep: Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468
I got it working!

Set network.protocol-handler.expose.rtsp to false. Then click on this working RTSP link from a random forum thread. The "choose a program to handle this protocol" window will then pop up.

http://kb.mozillazine.org/Register_protocol

Pasting an rtsp link into the address bar doesn't work. You have to actually click on a link.

The 64-bit Realplayer nightly build I'm using segfaults as soon as it loads the stream, but that's another story.

EDIT: So I installed Alien Bob's 64-bit VLC package from his restricted directory, and used Firefox's Application Preference tab to set vlc as the rtsp handler.

Last edited by dugan; 02-03-2010 at 01:24 PM. Reason: Also changed the sample rtsp stream to a working one.
 
Old 02-04-2010, 05:58 AM   #13
Olaus
Member
 
Registered: Apr 2006
Location: Sweden
Distribution: Slackware64 14.1 multilib
Posts: 112

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by dugan View Post
I got it working!

Set network.protocol-handler.expose.rtsp to false. Then click on this working RTSP link from a random forum thread. The "choose a program to handle this protocol" window will then pop up.

http://kb.mozillazine.org/Register_protocol
Thank you so much! I guess this will solve the Firefox-not-letting-you-choose-application trouble for other type of protocols too.
Do I still need to have the expose.rtsp set to false, even though I now have chosen the right action in the prefs?
 
Old 02-04-2010, 08:56 AM   #14
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,771

Rep: Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468Reputation: 1468
Quote:
Originally Posted by Olaus View Post
Do I still need to have the expose.rtsp set to false, even though I now have chosen the right action in the prefs?
According to the Mozillazine knowledgebase article on this key, setting it back to true would disable the protocol entirely.
http://kb.mozillazine.org/Network.pr...%28protocol%29
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS lookup doesn't work, ping, firefox will not work properly lovemov Linux - Networking 2 04-23-2009 02:30 PM
How do i make firefox 3 work after installing firefox 2 on Ubuntu 8.04 avinash.rao Ubuntu 10 09-06-2008 10:34 AM
WIll this GRUB config work with adding a new HDD and OS?... If not what will? Erik765 Linux - Software 3 04-06-2008 12:08 PM
RTSP: Server for Linux: Livestream --> RTSP polemon Linux - Software 0 10-10-2007 06:37 AM
./config Doesn't work korpirampa Linux - Newbie 2 09-30-2004 04:39 PM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration