LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How do I get rtsp:// in firefox to work? (adding entries in :config does not work) (http://www.linuxquestions.org/questions/slackware-14/how-do-i-get-rtsp-in-firefox-to-work-adding-entries-in-config-does-not-work-786402/)

Olaus 02-02-2010 06:59 AM

How do I get rtsp:// in firefox to work? (adding entries in :config does not work)
 
I have followed the instructions at http://www.vcn.bc.ca/~dugan/setting-up-slackware.html (under "Making Firefox Perfect"), but I still get the error message
"Firefox doesn't know how to open this address, because the protocol (rtsp) isn't associated with any program."
So, any further tips?

affinity 02-02-2010 07:36 AM

What is your exact entry in the about:config for rtsp?

Olaus 02-02-2010 07:42 AM

Quote:

Originally Posted by affinity (Post 3849435)
What is your exact entry in the about:config for rtsp?

According to the web site I quoted (of course I edited the path to realplay for my installation)

affinity 02-02-2010 07:50 AM

I was hoping you would copy and paste the exact line to check for errors, but assuming there are no typos have you enabled rtsp in the player you are pointing to?

Olaus 02-02-2010 08:27 AM

Quote:

Originally Posted by affinity (Post 3849452)
I was hoping you would copy and paste the exact line to check for errors, but assuming there are no typos have you enabled rtsp in the player you are pointing to?

In RealPlayer's preferences, under the "transport" tab, "Automatically select best transport" is chosen. Is this the right choice, or/and are there any other places where I should enable rtsp in RealPlayer?

craigevil 02-02-2010 08:38 AM

I do not run slackware, but this work for me in debian:

user_pref("network.protocol-handler.app.rtsp", "/usr/bin/realplayer");
user_pref("network.protocol-handler.external.rtsp", true);

Olaus 02-02-2010 08:46 AM

Quote:

Originally Posted by craigevil (Post 3849504)
I do not run slackware, but this work for me in debian:

user_pref("network.protocol-handler.app.rtsp", "/usr/bin/realplayer");
user_pref("network.protocol-handler.external.rtsp", true);

I guess you didn't check out the link I provided in the first post, which also tells me to do those settings. Which don't work for me.

affinity 02-02-2010 02:22 PM

I'm not sure about the realplayer options, I have never used it. However if you set the rtsp string to false in Firefox it will prompt you for a player when accessing an rtsp file. If it does prompt for a player that means that Firefox is set up correctly, if it still gives you an error it means something is not right in Firefox. If you do get the prompt I would search the real player site for information on using rtsp, you may have to set it as the default player for that type of file as well.

Olaus 02-03-2010 03:33 AM

Quote:

Originally Posted by affinity (Post 3849861)
I'm not sure about the realplayer options, I have never used it. However if you set the rtsp string to false in Firefox it will prompt you for a player when accessing an rtsp file. If it does prompt for a player that means that Firefox is set up correctly, if it still gives you an error it means something is not right in Firefox. If you do get the prompt I would search the real player site for information on using rtsp, you may have to set it as the default player for that type of file as well.

Unfortunately, Firefox does not prompt for a player even though I set network.protocol-handler.external.rtsp to false :scratch:

affinity 02-03-2010 09:09 AM

I did a Google search and the first result was this blog entry about editing the user.js file in your Firefox profile directory, the post says the information was taken from the Gentoo wiki. Another post on the Mozilla Zine forums says that in the about:config to add /usr/bin/realplay to the rtsp string.

dugan 02-03-2010 12:28 PM

Hmm... did the Firefox updates break it? I'm going to do some tests...

dugan 02-03-2010 01:45 PM

I got it working!

Set network.protocol-handler.expose.rtsp to false. Then click on this working RTSP link from a random forum thread. The "choose a program to handle this protocol" window will then pop up.

http://kb.mozillazine.org/Register_protocol

Pasting an rtsp link into the address bar doesn't work. You have to actually click on a link.

The 64-bit Realplayer nightly build I'm using segfaults as soon as it loads the stream, but that's another story.

EDIT: So I installed Alien Bob's 64-bit VLC package from his restricted directory, and used Firefox's Application Preference tab to set vlc as the rtsp handler.

Olaus 02-04-2010 06:58 AM

Quote:

Originally Posted by dugan (Post 3851111)
I got it working!

Set network.protocol-handler.expose.rtsp to false. Then click on this working RTSP link from a random forum thread. The "choose a program to handle this protocol" window will then pop up.

http://kb.mozillazine.org/Register_protocol

Thank you so much! I guess this will solve the Firefox-not-letting-you-choose-application trouble for other type of protocols too.
Do I still need to have the expose.rtsp set to false, even though I now have chosen the right action in the prefs?

dugan 02-04-2010 09:56 AM

Quote:

Originally Posted by Olaus (Post 3852155)
Do I still need to have the expose.rtsp set to false, even though I now have chosen the right action in the prefs?

According to the Mozillazine knowledgebase article on this key, setting it back to true would disable the protocol entirely.
http://kb.mozillazine.org/Network.pr...%28protocol%29


All times are GMT -5. The time now is 03:29 AM.