LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How do I get my Thinkpad trackpoint to scroll? (http://www.linuxquestions.org/questions/slackware-14/how-do-i-get-my-thinkpad-trackpoint-to-scroll-666513/)

Lufbery 08-30-2008 01:19 PM

How do I get my Thinkpad trackpoint to scroll?
 
Are there any other Thinkpad users here?

I've got an IBM Thinkpad A22m, and I can't get the scroll feature to work -- I press and hold down the middle button, but no scrolling happens. I followed the directions on Thinkwiki for modifying my xorg.conf, but did not have luck. Does anyone have any suggestions?

Thanks,

-Drew

camorri 08-30-2008 02:05 PM

Please post the lines for your mouse in /etc/X11/xorg.conf .

Lufbery 08-30-2008 03:13 PM

Quote:

Originally Posted by camorri (Post 3264689)
Please post the lines for your mouse in /etc/X11/xorg.conf .

Here you go:

Code:

Section "InputDevice"
        Identifier "Mouse0"
        Driver "mouse"
        Option "Buttons 5"
        Option "Device /dev/input/mice"
        Option "Name TPPS/2 IBM TrackPoint"
        Option "Protocol explorerps/2"
        #add the following lines
        Option "Emulate3Buttons on"
        Option "Emulate3TimeOut 50"
        Option "EmulateWheel on"
        Option "EmulateWheelTimeOut 200"
        Option "EmulateWheelButton 2"
        #end
        Option "Vendor Sysp"
        Option "YAxisMapping" "4 5"
        Option "XAxisMapping" "6 7"
        #Option "ZAxisMapping 4 5 6 7"
EndSection

Thanks!

-Drew

camorri 08-31-2008 06:09 AM

There are two things to edit, and try again.

1. In your file
Quote:

Option "Protocol explorerps/2"
In the example
Quote:

Option "Protocol" "ExplorerPS/2"
Note the number of quotes is different, and the case of the ExploererPS/2. Synyax is important.

2. In your file
Quote:

#Option "ZAxisMapping 4 5 6 7"
In the example
Quote:

Option "ZAxisMapping" "4 5"
The # sign comments this line, so it is ignored. Remove the #. I would try the values as stated also, first. Also note the quotes are not correct.

As root edit these changes and save, restart the Xserver with a Ctrl + Alt + Backspace. Log back in and try again. Post back the results.

Lufbery 08-31-2008 09:18 PM

Cliff,

You were right about the syntax being important. I copied the Mouse section from the Thinkwiki and compared it to mine. The quotation marks were uniformly missing in my file. I ended up simply replacing what was in my xorg.conf with the one from thinkwiki. Everything is working well now.

Regards,

-Drew

camorri 09-01-2008 06:03 AM

Glad to hear it.


All times are GMT -5. The time now is 08:07 PM.