LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-24-2006, 02:59 PM   #1
apsteffe
LQ Newbie
 
Registered: Sep 2006
Distribution: slackware
Posts: 1

Rep: Reputation: 0
How do I force hotplug to ignore a PCI slot?


Hotplug hangs (either during boot or manually) when a Yamaha ymfpci sound adapter is installed. The card works, the ALSA driver loads fine and I get sound. I tried blacklisting snd-ymfpci, but no effect. It would be nice to just force hotplug to ignore the PCI slot. I suspect it would have something to do with the pci.agent script in /etc/hotplug, but I can't find any documentation specific enough. I've got slackware 10.2 with kernel 2.6.13. By the way, I'm running 2 sound adapters: the onboard intel 865 and the yamaha--they work fine simultaneously.
 
Old 09-24-2006, 03:02 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Have you tried a different slot or change the order of the cards in the machine?
Make a note where everything is first before moving.

Brian1
 
Old 09-24-2006, 03:10 PM   #3
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

You might want to try turning off (or on) PNP in BIOS too.

Dave
 
Old 09-24-2006, 04:50 PM   #4
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
Just disable hotplug entirely.

"chmod -x /etc/rc.d/rc.hotplug"

You'll have to manually load the sound card modules and such though, but there are many ways to do that automatically too.
 
  


Reply

Tags
hotplug


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCI-X Raid card wont fit in motherboards PCI Express x16 slot???? abefroman Linux - Hardware 4 12-01-2006 08:24 AM
PCI pointing to wrong slot..or BUS..w/e Namingishard Ubuntu 1 07-28-2006 09:04 PM
sound on board plus pci slot bic Fedora 5 04-21-2006 03:11 PM
adding an extra pci slot diversitas Linux - Hardware 1 04-16-2005 02:00 PM
64 bit 66mhz pci slot hondaman Linux - Hardware 0 02-11-2005 07:18 PM


All times are GMT -5. The time now is 11:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration