LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2012, 02:09 PM   #1
hoodooman
Member
 
Registered: Oct 2006
Location: Stirling in Scotland
Distribution: Slackware 13.37 64 bit
Posts: 297

Rep: Reputation: 42
how do I disable onboard nvidia sound and use sblive card in Slack 14


Hi all.I just installed Slackware 14.The only problem I am having is that it switches sound cards every boot.The on board is an nvidia chipset which I do not want to use as it has no option for bass and treble.I want to use my SBlive card as it has the options I need.I am guessing that I need to disable the modules for the nvidia but I am unsure of how to do this.Thanks in advance.
 
Old 10-03-2012, 02:59 PM   #2
slacktroll
Member
 
Registered: May 2011
Distribution: Slackware 14.0 on Thinkpad X60
Posts: 58

Rep: Reputation: 4
Just blacklist the module used by the nvidia card in udev.

echo "driver" > /lib/modprobe.d/nvidia.conf

find out which driver it uses with lspci and lsmod.
 
Old 10-03-2012, 03:44 PM   #3
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,223

Rep: Reputation: 187Reputation: 187
You can do two things, you can disable it like slacktroll said. For my nvidia card the specific module is snd_hda_intel or you can set the sound card order so that the sblive is always the default card. See this post for more details http://www.linuxquestions.org/questi...device-713793/
 
Old 10-03-2012, 03:45 PM   #4
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Have you disabled your onboard sound in BIOS? I ask because when I've done that I've not had a problem with distros using the wrong card -- Slackware included. With both enabled, however, most distros seemed to swap the order of the cards regularly.
 
Old 10-03-2012, 03:56 PM   #5
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,223

Rep: Reputation: 187Reputation: 187
Yeah that is a good point, I missed that the first time I read the post, I am thinking of the hdmi sound on nvidia video cards, is its an onboard soundcard then there should be an option to disable it in the bios.
 
Old 10-04-2012, 08:48 AM   #6
hoodooman
Member
 
Registered: Oct 2006
Location: Stirling in Scotland
Distribution: Slackware 13.37 64 bit
Posts: 297

Original Poster
Rep: Reputation: 42
Thanks to all who replied.I will get right on it and see what I can do.
 
Old 10-04-2012, 09:56 AM   #7
hoodooman
Member
 
Registered: Oct 2006
Location: Stirling in Scotland
Distribution: Slackware 13.37 64 bit
Posts: 297

Original Poster
Rep: Reputation: 42
So I followed the guide here http://princ3.wordpress.com/2006/10/...d-under-linux/.I had to create the /etc/asound.conf file and entered the information "changing the card to Live" so suit my card.Thanks everyone.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable onboard intel graphic card on Toshiba M640 (Hybrid Intel/Nvidia) Marcelo Ruiz Linux - Laptop and Netbook 6 08-14-2010 10:59 AM
Onboard sound card MSI/nVIDIA not seen by Mint7 petsno123 Linux - Newbie 1 09-14-2009 06:15 AM
Sound issues with slack 10.2 and onboard sound chip ricardo_ok Slackware 10 08-21-2006 01:38 PM
Disable onboard sound card in Inspiron 8200 kiwidoc66 Linux - Hardware 3 08-02-2006 10:58 AM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 03:10 AM


All times are GMT -5. The time now is 10:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration