LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   how do I disable onboard nvidia sound and use sblive card in Slack 14 (http://www.linuxquestions.org/questions/slackware-14/how-do-i-disable-onboard-nvidia-sound-and-use-sblive-card-in-slack-14-a-4175430325/)

hoodooman 10-03-2012 02:09 PM

how do I disable onboard nvidia sound and use sblive card in Slack 14
 
Hi all.I just installed Slackware 14.The only problem I am having is that it switches sound cards every boot.The on board is an nvidia chipset which I do not want to use as it has no option for bass and treble.I want to use my SBlive card as it has the options I need.I am guessing that I need to disable the modules for the nvidia but I am unsure of how to do this.Thanks in advance.

slacktroll 10-03-2012 02:59 PM

Just blacklist the module used by the nvidia card in udev.

echo "driver" > /lib/modprobe.d/nvidia.conf

find out which driver it uses with lspci and lsmod.

Daedra 10-03-2012 03:44 PM

You can do two things, you can disable it like slacktroll said. For my nvidia card the specific module is snd_hda_intel or you can set the sound card order so that the sblive is always the default card. See this post for more details http://www.linuxquestions.org/questi...device-713793/

273 10-03-2012 03:45 PM

Have you disabled your onboard sound in BIOS? I ask because when I've done that I've not had a problem with distros using the wrong card -- Slackware included. With both enabled, however, most distros seemed to swap the order of the cards regularly.

Daedra 10-03-2012 03:56 PM

Yeah that is a good point, I missed that the first time I read the post, I am thinking of the hdmi sound on nvidia video cards, is its an onboard soundcard then there should be an option to disable it in the bios.

hoodooman 10-04-2012 08:48 AM

Thanks to all who replied.I will get right on it and see what I can do.

hoodooman 10-04-2012 09:56 AM

So I followed the guide here http://princ3.wordpress.com/2006/10/...d-under-linux/.I had to create the /etc/asound.conf file and entered the information "changing the card to Live" so suit my card.Thanks everyone.


All times are GMT -5. The time now is 03:53 PM.