LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2010, 07:31 PM   #1
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
How do I disable HP device manager?


I've always run as root on Slackware, but having done away with Ubuntu for now, all of my machines including the family desktop are running Slackware. There have been several ups and downs and the last one that I know of (for now) is the HP Device Manager. It doesn't run as root so I've never noticed that it drastically slows down printing via a shared printer. Disabled the system just sends it's requests to the samba/cups server and starts printing instantly. The HP Device Manager seems to go through an intialization step each time that takes several seconds before I can even hit the "print" button.
 
Old 05-02-2010, 08:08 PM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
I've always run as root on Slackware,
Sorry about not giving help to your immediate problems but - honestly this is a really bad move! You really should run as a normal user and only go to root when neccesary. Trust me - I don't run as root as that is crazy but I have messed up many systems with su commands. You really should avoid running with root permisions as it's not wise at all. The difference between root and user permissions are there for good reason - you should follow this.

Last edited by bgeddy; 05-02-2010 at 08:22 PM. Reason: Spelling
 
Old 05-02-2010, 08:34 PM   #3
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Most of my time is spent experimenting so it was fine to run as root as only root could do what it was I was doing. Now however, I need a daily use machine and I'm trying to learn better user management. This HP thing though is just getting in my way.
 
Old 05-02-2010, 08:39 PM   #4
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 490

Rep: Reputation: 207Reputation: 207Reputation: 207
Quote:
Originally Posted by damgar View Post
I've always run as root on Slackware, but having done away with Ubuntu for now, all of my machines including the family desktop are running Slackware. There have been several ups and downs and the last one that I know of (for now) is the HP Device Manager. It doesn't run as root so I've never noticed that it drastically slows down printing via a shared printer. Disabled the system just sends it's requests to the samba/cups server and starts printing instantly. The HP Device Manager seems to go through an intialization step each time that takes several seconds before I can even hit the "print" button.
Just a stab in the dark here - would it have anything to do with name resolution on the network, with names being resolved by broadcast rather than DNS or WINS? If it's just a small home network try putting the name and IP address of each computer in your hosts file, and set Samba in smb.conf to consult your hosts file before DNS or WINS or broadcast. If that solves the problem consider using a local DNS server or keep your hosts files on all machines updated. If you have Windows machines on the network set Samba to act as a Wins server and on your MS machines specify the Samba server as your WINS server (IP configuration | Advanced tab).

And I second bgeddy's advice - when I started using Linux I tended to do everything as root. It's a bad idea. Permissions tend to go astray when you install from source and such. Get into the habit of doing things as a normal user. You'll have less trouble. Su or sudo when you need elevated permissions.
 
Old 05-02-2010, 08:43 PM   #5
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
The HP Device Manager scans and initalizes. Printing via samba/cups works just fine. I have all 4 machines in /etc/hosts. The HP Device Manager seems to override the cups settings and I have to wait for it to do what seems like a handshake with the printer before I can hit the "print" button.

All warnings regarding running as root are noted, and I understand, and yes I've borked a system running as root, and yes I am trying to learn proper user/permission management.
 
Old 05-02-2010, 09:04 PM   #6
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,141

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Exclamation

Quote:
Originally Posted by bgeddy View Post
Sorry about not giving help to your immediate problems but - honestly this is a really bad move! You really should run as a normal user and only go to root when neccesary. Trust me - I don't run as root as that is crazy but I have messed up many systems with su commands. You really should avoid running with root permisions as it's not wise at all. The difference between root and user permissions are there for good reason - you should follow this.
Agreed. Running as root all the time is a bad move. damgar, you should run as a regular user and give your regular user administration privileges only as needed (security patches, software updates).
 
Old 05-02-2010, 09:09 PM   #7
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Originally Posted by hitest View Post
Agreed. Running as root all the time is a bad move. damgar, you should run as a regular user and give your regular user administration privileges only as needed (security patches, software updates).
I AM RUNNING AS A REGULAR USER! That's what causes the problem. The HP device manager doesn't run as root, so it's never been a problem. I just need help finding the stupid program so I can chmod -x it so that I can CONTINUE TO RUN AS A REGULAR USER WITHOUT GOING CRAZY!!

"ARGH!"
-Charlie Brown

LOL
 
Old 05-02-2010, 10:12 PM   #8
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 491

Rep: Reputation: 79
hplip?
 
Old 05-02-2010, 10:17 PM   #9
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,141

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
In XFce in settings---->Session and startup there is an application Autostart section where the HP System Tray Service is activated at startup by default. Maybe KDE has something like this as well. I un-check this in XFce. Have you done that?
 
Old 05-02-2010, 10:47 PM   #10
rfernandez
Member
 
Registered: Mar 2010
Location: Brazil
Distribution: Slackware64
Posts: 264

Rep: Reputation: 40
If it is hplip (I haven't understood the question), it's under

Code:
/etc/xdg/autostart
I have removed mine so it doesn't start on boot.
 
Old 05-02-2010, 10:48 PM   #11
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
I renamed hplip-systray.desktop in /etc/xdg/autostart/, but I'm not sure that's going to do what I'm looking for. This install is a little complicated due to the presence of gnome and gdm. My four year old is used to Gnome so it was a requirement. I'm going have to do a little experimenting to get this right I think. I don't have the problems in my kde sessions, but the gnome users do.
 
Old 05-03-2010, 12:31 AM   #12
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
The binary you are looking for is /usr/share/hplip/toolbox.py
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i disable network manager ? Ant1972 Linux - Newbie 2 01-17-2010 05:21 PM
I prefere networking, how to disable network-manager abd_bela Ubuntu 3 01-11-2010 05:13 AM
disable current window manager sumeet inani Linux - Newbie 12 04-26-2009 03:18 PM
how do I disable gnome screenshot manager? Virtuality Linux - Newbie 2 12-25-2007 05:15 PM
Disable Mozilla Profile Manager beajedi Linux - Software 10 01-28-2004 06:15 PM


All times are GMT -5. The time now is 08:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration