LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-23-2008, 03:45 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
How do I disable a device that was enabled in udev?


I do not want or need the /dev/md0 device. That device is enabled in 50-udev.rules. I could comment that line, but if I understand correctly, that configuration file gets overwritten with updates. My understanding is to create a 99-local.rules file. But how to disable within that file after the device is enabled?

Thanks.
 
Old 03-23-2008, 06:49 PM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
that is your raid device.

do you use raid?

if not in grub you can add noraid to your kernel line....should be able to do the same to lilo?
 
Old 03-29-2008, 04:23 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
that is your raid device. do you use raid?
No. I have disabled raid/lvm in my kernel build too. So I'm unsure why this device node is created.
 
Old 03-29-2008, 06:40 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
What about the other 700+ devices created?
Code:
mingdao@silas:~$ ls -l /dev/ | wc
    759    7460   50576


I use RAID/LVM in my kernel and don't have /dev/md0:
Code:
root@silas:~# ls -l /dev/md*
/bin/ls: cannot access /dev/md*: No such file or directory

mingdao@silas:~$ sudo /sbin/vgdisplay
  --- Volume group ---
  VG Name               vg
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  4
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                3
  Open LV               3
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               37.25 GB
  PE Size               4.00 MB
  Total PE              9536
  Alloc PE / Size       4864 / 19.00 GB
  Free  PE / Size       4672 / 18.25 GB
  VG UUID

Last edited by Bruce Hill; 03-29-2008 at 06:50 PM.
 
Old 03-29-2008, 07:07 PM   #5
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
slackware uses lilo last time I checked...try adding a append noraid option to it and rerun lilo

http://www.linuxquestions.org/questi...18#post3095418
is an example.

but I am not a lilo fan.
 
Old 03-29-2008, 08:03 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Huh. Well, never mind! Apparently my memory is not so good between weekends. Last weekend I recompiled my kernel without raid/lvm support, but I forgot to check on the existence of /dev/md0 with respect to this thread. The device no longer exists. In othr words: problem solved. My apologies for not being more methodical!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
udev and a new device jmoody Linux - Software 12 10-11-2007 12:32 PM
sharing internet with bluetooth-enabled device a550ee Linux - Networking 0 07-14-2007 05:00 AM
Udev rules not holding for device binarybob0001 Linux - Software 6 04-14-2007 04:04 PM
Can I disable rc.udev with 2.4 kernel shepper Slackware 2 09-18-2005 08:45 PM
bad super-block message when udev is enabled LSA Slackware 1 11-03-2004 06:26 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration