LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-30-2005, 07:48 PM   #1
bad_andy
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1/Slackware 10.0
Posts: 154

Rep: Reputation: 30
Unhappy How come my CD eject button doesn't work?


I guess it's one of those things you take for granted, but when I mount my CD drive, I can't eject it afterwards. What do I need to do to get this convenient feature working?
 
Old 01-30-2005, 07:53 PM   #2
slackMeUp
Member
 
Registered: Nov 2003
Distribution: Slack-where?
Posts: 654

Rep: Reputation: 30
You will need to unmount it, it's that simple.

Once the CD is not mounted... you can even eject it from the command line.

#eject

-or-

#eject /dev/hdx

(where x is your CDrom device if you have more then one)

Don't like it? You can always use submount. (I do, and love it.)
 
Old 01-30-2005, 08:10 PM   #3
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Urr you can even eject it if it is mounted right? I mean it will unmount for you first before ejecting.

To bring back the tray into the cdrom use
Code:
eject -t
 
Old 01-30-2005, 08:16 PM   #4
bad_andy
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1/Slackware 10.0
Posts: 154

Original Poster
Rep: Reputation: 30
Why can't I just press the button???
 
Old 01-30-2005, 08:19 PM   #5
Social Burn
LQ Newbie
 
Registered: Aug 2004
Location: Indiana, Pennsylvania
Distribution: Slackware 8.1, 9.1, 10.0, 10.1, Slamd64
Posts: 11

Rep: Reputation: 0
Quote:
Originally posted by bad_andy
Why can't I just press the button???
Because you have a filesystem mounted.

FFS man just type umount /mnt/xxxxxx (where xxxxxx is the mount point).
 
Old 01-30-2005, 08:28 PM   #6
slackMeUp
Member
 
Registered: Nov 2003
Distribution: Slack-where?
Posts: 654

Rep: Reputation: 30
Quote:
Originally posted by carboncopy
Urr you can even eject it if it is mounted right? I mean it will unmount for you first before ejecting.

To bring back the tray into the cdrom use
Code:
eject -t
ERR... No. (well yes, but still)

While eject can and will unmount the CDrom drive for you... it will only do so if you are root. (By default that is.)

Which leaves me at this point:
While the CDrom is mounted, you can not 'press the button'.

Why? because that would be silly. . . hehe
 
Old 01-30-2005, 08:29 PM   #7
bad_andy
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1/Slackware 10.0
Posts: 154

Original Poster
Rep: Reputation: 30
Can I do it so the CD unmounts itself when I press the button?
 
Old 01-30-2005, 08:35 PM   #8
slackMeUp
Member
 
Registered: Nov 2003
Distribution: Slack-where?
Posts: 654

Rep: Reputation: 30
Quote:
Originally posted by bad_andy
Can I do it so the CD unmounts itself when I press the button?


Sure you can, as long as you release the code under the GPL afterward I'll be happy.

hehe...

I will now point out part of my first post in this thread... because you clearly did not read it.

SUBMOUNT
 
Old 01-30-2005, 09:01 PM   #9
bad_andy
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1/Slackware 10.0
Posts: 154

Original Poster
Rep: Reputation: 30
lol....you're right, I didn't read it. I'll check it out and get back to you.
 
Old 01-30-2005, 09:44 PM   #10
slackMeUp
Member
 
Registered: Nov 2003
Distribution: Slack-where?
Posts: 654

Rep: Reputation: 30
Well if you need any help with it... don't be afraid to ask.
 
Old 01-30-2005, 09:50 PM   #11
bad_andy
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1/Slackware 10.0
Posts: 154

Original Poster
Rep: Reputation: 30
Well, since you offered....

The module has been created, and it loads when I "modprobe subfs". Problem is, when I restart the computer, it's not automatically loaded (meaning, it's not in lsmod).

What am I missing?
 
Old 01-30-2005, 09:55 PM   #12
slackMeUp
Member
 
Registered: Nov 2003
Distribution: Slack-where?
Posts: 654

Rep: Reputation: 30
add it to your "/etc/rc.d/rc.local" file... as a startup command.
(ex. #modprobe subfs)

Then just define your CDrom drive in "/etc/fstab" as a FS type of 'subfs'... well there's a bit more to it then that, but just fallow the online docs.
 
Old 01-30-2005, 10:08 PM   #13
bad_andy
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1/Slackware 10.0
Posts: 154

Original Poster
Rep: Reputation: 30
Ok, got the modules to load at boot, but now while trying to mount the cdrom, I get an "bad fstab" error. My fstab now reads "/dev/sr0 /mnt/cdrw1 subfs fs=iso9660 noauto,users,ro 0 0".

What's wrong with that???
 
Old 01-30-2005, 10:18 PM   #14
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
I think the cdrom entry in fstab should look something like this:

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,users,ro 0 0
(of course with the spaces)
What is sr0 ?
 
Old 01-30-2005, 10:41 PM   #15
slackMeUp
Member
 
Registered: Nov 2003
Distribution: Slack-where?
Posts: 654

Rep: Reputation: 30
bad_andy,
You have an extra space there.... fs=iso9660 is an option, and should be listed as one, not on it's own like you seem to have it.

should look like. . .
Code:
/dev/sr0 /mnt/cdrw1 subfs fs=iso9660,users,ro 0 0
Also, there is no point in putting 'noauto' as an option... considering that you need to mount the subfs at boot to be able to use it.

Now, if all works out fine, all you have to do to mount a CD would be to enter '/mnt/cdrw1' via command line or any file browser. And to unmount, just press the button... so you kinda have the same effect of Windows when it comes to dealing with the CDrom.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling CD-ROM drive eject button Nobber Linux - Hardware 16 06-05-2009 10:45 AM
xine: vcd eject button pressed BUT still VCD does not goes out.. ic_torres Linux - Hardware 2 12-02-2005 03:03 AM
VCD does not eject even eject button pressed ic_torres Linux - Software 4 12-01-2005 06:40 PM
eject cd-rom drive using (gasp) the button on the front pcweirdo Linux - Hardware 3 12-26-2004 08:28 PM
xmms eject button doesn't itsjustme Slackware 8 05-20-2003 01:42 PM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration