LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-02-2004, 02:34 PM   #1
JulianS
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
How can I start gnome?


How can I start gnome with slackware? I mean, after installing and then rebooting you get to a console. So what do you do from that console to start gnome?

- Julian
 
Old 03-02-2004, 02:38 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
Type in "startx" - minus the quotes. Of course, this assumes that you set Gnome as the default desktop. If not, run xwmconfig, set Gnome and then do startx.
 
Old 03-02-2004, 02:51 PM   #3
JulianS
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 44

Original Poster
Rep: Reputation: 15
I'm a newbie, so don't take it bad, but I don't know how to run xwmconfig? I mean like:

shell xwmconfig

run xwmconfig

or just:

xwmconfig



Please help me. Thanks.

- Julian
 
Old 03-02-2004, 03:01 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
Type in the following:

xwmconfig

In the window/menu which opens up, use the cursor keys to highlight your choice, press space to select your choice (a capital X will appear next to it), press space to ok your choice. The menu will close.

Type the following to start it:

startx

man xwmconfig
man startx
for more help.
 
Old 03-02-2004, 03:19 PM   #5
JulianS
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 44

Original Poster
Rep: Reputation: 15
I select it, even though it doesn't go capital(continues to be lower case). So when I say ok and do:
startx

it doesn't work, maybe this is because I didn't select one at all, I think the reason to why it doesn't become capital when I press space is because I don't use the US keyboard, I use DK.

So what now?

- Julian
 
Old 03-02-2004, 03:31 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
well, if you don't select it, it won't work.

have you tried typing startx? what happens? do you get an error message?

BTW, I also don't use the US keyboard - mine is UK and as far as i know, space is space on all keyboards
 
Old 03-02-2004, 03:37 PM   #7
JulianS
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 44

Original Poster
Rep: Reputation: 15
Well, when I press the space it goes from ok to cancel or vice-versa.
So, what do I do? I mean selecting it with the mouse doesn't make any differece.

- Julian
 
Old 03-02-2004, 03:47 PM   #8
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
press enter
 
Old 03-02-2004, 07:11 PM   #9
linuxnut2003
Member
 
Registered: Nov 2003
Location: Oklahoma, USA
Distribution: gentoo
Posts: 73

Rep: Reputation: 15
another way to switch to gnome is type
Code:
 switchdesk gdm 
or 
switchdesk gnome
atm i am not at my linux box or i could tell you for sure

Last edited by linuxnut2003; 03-02-2004 at 07:13 PM.
 
Old 03-02-2004, 07:41 PM   #10
nvn
Member
 
Registered: Apr 2003
Location: Sweden
Distribution: Slackware
Posts: 242

Rep: Reputation: 30
Hmm...switchdesk sounds very RH'ish. Doubt it's there in Slack.
 
Old 03-03-2004, 07:22 AM   #11
JulianS
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 44

Original Poster
Rep: Reputation: 15
When I checked with Pkg tool it showed up, so it must be there, or is it?
So can somebody give me a step-by-step guide on how to install gnome and run gnome by using nothing then the basic system.

- Julian
 
Old 03-03-2004, 07:49 AM   #12
nvn
Member
 
Registered: Apr 2003
Location: Sweden
Distribution: Slackware
Posts: 242

Rep: Reputation: 30
Did you install from official ISO images?
Did you get the images for CD 1 and CD 2?
Did you select "Full install"?
Did you insert CD 2 when prompted?

The above is probably standard procedure and it installs pretty much everything - including gnome. Then after rebooting, all you should have to do to get gnome up and running is to select it in xwmconfig (if you didn't already do that during the installation process), set up your XF86Config (by xf86config, xfree86setup or manually), and then startx.
 
Old 03-04-2004, 08:02 AM   #13
JulianS
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 44

Original Poster
Rep: Reputation: 15
I reinstalled it and it worked. Thanks for helping me.

- Julian
 
Old 03-04-2004, 01:00 PM   #14
dbauder
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-Current
Posts: 12

Rep: Reputation: 0
Another option is to edit/create the .xinitrc file in your home directory. If you add the following line:

Code:
exec gnome-session
It will start gnome when you start up X. If the file already exists, be sure to comment out any other lines that would start a different window manager/desktop, i.e.:

Code:
exec startkde
exec wmaker
exec blackbox
exec fluxbox
you get the idea
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome-panel won't start after upgrade to GNOME 2.6 computergeek84 Debian 5 08-12-2007 01:37 PM
I want gnome! My gnome doesnt start anymore! :( maginotjr Slackware 2 07-09-2005 03:06 PM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 08:53 PM
gnome 2.6 will not start TheOneAndOnlySM Slackware 5 05-10-2004 09:48 PM
getting gnome to start JamminJ Linux - Newbie 4 07-04-2003 01:18 PM


All times are GMT -5. The time now is 01:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration