LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-23-2009, 10:03 AM   #1
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
How can I set the default audio device?


I recently built myself a computer and I'm running Slackware -current on it. My slight dilemma is that it has three audio devices and for the life of me, I can't figure out how to set one as the standard default.

The devices are:

1) Intel 82801JI (ICH10) which uses the snd_hda_intel module
2) ATI HD48x0 audio (which I'm not using at the moment)
3) Logitech USB headset


I want the Intel to be the default audio, however if I boot with the USB headset plugged in, it is always grabs the default, and the Intel audio is secondary. Since I don't always have the headset plugged in (and I want the Intel to be the default regardless), this causes a problem.

I tried running the following in my /etc/modprobe.d/sound file, but if the options line is there, the Intel chip simply isn't found (the exact error is "hda-intel: error creating card").

Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel index=0

From the googling I've done, I thought this would be the answer, but obviously not so, so any suggestions would be very welcomed.
 
Old 03-23-2009, 01:28 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,333

Rep: Reputation: 143Reputation: 143
You can try blacklisting the modules used by the Logitech USB headset by editing the /etc/modprobe.d/blacklist file.
 
Old 03-23-2009, 01:38 PM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Original Poster
Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Sorry, I probably should have been clearer. I need to use both the Intel soundcard and the USB headset, so disabling the headset isn't what I'm after.
 
Old 03-23-2009, 02:32 PM   #4
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
I wonder if you're getting the error "hda-intel: error creating card" because by the time the hda-intel device is recognized, some other audio device has already been assigned to index slot 0. What happens if you create alias and options lines for your other audio devices as well, with index=1 and index=2 for the other devices?
 
1 members found this post helpful.
Old 03-23-2009, 04:42 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Original Poster
Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by DavidHindman View Post
I wonder if you're getting the error "hda-intel: error creating card" because by the time the hda-intel device is recognized, some other audio device has already been assigned to index slot 0. What happens if you create alias and options lines for your other audio devices as well, with index=1 and index=2 for the other devices?
THANK YOU! That definitely did the trick. Just for posterity, my /etc/modprobe.d/sound looks like this:

Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel index=0
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio
options snd-usb-audio index=1
 
1 members found this post helpful.
Old 03-23-2009, 04:48 PM   #6
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,225

Rep: Reputation: 187Reputation: 187
I've also used this method before and it works
http://princ3.wordpress.com/2006/10/...d-under-linux/

Ignore this method, use the above

Last edited by Daedra; 03-28-2011 at 09:29 PM.
 
Old 03-23-2009, 05:16 PM   #7
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
Quote:
Originally Posted by Daedra View Post
I've also used this method before and it works
http://princ3.wordpress.com/2006/10/...d-under-linux/
I'd like to add a caution about using the method described in that article. That's the method that uses ~/.asoundrc or /etc/asound.conf to establish the default alsa audio device. It works for most sound applications, but not all. Specifically, it doesn't always work with Adobe Flash video players versions 9 and above. The symptom that's usually reported is that Youtube has video but has no sound.

I haven't found a workaround for the incompatibility of Flash versions 9+ with default audio devices defined in ~/.asoundrc and /etc/asound.conf.
 
1 members found this post helpful.
Old 03-24-2009, 08:30 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Original Poster
Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I was making the assumption that the .asoundrc approach was pretty much rendered obsolete by HAL. I never found a definitive article, but that seemed to be the gist of what I was reading.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
set default network device Utapez Linux - Wireless Networking 2 05-18-2006 08:54 PM
How can I set a newly installed soundcard as the default audio device? Crushing Belial Linux - Hardware 2 12-23-2005 10:55 PM
How to pipe the default audio h/w device directly to hw:0,2 Erin Linux - Software 3 04-16-2005 12:55 PM
Set default ALSA device redneon Linux - Software 2 06-01-2004 10:02 AM
change default audio device (debian woody) zhynn Debian 3 07-04-2003 05:35 PM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration