LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2013, 05:28 PM   #1
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Rep: Reputation: Disabled
Hint: Num Lock on


I have a problem with Salix, and already asked on their forum without gettings an answer yet. Since Salix is based on Slackware I think this could be related to Slackware, too.

On the console between issue and the login prompt I always get the message "Hint: Num Lock on".

Where does this message come from, and is it possible to deactivate this message?

On a notebook it can be quite helpful, even if there's a num lock indicator light, too, but on a desktop I don't like it too much, because the numeric keypad is separated and the num lock indicator light is seen a lot better.
 
Old 02-01-2013, 06:01 PM   #2
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 875

Rep: Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819
Quote:
Originally Posted by cyberpatrol View Post
I have a problem with Salix, and already asked on their forum without gettings an answer yet. Since Salix is based on Slackware I think this could be related to Slackware, too.
Nope.
 
2 members found this post helpful.
Old 02-01-2013, 06:45 PM   #3
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Thanks anyway.
 
Old 02-01-2013, 09:41 PM   #4
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
I think I should post the solution I found anyway. Adding the parameter --nohints to the agetty commands in /etc/inittab disables the hints about Num, Caps and Scroll Locks.
 
3 members found this post helpful.
Old 06-19-2013, 04:28 PM   #5
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Sorry for necrobumping this thread, but another (perhaps more practical) solution is to use setleds to turn numlock on/off as you login/logout. Great for people who like to keep numlock on.

In ~/.bash_profile:
Code:
# Turn on numlock:
if [ -z "$DISPLAY" ]; then
    setleds +num > /dev/null 2>&1
fi
In ~/.bash_logout:
Code:
# Turn off numlock:
if [ -z "$DISPLAY" ]; then
    setleds -num > /dev/null 2>&1
fi
 
Old 06-19-2013, 04:41 PM   #6
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by i_joh View Post
Sorry for necrobumping this thread, but another (perhaps more practical) solution is to use setleds to turn numlock on/off as you login/logout. Great for people who like to keep numlock on.

In ~/.bash_profile:
Code:
# Turn on numlock:
if [ -z "$DISPLAY" ]; then
    setleds +num > /dev/null 2>&1
fi
In ~/.bash_logout:
Code:
# Turn off numlock:
if [ -z "$DISPLAY" ]; then
    setleds -num > /dev/null 2>&1
fi
This was not the problem. The problem was the message which was always printed by agetty, when numlock was turned on. The question was not how to turn numlock on or off. And it was not a bash, but an agetty issue.
 
1 members found this post helpful.
Old 06-19-2013, 04:48 PM   #7
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
If .bash_logout turns off numlock you won't see the message. No editing inittab then.
 
Old 06-19-2013, 05:59 PM   #8
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by i_joh View Post
If .bash_logout turns off numlock you won't see the message. No editing inittab then.
And what if I want to have numlock turned on? And what if I am just annoyed about this message, because I have a LED on my keyboard that shows me that numlock is turned on? That's the problem.

But if you had read my original post, you would have known that.
 
Old 06-19-2013, 06:08 PM   #9
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Quote:
And what if I want to have numlock turned on?
I gave you the solution to that problem.

Quote:
And what if I am just annoyed about this message
I gave you the solution to that problem too.

Quote:
But if you had read my original post, you would have known that.
Now you're just being difficult. Forget the whole thing and let other people use the solution then if you don't get it. Sheesh.
 
Old 06-20-2013, 12:15 AM   #10
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by i_joh View Post
I gave you the solution to that problem.
You told me how to disable numlock. The question was not how to disable numlock, because I want to have numlock enabled.

Quote:
Originally Posted by i_joh View Post
I gave you the solution to that problem too.
You didn't give me a solution to that problem. To deactivate the message you just need to start agetty with the parameter --nohints.

Quote:
Originally Posted by i_joh View Post
Now you're just being difficult. Forget the whole thing and let other people use the solution then if you don't get it. Sheesh.
You are the one who is difficult. I guess you don't want to or can't understand my original post. But never mind. The solution to the problem is in my third post, and repeated in this post.
 
Old 06-20-2013, 10:01 AM   #11
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Please do not assume that the entire community of the internet is here at your personal service. You lost the sole ownership to the text contained in your post the moment you clicked 'submit thread/reply', from there on enabling anyone on the internet to read your post and make use of the information contained within it.

My solution, while somewhat alternative, is not irrelevant to the issue, and I do believe anyone with a positive attitude (read: who is not a troll) and who do not just simply have their minds irrationally and obsessively set on modifying the behaviour of agetty itself instead of just as well working around the issue, will be able to see just how it can be useful to them.

That said, I do not intend to post any further replies as I have concluded that you are indeed a troll. I can only hope that you learn something from what I just wrote, although I realize I may be overly optimistic.
 
Old 06-20-2013, 10:16 AM   #12
cyberpatrol
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by i_joh View Post
as I have concluded that you are indeed a troll.
Question is: Who is the troll? The one who opened a thread with a very specific question, and who posted the solution to this question? Or the one who posted a solution to a completely different problem in this thread after the issue was already solved, and tells something about the owner of the internet?
 
Old 06-20-2013, 10:58 AM   #13
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
I have no idea what is going on in this thread. The solution posted by the OP did, indeed, solve the posted problem and was confirmed. So, if you are a Salix user and do not wish to see the num lock message, post #4 is the post for you!

The other fix posted would have solved a slightly different issue that wasn't posted but is also useful to know for people that find that sort of knowledge useful.

Still don't know why the argument, but hey, I'm not the one with a num lock obsession either.....
 
1 members found this post helpful.
Old 06-20-2013, 11:16 AM   #14
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Quote:
On the console between issue and the login prompt I always get the message "Hint: Num Lock on".

Where does this message come from, and is it possible to deactivate this message?
There are two ways of resolving this issue if you're the type who likes to keep numlock on and hates this nag.

1: Modify agetty's behaviour
2: Keep numlock off while agetty is running.

OP chose solution 1. I chose solution 2 while relieving myself of ever having to turn on numlock again manually, thus keeping mp3blaster from locking up as I press the numeric keys with numlock off.

While issues like these may seem trivial, we're just making use of the endless possibilities of customizing a Linux system. Wallpapers are just as trivial.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Num lock OFF and Caps & Screen Lock ON at Linux startup. Reversing? peteyperson Linux - Newbie 2 02-28-2009 12:44 PM
Caps lock, Num Lock notification applications tuxedup Linux - Desktop 2 03-02-2008 06:23 PM
Caps Lock and Num Lock leds dont work! npc Linux - Hardware 2 11-08-2005 11:40 AM
Num, Scroll, Caps/Lock all Lock up Slackware Zamochit Linux - Newbie 0 10-18-2004 08:47 PM
num lock chrismiceli Linux - General 18 12-16-2002 09:26 PM


All times are GMT -5. The time now is 07:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration