LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Hint: Num Lock on (http://www.linuxquestions.org/questions/slackware-14/hint-num-lock-on-4175448239/)

cyberpatrol 02-01-2013 04:28 PM

Hint: Num Lock on
 
I have a problem with Salix, and already asked on their forum without gettings an answer yet. Since Salix is based on Slackware I think this could be related to Slackware, too.

On the console between issue and the login prompt I always get the message "Hint: Num Lock on".

Where does this message come from, and is it possible to deactivate this message?

On a notebook it can be quite helpful, even if there's a num lock indicator light, too, but on a desktop I don't like it too much, because the numeric keypad is separated and the num lock indicator light is seen a lot better.

volkerdi 02-01-2013 05:01 PM

Quote:

Originally Posted by cyberpatrol (Post 4882611)
I have a problem with Salix, and already asked on their forum without gettings an answer yet. Since Salix is based on Slackware I think this could be related to Slackware, too.

Nope.

cyberpatrol 02-01-2013 05:45 PM

Thanks anyway.

cyberpatrol 02-01-2013 08:41 PM

I think I should post the solution I found anyway. Adding the parameter --nohints to the agetty commands in /etc/inittab disables the hints about Num, Caps and Scroll Locks.

i_joh 06-19-2013 03:28 PM

Sorry for necrobumping this thread, but another (perhaps more practical) solution is to use setleds to turn numlock on/off as you login/logout. Great for people who like to keep numlock on.

In ~/.bash_profile:
Code:

# Turn on numlock:
if [ -z "$DISPLAY" ]; then
    setleds +num > /dev/null 2>&1
fi

In ~/.bash_logout:
Code:

# Turn off numlock:
if [ -z "$DISPLAY" ]; then
    setleds -num > /dev/null 2>&1
fi


cyberpatrol 06-19-2013 03:41 PM

Quote:

Originally Posted by i_joh (Post 4974963)
Sorry for necrobumping this thread, but another (perhaps more practical) solution is to use setleds to turn numlock on/off as you login/logout. Great for people who like to keep numlock on.

In ~/.bash_profile:
Code:

# Turn on numlock:
if [ -z "$DISPLAY" ]; then
    setleds +num > /dev/null 2>&1
fi

In ~/.bash_logout:
Code:

# Turn off numlock:
if [ -z "$DISPLAY" ]; then
    setleds -num > /dev/null 2>&1
fi


This was not the problem. The problem was the message which was always printed by agetty, when numlock was turned on. The question was not how to turn numlock on or off. And it was not a bash, but an agetty issue.

i_joh 06-19-2013 03:48 PM

If .bash_logout turns off numlock you won't see the message. No editing inittab then.

cyberpatrol 06-19-2013 04:59 PM

Quote:

Originally Posted by i_joh (Post 4974974)
If .bash_logout turns off numlock you won't see the message. No editing inittab then.

And what if I want to have numlock turned on? And what if I am just annoyed about this message, because I have a LED on my keyboard that shows me that numlock is turned on? That's the problem.

But if you had read my original post, you would have known that.

i_joh 06-19-2013 05:08 PM

Quote:

And what if I want to have numlock turned on?
I gave you the solution to that problem.

Quote:

And what if I am just annoyed about this message
I gave you the solution to that problem too.

Quote:

But if you had read my original post, you would have known that.
Now you're just being difficult. Forget the whole thing and let other people use the solution then if you don't get it. Sheesh.

cyberpatrol 06-19-2013 11:15 PM

Quote:

Originally Posted by i_joh (Post 4975031)
I gave you the solution to that problem.

You told me how to disable numlock. The question was not how to disable numlock, because I want to have numlock enabled.

Quote:

Originally Posted by i_joh (Post 4975031)
I gave you the solution to that problem too.

You didn't give me a solution to that problem. To deactivate the message you just need to start agetty with the parameter --nohints.

Quote:

Originally Posted by i_joh (Post 4975031)
Now you're just being difficult. Forget the whole thing and let other people use the solution then if you don't get it. Sheesh.

You are the one who is difficult. I guess you don't want to or can't understand my original post. But never mind. The solution to the problem is in my third post, and repeated in this post.

i_joh 06-20-2013 09:01 AM

Please do not assume that the entire community of the internet is here at your personal service. You lost the sole ownership to the text contained in your post the moment you clicked 'submit thread/reply', from there on enabling anyone on the internet to read your post and make use of the information contained within it.

My solution, while somewhat alternative, is not irrelevant to the issue, and I do believe anyone with a positive attitude (read: who is not a troll) and who do not just simply have their minds irrationally and obsessively set on modifying the behaviour of agetty itself instead of just as well working around the issue, will be able to see just how it can be useful to them.

That said, I do not intend to post any further replies as I have concluded that you are indeed a troll. I can only hope that you learn something from what I just wrote, although I realize I may be overly optimistic.

cyberpatrol 06-20-2013 09:16 AM

Quote:

Originally Posted by i_joh (Post 4975394)
as I have concluded that you are indeed a troll.

Question is: Who is the troll? The one who opened a thread with a very specific question, and who posted the solution to this question? Or the one who posted a solution to a completely different problem in this thread after the issue was already solved, and tells something about the owner of the internet?

XavierP 06-20-2013 09:58 AM

I have no idea what is going on in this thread. The solution posted by the OP did, indeed, solve the posted problem and was confirmed. So, if you are a Salix user and do not wish to see the num lock message, post #4 is the post for you!

The other fix posted would have solved a slightly different issue that wasn't posted but is also useful to know for people that find that sort of knowledge useful.

Still don't know why the argument, but hey, I'm not the one with a num lock obsession either.....

i_joh 06-20-2013 10:16 AM

Quote:

On the console between issue and the login prompt I always get the message "Hint: Num Lock on".

Where does this message come from, and is it possible to deactivate this message?
There are two ways of resolving this issue if you're the type who likes to keep numlock on and hates this nag.

1: Modify agetty's behaviour
2: Keep numlock off while agetty is running.

OP chose solution 1. I chose solution 2 while relieving myself of ever having to turn on numlock again manually, thus keeping mp3blaster from locking up as I press the numeric keys with numlock off.

While issues like these may seem trivial, we're just making use of the endless possibilities of customizing a Linux system. Wallpapers are just as trivial.


All times are GMT -5. The time now is 01:46 AM.