LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2003, 11:23 AM   #16
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30

when i go into lynx it reports that not connected to remote host

and this is what comes one the screen when i type iwconfig

ieee 802.11-ds essid:"haugstadbo" Nickname:"prism I"
mode:managed frequency:2.412GHz accsess point:44:44:44:44:44:44
bit rate:2mb/s tx-power=15dbm sensitivity:1/3
retry min limit:8 rts thrff fragment thr: off
encryption key:2132-1321-0000-0000-00 encryption modepen
power managementff
link quality:0/92 signal level:134/153 noise level: 134/153
rx invalid nwid:0 rx invalid crypt:0 rx invalid frag:0
tx execessive retrives:0 invalid misc:0 missed beacon:0
 
Old 04-23-2003, 11:23 AM   #17
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
all the faces means : off
 
Old 04-23-2003, 01:23 PM   #18
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
The line I put in there:

iwconfig eth1 enc 123123123213

Was just for if you are actually running encryption, it was an example, you didn't need to actually use that... If your node is wide open the only lines of the 4 you will need are the first one to bring the device up and the last one to grab a dhcp lease.

Cheers,

Finegan
 
Old 04-23-2003, 01:30 PM   #19
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
singnal level i now -49dbm and i still cannot connect to remote host
 
Old 04-23-2003, 01:32 PM   #20
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
What's iwconfig eth1 say now though?

Cheers,

Finegan
 
Old 04-23-2003, 01:41 PM   #21
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
the same exept
acsess point :00:30:65:05:3a:d3
link qaulity:52/92
signal level:-50 dbm
noise level:-146dbm
 
Old 04-23-2003, 02:05 PM   #22
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Okay, its registered the MAC address of the access point and its got a solid signal, now you have to deal with the ethernet aspect of device:

dhcpcd eth1

Will grab an address from a wireless router running a dhcp server, otherwise you have to add those settings by hand, most easily done by using the command:

netconfig

Although really this will do it to:

ifconfig eth1 192.168.1.23 up (the IP is a guess)
route add default gw 192.168.1.1 (the router's IP is a guess too, although this is so standard as to be called a "highly" educated guess.)

nameservers is the annoying part:

echo "nameserver 123.123.123.123" >> /etc/resolv.conf

Your ISP has name servers... the router has them listed in it somewhere, gotta find those numbers. Of course... nearly every wireless router on the planet is broadcasting a dhcp signal.

Cheers,

Finegan
 
Old 04-23-2003, 02:33 PM   #23
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
when i try the
route add default gw 192.168.1.1
this message comes
default: host name look up failure

i have an norwegian keyboard and i dont know the keyboard remap code so i cant remap my keyboard what is the command
 
Old 04-23-2003, 02:34 PM   #24
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
i want to now this command beacause i cant make the " symbol
 
Old 04-23-2003, 04:32 PM   #25
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
This should work too:

echo 'nameserver 123.123.123.123' >> /etc/resolv.conf

Odd that your wireless router isn't running dhcp... that makes it pretty unique.

To switch keymaps, look into the command: loadkeys

Cheers,

Finegan
 
Old 04-24-2003, 09:21 AM   #26
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
now all the command's worked
but when i go into lynx
this message comes
looking up lynx.browser.org
could not connect to remote host
and i tried lynx www.sol.no:
looking up www.sol.no
after awhile
looking up www.sol.no ,guessing
unable to open document

what shall i do now
 
Old 04-24-2003, 09:22 AM   #27
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
i got the route default command to work to
 
Old 04-25-2003, 10:16 AM   #28
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Original Poster
Rep: Reputation: 30
i had a friend over and he fixed it thx anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
machine has adsl ethernet modem, to make it gateway over lan do i need more lan cards b0nd Linux - Networking 2 10-04-2005 10:19 PM
Fast WAN slow LAN Slack 9.x - 10.x Grunthos Slackware 5 09-28-2005 03:58 AM
slack 10.0 intel PRO/Wireless LAN 2100 pgrimes Linux - Wireless Networking 1 10-06-2004 10:40 AM
Setting up my wireless LAN internet on my slack laptop :D Belize Linux - Wireless Networking 17 10-04-2003 01:15 PM
Can't get slack to recognize onboard lan fsu_slacker Linux - Networking 26 08-11-2003 10:09 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration