LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   HELP with dual booting LILO slackware 10.2 (http://www.linuxquestions.org/questions/slackware-14/help-with-dual-booting-lilo-slackware-10-2-a-389952/)

v@ny@ 12-06-2005 05:11 PM

HELP with dual booting LILO slackware 10.2
 
Hello!
I installed slackware 10.2 today and I'm full of questions! The most important to solve now is the booting... I used a new HDD 60GB. Using fdisk I created the partitons:
hda1 - 1GB - linux swap
hda2 - 10GB - linux *bootable
hda3 - 30GB - fat(windows)
hda4 - "the rest" - /home
My intention was to use hda4 to create an extented partiton and then creating a fith partition of 1GB for transfering files btw the two O/S but I couldn't work it out how to do it. Anyway, after I had my slackware installed and running I used LILO to load Linux (at this stage hda3 was empty). Now I installed windows and it has changed my boot and when I turn the computer on it loads Windows automatic! Does anyone know how to get my LILO back at boot and add windows to LILO?
The slackware handbook was useful during installation but it only covered very basic aspects. I still have a lot of problems ot solve, so if anyone knows a good slackware for begginers site let me know too ;)!
Thanks!

rkelsen 12-06-2005 06:36 PM

Quote:

Originally Posted by v@ny@
Now I installed windows and it has changed my boot and when I turn the computer on it loads Windows automatic! Does anyone know how to get my LILO back at boot and add windows to LILO?

Yep. Windows overwrites the MBR upon installation.

Anyhow, getting onto your problem:

Step 1. Boot from the Slackware Install CD (Disc 1)

Step 2. At the 'boot:' prompt, enter this:
Code:

bare.i root=/dev/hda2 noinitrd ro 1
Don't worry if it complains about missing modules.

Step 3. At the login prompt, log in as root.

Step 4. At the command prompt, do this:
Code:

# cat << EOF >> /etc/lilo.conf
> other=/dev/hda3
>  label=windows
>  table=/dev/hda
> EOF
# /sbin/lilo

Step 5. Remove the CD and then:
Code:

# reboot
And you should be golden.

Note: Most Linux distros do not need the "bootable" flag on their root partition. However, Windows requires it.

v@ny@ 12-07-2005 03:12 AM

During the installation I could not install LILO in the MBR, it gave me some error. So I installed it in the root partition. I'll give it a go anyway and post the result ;)! Thanks

Azmeen 12-07-2005 03:19 AM

If you're using Windows XP (or any of the NT series Win32), then bootpart will be your best friend.

v@ny@ 12-07-2005 03:57 AM

I tried to use the commands, I got no error messages but after reboot... Windows! No choice! I tryed boot part and I could not get it to work. I am thinking... What if I format the partition where I have slackware installed and re-install it? Will this get my LILO back at boot?

Azmeen 12-07-2005 04:31 AM

Quote:

Originally Posted by v@ny@
I tried to use the commands, I got no error messages but after reboot... Windows! No choice! I tryed boot part and I could not get it to work. I am thinking... What if I format the partition where I have slackware installed and re-install it? Will this get my LILO back at boot?

Reinstalling will not bring you any benefits. For one thing, you installed LILO on to your Linux partition, not the MBR.

Using bootpart will get you a working system without the need to reinstall. All it takes is a few minutes of your time to actually read through the documentation.

It took me barely five minutes to get mine working from download to booting... but then I'm a bloody genius :P. However, even for mere mortals, it wouldn't take more than 15-20 minutes. It really is that easy!

v@ny@ 12-07-2005 06:02 AM

I actually read through the documentation and actually tryed to google out the answer but nothing. The problem with bootpart is that manage to get a boot option at the start, when I turn the computer on, but when I choose to boot Linux I get a message saying it could not boot from HDD please insert a disk and press any key to continue...
???????????????????????????????????????????????????????????????????????????

v@ny@ 12-07-2005 06:42 AM

I removed the changes with the command:

bootpart remove "number of entry in boot.ini"

v@ny@ 12-07-2005 07:50 AM

I solved the problem following the instructions I found in this link:

http://www.tldp.org/HOWTO/Linux+NT-Loader.html

Execpt I copied the bootsect.lnx to the windows partition trough a GUI (my windows partition is a FAT 32).

rkelsen 12-07-2005 04:52 PM

Quote:

Originally Posted by v@ny@
During the installation I could not install LILO in the MBR, it gave me some error. So I installed it in the root partition.

It won't work unless you install it to the MBR.

Please post the error you get.

Azmeen 12-07-2005 05:05 PM

Quote:

Originally Posted by rkelsen
It won't work unless you install it to the MBR.

Please post the error you get.

That is not true. Please get your facts right before posting.

rkelsen 12-07-2005 09:36 PM

Quote:

Originally Posted by Azmeen
That is not true. Please get your facts right before posting.

Please point me to where it says that installing LILO to anywhere other than the MBR (on an IDE HD, as in this case) will work.

In my experience, installing LILO to root partitions does not work.

v@ny@ 12-07-2005 11:43 PM

I installed Lilo to the root, not the MBR. But I could not get LILO to be the first boot screen. Maybe if I had installed in the MBR it would be. SO in this case added the bootsect.lnx line to boot.ini of windows. This gives me a first screen to choose from Windows or Linux, if I choose Linux I get the LILO screen asking me to choose the OS... So it works... not as i wanted but it works...

v@ny@ 12-09-2005 09:24 AM

Ok, one more note... I just reformatted my computer and this time I installed Windows first, then Linux. This time there was no problem to install LILO in the MBR and being in the MBR LILO is the first thing I see at boot, and it gives me the choice btw the operating systems... So now it really works.

JohnSeth 12-09-2005 11:21 AM

The general concensus I've noted in the various linux resources is to create your partitions using whatever fdisk program you desire... Then install Window *first*. Next, install Linux, and load lilo onto your MBR. In my own experience (and I'm guessing, with RKELSON, above) loading lilo anywhere else does not allow your computer to boot, none of mine ever ever have... unless I created a boot floppy. Installing Lilo to your MBR and adding a Windows segment to your /etc/lilo.conf file usually does the trick, with the least effort.

As stated prior... installing Windows after Linux, will 99% of the time, always rewrite your MBR to load windows without prompting to load another OS.


All times are GMT -5. The time now is 03:25 PM.