LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-14-2009, 06:11 PM   #1
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Help setting up printer on network


Running SW13/64, HP D1660 printer. Setup, works on local.

Setup Samba, Sw box can be seen on network, but no printer.

Tried various settings in SWAT, no-go

When trying to access SW box from network (to try and SEE printer), it asks for username/password. According to SWAT, no password, but can't get past this point

Ideas?
 
Old 10-14-2009, 06:20 PM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
OK..got past the password thing by setting to 'share' ,not 'user' (Doh!)

But still cannot print...

Ideas?

Windows box can see the printer on network, but just can't print to it.
 
Old 10-14-2009, 07:41 PM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,378

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Have you tried using the CUPS configuration page at http://localhost:631 and selecting "Publish printer" on the Printers tab as well as selecting "Share published printers connected to this system" on the Administration tab?
 
Old 10-14-2009, 08:38 PM   #4
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Trying that now...(Publish already selected)

And nothing so far...

Error says "Access denied, unable to connect"
 
Old 10-14-2009, 08:59 PM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,378

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
I suggest that you go back to using security = user in /etc/samba/smb.conf.
Have you added your user to the Samba password backend using 'smbpasswd'?

Please post the contents of /etc/cups/printers.conf and /etc/samba/smb.conf.

Edit:
Have you looked at this?
http://alien.slackbook.org/dokuwiki/...slackware:cups

Last edited by allend; 10-14-2009 at 09:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting up network printer?? frankkky General 4 04-15-2007 08:50 PM
Setting up network printer? frankkky General 1 04-11-2007 02:12 AM
Need help with setting up printer in a network environment yinglcs Linux - General 3 03-09-2006 01:37 AM
Setting up a network printer HELP Nefarious Linux - Hardware 0 04-20-2003 10:09 PM
setting up a network printer fisher99 Slackware 2 02-08-2003 12:56 AM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration