LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2004, 12:53 AM   #1
elyk
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 162

Rep: Reputation: 23
Help needed! I've killed my internet settings!


Title says it all...

I'm on dialup at home, had everything working fine. I had netconfig set up for a static IP address for ethernet, then set up my winmodem to connect to dialup.

Me and some other people set up a lan at another house where they have broadband, so I ran netconfig to set up DHCP so I could connect, but I had to register my card with the ISP (which I didn't), so I was online, the ISP gave me an IP address, but I couldn't connect to anything.

Now I'm back home, ran netconfig to change my settings back to use a static IP address, restarted everything, then connected through dialup without errors. But now nothing will connect, I can't visit any websites, gaim won't connect, I've tried several browsers.

There must be some setting somewhere that's telling these applications to use eth0 when it should be using ppp0, but what and where?

I'm now reduced to using windows! Help!

Any help is much appreciated,
-elyk
 
Old 08-15-2004, 01:03 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
If you just setup netconfig, make sure your still not using the DNS server settings from the other connection by checking your /etc/resolv.conf

And if that doesn't work, I've seen it act a little quirky after running a netconfig in Slackware, the quick and dirty way is after running it, reboot your system.

Another way is to restart all your /etc/rc.d/inet scripts.. should be rc.inet1 and rc.inet2... and so on. Sometimes you may have to bring down your eth0 as well, or even check your default route.. by typing route.

To add your default route.. do a:

route add default gw x.x.x.x where the x's are the IP of your gateway or router, etc.
 
Old 08-15-2004, 01:16 AM   #3
elyk
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 162

Original Poster
Rep: Reputation: 23
I'm just looking at this from within windows, and I see 3 files:

/etc/resolv.conf
Code:
search elyk.lan
/etc/resolv.conf.1042
Code:
search elyk.lan
/etc/resolv.conf.1156
Code:
search socket.net
nameserver 216.106.1.2
It looks like running netconfig overwrote resolv.conf and backed it up with random numbers at the end of the filename. I'll try tweaking those settings and reading up on resolv.conf. Thanks a lot!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
internet settings shocker-z Mandriva 23 04-10-2008 11:50 AM
Messed up my internet settings (NO internet connection) :( Almazick Linux - Networking 2 09-08-2004 12:05 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 06:23 PM
Internet Settings in Mandrake 9.1 marvelous Linux - Networking 1 03-03-2004 08:34 AM
Example needed of a Debian -interfaces file with wireless settings slewis1972 Linux - Wireless Networking 2 09-14-2003 02:44 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration