LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Help building mumble 1.2.2 on Slackware -current 64 (http://www.linuxquestions.org/questions/slackware-14/help-building-mumble-1-2-2-on-slackware-current-64-a-855334/)

D1ver 01-10-2011 08:14 AM

Help building mumble 1.2.2 on Slackware -current 64
 
Hello all,
I'm very keen on getting Mumble installed on my slackware -current 64 bit install.

I found a slackbuild script for 12.2 here, but changing the version number resulted in failure.

I also tried following the build instructions on the Mumble website, which failed with the following.
Code:

neil@slackbox:~/Downloads/mumble/mumble-1.2.2$ qmake -recursive main.pro
Reading /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble11x/mumble11x.pro
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble11x/mumble11x.pro:33: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble11x/mumble11x.pro:33: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
WARNING: Failure to find: qt_ja_JP.qm
WARNING: Failure to find: qt_zh_CN.qm
WARNING: Failure to find: qt_zh_TW.qm
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble11x/mumble11x.pro:28: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
WARNING: Failure to find: qt_ja_JP.qm
WARNING: Failure to find: qt_zh_CN.qm
WARNING: Failure to find: qt_zh_TW.qm
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_en.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_es.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_fr.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_de.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_it.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_ru.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_ja.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_cs.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_pl.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_zh_CN.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_zh_TW.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_ja_JP.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_en.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_es.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_fr.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_de.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_it.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_ru.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_ja.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_cs.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_pl.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_zh_CN.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_zh_TW.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_ja_JP.qm'
Reading /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble/mumble.pro
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble.pri:61: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble.pri:61: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
WARNING: Failure to find: Mumble.pb.cc
WARNING: Failure to find: qt_de.qm
WARNING: Failure to find: qt_es.qm
WARNING: Failure to find: qt_fr.qm
WARNING: Failure to find: qt_ru.qm
WARNING: Failure to find: qt_pl.qm
WARNING: Failure to find: qt_ja_JP.qm
WARNING: Failure to find: qt_zh_CN.qm
WARNING: Failure to find: qt_zh_TW.qm
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble.pri:56: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
Package sndfile was not found in the pkg-config search path.
Perhaps you should add the directory containing `sndfile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sndfile' found
WARNING: Failure to find: Mumble.pb.cc
WARNING: Failure to find: qt_de.qm
WARNING: Failure to find: qt_es.qm
WARNING: Failure to find: qt_fr.qm
WARNING: Failure to find: qt_ru.qm
WARNING: Failure to find: qt_pl.qm
WARNING: Failure to find: qt_ja_JP.qm
WARNING: Failure to find: qt_zh_CN.qm
WARNING: Failure to find: qt_zh_TW.qm
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_en.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_es.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_fr.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_de.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_it.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_ja.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_pl.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_da.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_de.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_es.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_fr.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_pl.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_ja_JP.qm'
RCC: Warning: No resources in 'mumble_qt.qrc'.
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_en.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_es.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_fr.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_de.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_it.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_ja.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_pl.qm'
RCC: Error in 'mumble.qrc': Cannot find file 'mumble_da.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_de.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_es.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_fr.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_pl.qm'
RCC: Error in 'mumble_qt.qrc': Cannot find file 'qt_ja_JP.qm'
RCC: Warning: No resources in 'mumble_qt.qrc'.
Reading /home/neil/Downloads/mumble/mumble-1.2.2/plugins/plugins.pro
 Reading /home/neil/Downloads/mumble/mumble-1.2.2/plugins/link/link.pro
 Reading /home/neil/Downloads/mumble/mumble-1.2.2/plugins/manual/manual.pro
Reading /home/neil/Downloads/mumble/mumble-1.2.2/overlay_gl/overlay_gl.pro
Project MESSAGE: Overriding linker
Project MESSAGE: Overriding linker
Project MESSAGE: Overriding linker
Reading /home/neil/Downloads/mumble/mumble-1.2.2/src/murmur/murmur.pro
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble.pri:61: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble.pri:61: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
WARNING: Failure to find: Mumble.pb.cc
WARNING: Failure to find: Murmur.cpp
WARNING: /home/neil/Downloads/mumble/mumble-1.2.2/src/mumble.pri:56: Variable LIBPATH is deprecated; use QMAKE_LIBDIR instead.
WARNING: Failure to find: Mumble.pb.cc
WARNING: Failure to find: Murmur.cpp

I believe the scripts looking for qt4 in the wrong place but I have no idea where to start.

Any help is very much appreciated.

knudfl 01-10-2011 02:28 PM

1 Attachment(s)
Mumble-1.2.2 http://mumble.sourceforge.net/BuildingLinux
Other prerequisites : celt.

# touch /usr/lib64/qt/translations/qt_ja_JP.qm
(Unless you want Japanese text, this empty file created by touch will do OK,
and seems to surpress all the language related errors / warnings.)
( But other errors will probably appear.)
( I got undefined reference to `sf_open_virtual' (libsndfile)).

Mumble, the latest version :
git clone git://mumble.git.sourceforge.net/gitroot/mumble/mumble mumble
cd mumble/ && qmake && make && make install && cd release/ && ./mumble
( Some workarounds were required.)

For mcpp to work :
./configure --prefix=/usr/ --enable-mcpplib --libdir=/usr/lib64/

Pulseaudio info, version
http://www.linuxquestions.org/questi...1x64-830061/#2


EDIT : added the forgotten 'qmake'.
..

D1ver 01-10-2011 04:18 PM

Yikes what a nightmare! Thanks for the help mate! I'll work through it and report any troubles.

D1ver 01-10-2011 05:09 PM

I'm having some trouble building ice. I downloaded the source and the patch from the URL's you supplied, extracted it and successfully applied the patch with
Code:

patch -p1 < zeroc-ice_3.2.1-1.diff
I then modified config/Make.rules and changed the following
Code:

# If libbzip2 is not installed in a standard location where the
# compiler can find it, set BZIP2_HOME to the bzip2 installation
# directory.
#
BZIP2_HOME                ?= /bin/bzip2


#
# If Berkeley DB is not installed in a standard location where the
# compiler can find it, set DB_HOME to the Berkeley DB installation
# directory.
#
DB_HOME                ?= /usr/include/db

#
# If expat is not installed in a standard location where the compiler
# can find it, set EXPAT_HOME to the expat installation directory.
#
EXPAT_HOME                ?= /usr/include/expat

#
# If OpenSSL is not installed in a standard location where the
# compiler can find it, set OPENSSL_HOME to the OpenSSL installation
# directory.
#
OPENSSL_HOME                ?= /usr/bin/openssl

Running make gives the following errors

Code:

making all in config
make[1]: Entering directory `/home/neil/Downloads/Mumble-deps/Ice-3.2.1/config'
echo ""

make[1]: Leaving directory `/home/neil/Downloads/Mumble-deps/Ice-3.2.1/config'
making all in src
make[1]: Entering directory `/home/neil/Downloads/Mumble-deps/Ice-3.2.1/src'
making all in IceUtil
make[2]: Entering directory `/home/neil/Downloads/Mumble-deps/Ice-3.2.1/src/IceUtil'
c++ -c -I../../include  -DICE_UTIL_API_EXPORTS -I.. -m64 -ftemplate-depth-128 -Wall -D_REENTRANT -fPIC -g  ArgVector.cpp
ArgVector.cpp: In member function 'void IceUtil::ArgVector::copyVec(int, int, char**)':
ArgVector.cpp:74:56: error: 'strlen' was not declared in this scope
ArgVector.cpp:91:38: error: 'strcpy' was not declared in this scope
ArgVector.cpp: In member function 'void IceUtil::ArgVector::copyVec(const std::vector<std::basic_string<char> >&)':
ArgVector.cpp:126:39: error: 'strcpy' was not declared in this scope
make[2]: *** [ArgVector.o] Error 1
make[2]: Leaving directory `/home/neil/Downloads/Mumble-deps/Ice-3.2.1/src/IceUtil'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/neil/Downloads/Mumble-deps/Ice-3.2.1/src'
make: *** [all] Error 1

Sorry, I'm still pretty new to all of this.

knudfl 01-10-2011 05:42 PM

Quote:

I then modified config/Make.rules
No manual edits are required. 'make' will do, using 'Makefile'.

The reason for "the attached 'URLs-mumble-deps+workarounds.txt' "
to say "12 patches" is that they should be used.

cd Ice-3.2.1/
patch -p1 < debian/patches/10-... ( eight times 10-* )

Apparently I forgot patches starting with '20-', suggest : apply them all :
patch -p2 < debian/patches/20-...
( I just did : some files are being recompiled, when running make.)

Good luck ! .. .. :) ..
..

D1ver 01-10-2011 05:57 PM

Sorry just to clarify..
I untar the source, and I extract the patch file, then
Code:

mv zeroc-ice_3.2.1-8.diff Ice-3.2.1/
cd Ice-3.2.1/
patch -p1 < zeroc-ice_3.2.1-8.diff
patch -p2 < zeroc-ice_3.2.1-8.diff

make

This seems to give me extra files in the source directory but make still fails with the same error.

Thanks again, I really appreciate your help.

knudfl 01-10-2011 06:21 PM

This is, what I did :
cd Ice-3.2.1/
1) zcat zeroc-ice_3.2.1-8.diff.gz | patch -p1
( Just a technically different method, no need to gunzip.)
... And then please look into the directory, created by your patch command,
namely debian/ , to find a sub directory = patches/ ... : 12 patches.
2) patch -p1 < debian/patches/10-add-common-flags.patch
3) patch -p1 < debian/patches/10-bugs-arch.patch
4) patch -p1 < debian/patches/10-gcc4.3-compilation.patch
5) patch -p1 < debian/patches/10-glibc-defaults.patch
6) patch -p1 < debian/patches/10-optimization-flags.patch
7) patch -p1 < debian/patches/10-poll-fall-back.patch
8) patch -p1 < debian/patches/10-skip-tests-and-demos.patch
9) patch -p1 < debian/patches/10-udp-mcast.patch
10) patch -p2 < debian/patches/20-ice-3.2.1-patch1.patch
11) etc. etc.

..

D1ver 01-10-2011 06:54 PM

Thanks that seems to have worked. make now compiles for a while and finishes unceremoniously with no visible errors.

Although It seems to have created lib/ bin/ doc/ src/ directories inside the source archive directory (in my case ~/Downloads/ice/Ice-3.2.1/), did I screw something up?


I'll keep working through the other dependencies.

D1ver 01-10-2011 08:51 PM

So I think I've got the dependencies all installed properly. I'm using your method of installing using the git repository.
Code:

git clone git://mumble.git.sourceforge.net/gitroot/mumble/mumble mumble
I then applied the work arounds from your text file and tried
Code:

cd mumble
make

which gives
Code:

make: *** No targets specified and no makefile found.  Stop.
The build instructions suggest using
Code:

qmake -recursive main.pro
which fails pretty spectacularly, I think it's looking for libraries in the wrong place. Did you have these issues?

knudfl 01-10-2011 09:08 PM

Yes, you are right, I forgot to write qmake. Sorry.
( 'qmake' alone will do, and then make.)

And no, I don't remember any errors.
May be the most were fixed when I tried to build mumble-1.2.2.

Did you build all the dependencies ? And which errors appeared ?

..

D1ver 01-10-2011 09:15 PM

Ok I think I'm getting very close.
I ran qmake and it didn't give any errors (qmake -recursive did)
I then ran make && make install which finished with no visible errors.

My release directory contains 'mumble11x' and 'plugins'. Running
Code:

./mumble11x
./mumble11x: error while loading shared libraries: libspeechd.so.2: cannot open shared object file: No such file or directory

Which looks like I'm missing a dependency..

knudfl 01-10-2011 09:30 PM

ls mumble/release/
libmumble.so libmumble.so.1 libmumble.so.1.2 libmumble.so.1.2.3
mumble mumble11x murmurd plugins
( Seems, you are missing something, to have all these files included.)

ls /usr/local/lib/ | grep libspeechd.so
libspeechd.so libspeechd.so.2 libspeechd.so.2.2.1

ls speech-dispatcher-0.7/src/c/api/.libs/
libspeechd.a libspeechd.lai libspeechd.so libspeechd.so.2.2.1
libspeechd.la libspeechd.o libspeechd.so.2


'./mumble11x' opens the GUI OK.

..

D1ver 01-10-2011 10:33 PM

Ok we're so close it's not funny.
The problem I was having related to the work-around you supplied, I needed to change all instances of 'ice' to 'Ice'. :doh:

It then compiled and installed with no errors and took a lot longer than previously. My release directory contains the following.
libmumble.so@ libmumble.so.1@ libmumble.so.1.2@ libmumble.so.1.2.3* mumble* mumble11x* murmurd* plugins/

Edit:
If I used the Debian source rather than the Git repository it seems to work better. In fact if I run ./mumble as root it works perfectly! As user it seems to lock up when I go through the wizard.

Honestly mate I cant thank you enough, you saved me installing Ubuntu today :)

Edit #2: After running it once as root, I tried again as user and its working just fine now.. :S


All times are GMT -5. The time now is 08:09 PM.