LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-03-2009, 05:21 PM   #1
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Rep: Reputation: 0
Hebrew PS/2 Keyboard to work with Slackware 12.1 /etc/X11/xorg.conf


I have an Hebrew/English PS/2 keyboard which works under Slackware 8.1 I have since
bought Slackware 12.1 and am trying to use "sea-monkey" as my browser with this keyboard.
Modifying the following file

http://members.shaw.ca/ivri/xorg.conf

near the end for the "il" keyboard layout does NOT work. Nothing I type appears,
and I can't get the "Scroll Lock" LED to illuminate when I press <left "Ctrl-Shift">
The log file for this can be found at

http://members.shaw.ca/ivri/Xorg.0.log

Note that the changes for "il" keyboard type "pc-101" are near the end of both files.
Hebrew goes from Right to Left, and the modifications to "/etc/X11/xorg.conf" should
be identical for either Hebrew or Arabic keyboards.

Can anybody tell me what I am missing in my "/etc/X11/xorg.conf" file?

I think I have made the appropriate changes to the files

/etc/rc.d/rc.font

and

/etc/rc.d/rc.keymap

As a bonus, can someone tell me how to modify "/etc/X11/xorg.conf" for a Russian/English
keyboard (on another Slackware 12.1 Linux machine, dedicated to Russian/English)
 
Old 11-04-2009, 11:09 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,369

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
I would start by cobbling up an /etc/environment file, make sure you have hebrew locale installed, and surfing off to a hebrew site where they have guys using hebrew keyboards working as a rule, and asking there.
 
Old 11-04-2009, 11:36 AM   #3
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
What is the "Environment" for Hebrew?

Quote:
Originally Posted by business_kid View Post
I would start by cobbling up an /etc/environment file, make sure you have hebrew locale installed, and surfing off to a hebrew site where they have guys using hebrew keyboards working as a rule, and asking there.
What should I set the environment to for Hebrew? The only people I know of using Hebrew
are using Microsoft Windows, which is not exactly helpful for setting up Linux Slack 12.1

I don't know anything about a "Hebrew locale". All I know is to edit /etc/X11/xorg.conf
for the "pc-101" type keyboard

Option "KkbRules" "xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "il"
Option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"

and to make sure that the files

/etc/rc.d/rc.font

and

/etc/rc.d/rc.keymap

are properly defined for Israel. Do I have to set a "Hebrew locale" in the Environment?
 
Old 11-04-2009, 03:34 PM   #4
nivieru
Member
 
Registered: Feb 2008
Posts: 48

Rep: Reputation: 7
no, you don't have to set a hebrew locale,
for me just setting - 'Option "XkbLayout" "us,il"' - worked fine in slackware out of the box,
but if you didn't make a full install you might be missing some fonts or something.
also check penguin.org.il, they have some guides for setting hebrew
 
Old 11-04-2009, 05:29 PM   #5
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nivieru View Post
no, you don't have to set a hebrew locale,
for me just setting - 'Option "XkbLayout" "us,il"' - worked fine in slackware out of the box,
but if you didn't make a full install you might be missing some fonts or something.
also check penguin.org.il, they have some guides for setting hebrew
I tried 'Option "XkbLayout" "us,il"' by itself and it didn't work.
What version of Slackware are you using? I am using Slackware 12.1
 
Old 11-05-2009, 03:58 AM   #6
nivieru
Member
 
Registered: Feb 2008
Posts: 48

Rep: Reputation: 7
now I'm using slackware-current, but I used 12.1 without any problems.
is this only happens in seamonkey or in general you can't write hebrew?
did you make a full install?
have you tryed:
Quote:
Option "XkbLayout" "us,il"
Option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"
?
what desktop enviroment do you use? some may override the xorg settings so you might need to configure your keyboard layout for the DE
 
Old 11-06-2009, 03:16 AM   #7
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
Hi! I finally got it to work! The following is what I added
to the /etc/X11/xorg.conf file

option "KxbRules" "xorg"
option "XkbModel" "pc101"
option "KxbLayout" "us,il"
option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"

I have updated the following link to show the complete configuration

http://members.shaw.ca/ivri/xorg.conf

and have updated the link to show the log file

http://members.shaw.ca/ivri/Xorg.0.log

Last edited by ivri; 11-06-2009 at 05:23 AM. Reason: Typo
 
Old 11-06-2009, 07:08 AM   #8
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
I got Russian to work as well... рускии Hebrew עברית

Adding the following lines to /etc/X11/xorg.conf makes Russian work.

option "XkbRules" "xorg"
option "XkbModel" "pc101"
option "XkbLayout" "us,il,ru" << Appended ",ru" to the XkbLayout options.
option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"

Does anybody know where I can buy a trilingual (English/Hebrew/Russian)
(English, עברית, руский) PS/2 keyboard?

Last edited by ivri; 11-06-2009 at 12:28 PM. Reason: typo
 
Old 11-08-2009, 05:00 AM   #9
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
How to generate period "." in my Russian keyboard layout

My Russian keyboard "claims" to generate period "." by using the key next to the "right shift". This generates a forward slash "/". In order to generate a period, I have to type "shift 7" which is marked "?" on my keyboard.

Is my keyboard marked incorrectly, is the keyboard layout file wrong? Can somebody please tell me what is going on?

Last edited by ivri; 11-08-2009 at 05:03 AM. Reason: typo
 
Old 11-08-2009, 06:07 AM   #10
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
I have been using Hebrew as an option for a while and I have never had to edit a xorg file.

I installed the kde hebrew package from the installation dvd.
Under System settings/Regional and Language, enable keyboard layouts and select my particular keyboard

Then add the Hebrew layout. Switching between Hebrew and English input is simply a matter of clicking the icon bottom right.

Using the Keyboard Layouts in System Settings might help you solve your other problems.
 
Old 11-08-2009, 08:36 PM   #11
ivri
LQ Newbie
 
Registered: Oct 2009
Location: Vancouver, Canada
Distribution: slackware 12.2
Posts: 13

Original Poster
Rep: Reputation: 0
As I am almost fluent in English, Hebrew, and Russian, I wanted
to set up my computer so as to be able to toggle between all
three keyboards. Modifying /etc/X11/xorg.conf was sufficient
for me to do this.

I do not use KDE, I use fvwm2. My browser is SeaMonkey A.K.A.
Mozilla, and the right hand "scroll" keeps colliding with the
"Bomb" Icon of /etc/X11/fvwm2 I modified the fvwm2 file so that
the "Bomb" calls a "Dummy" procedure rather than the "Destroy"
procedure. I left the icon in place so that if I accidentally
hit something while scrolling, I hit the now "harmless" Bomb.
Using the primitive desktop fvwm2 means that I do not have the
ready-made keyboard layouts for many languages. I do not mind
the trivial hack of /etc/X11/xorg.conf to configure in Hebrew
and Russian keyboard layouts.

- Yakov

p.s. Can someone please tell me how to "Thank" someone on "LQ"?

Last edited by ivri; 11-08-2009 at 08:39 PM. Reason: typo
 
Old 11-09-2009, 02:33 AM   #12
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
To thank someone click on the blue 'thumbs up' at the lower right of the message
 
  


Reply

Tags
keyboard, keyboards, russian, slackware12, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3 keyboard layouts in xorg.conf doesn't work VMM Linux - Newbie 3 11-10-2009 05:43 PM
Trying to get mouse wheel to work:/etc/X11/xorg.conf and Nano fullmetalgerbil Slackware 5 03-25-2009 09:18 AM
X11 xorg.conf issue darkstar01 Suse/Novell 4 02-21-2009 01:29 PM
mouse doesn't show up in /etc/x11/xorg.conf ~zoey~ Linux - Newbie 1 01-19-2009 02:01 PM
modelines for /etc/X11/xorg.conf TranceDude Linux - Hardware 3 09-30-2005 09:59 AM


All times are GMT -5. The time now is 12:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration