LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Hebrew PS/2 Keyboard to work with Slackware 12.1 /etc/X11/xorg.conf (http://www.linuxquestions.org/questions/slackware-14/hebrew-ps-2-keyboard-to-work-with-slackware-12-1-etc-x11-xorg-conf-766614/)

ivri 11-03-2009 05:21 PM

Hebrew PS/2 Keyboard to work with Slackware 12.1 /etc/X11/xorg.conf
 
I have an Hebrew/English PS/2 keyboard which works under Slackware 8.1 I have since
bought Slackware 12.1 and am trying to use "sea-monkey" as my browser with this keyboard.
Modifying the following file

http://members.shaw.ca/ivri/xorg.conf

near the end for the "il" keyboard layout does NOT work. Nothing I type appears,
and I can't get the "Scroll Lock" LED to illuminate when I press <left "Ctrl-Shift">
The log file for this can be found at

http://members.shaw.ca/ivri/Xorg.0.log

Note that the changes for "il" keyboard type "pc-101" are near the end of both files.
Hebrew goes from Right to Left, and the modifications to "/etc/X11/xorg.conf" should
be identical for either Hebrew or Arabic keyboards.

Can anybody tell me what I am missing in my "/etc/X11/xorg.conf" file?

I think I have made the appropriate changes to the files

/etc/rc.d/rc.font

and

/etc/rc.d/rc.keymap

As a bonus, can someone tell me how to modify "/etc/X11/xorg.conf" for a Russian/English
keyboard (on another Slackware 12.1 Linux machine, dedicated to Russian/English)

business_kid 11-04-2009 11:09 AM

I would start by cobbling up an /etc/environment file, make sure you have hebrew locale installed, and surfing off to a hebrew site where they have guys using hebrew keyboards working as a rule, and asking there.

ivri 11-04-2009 11:36 AM

What is the "Environment" for Hebrew?
 
Quote:

Originally Posted by business_kid (Post 3744424)
I would start by cobbling up an /etc/environment file, make sure you have hebrew locale installed, and surfing off to a hebrew site where they have guys using hebrew keyboards working as a rule, and asking there.

What should I set the environment to for Hebrew? The only people I know of using Hebrew
are using Microsoft Windows, which is not exactly helpful for setting up Linux Slack 12.1

I don't know anything about a "Hebrew locale". All I know is to edit /etc/X11/xorg.conf
for the "pc-101" type keyboard

Option "KkbRules" "xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "il"
Option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"

and to make sure that the files

/etc/rc.d/rc.font

and

/etc/rc.d/rc.keymap

are properly defined for Israel. Do I have to set a "Hebrew locale" in the Environment?

nivieru 11-04-2009 03:34 PM

no, you don't have to set a hebrew locale,
for me just setting - 'Option "XkbLayout" "us,il"' - worked fine in slackware out of the box,
but if you didn't make a full install you might be missing some fonts or something.
also check penguin.org.il, they have some guides for setting hebrew

ivri 11-04-2009 05:29 PM

Quote:

Originally Posted by nivieru (Post 3744826)
no, you don't have to set a hebrew locale,
for me just setting - 'Option "XkbLayout" "us,il"' - worked fine in slackware out of the box,
but if you didn't make a full install you might be missing some fonts or something.
also check penguin.org.il, they have some guides for setting hebrew

I tried 'Option "XkbLayout" "us,il"' by itself and it didn't work.
What version of Slackware are you using? I am using Slackware 12.1

nivieru 11-05-2009 03:58 AM

now I'm using slackware-current, but I used 12.1 without any problems.
is this only happens in seamonkey or in general you can't write hebrew?
did you make a full install?
have you tryed:
Quote:

Option "XkbLayout" "us,il"
Option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"
?
what desktop enviroment do you use? some may override the xorg settings so you might need to configure your keyboard layout for the DE

ivri 11-06-2009 03:16 AM

Hi! I finally got it to work! The following is what I added
to the /etc/X11/xorg.conf file

option "KxbRules" "xorg"
option "XkbModel" "pc101"
option "KxbLayout" "us,il"
option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"

I have updated the following link to show the complete configuration

http://members.shaw.ca/ivri/xorg.conf

and have updated the link to show the log file

http://members.shaw.ca/ivri/Xorg.0.log

ivri 11-06-2009 07:08 AM

I got Russian to work as well... рускии Hebrew עברית
 
Adding the following lines to /etc/X11/xorg.conf makes Russian work.

option "XkbRules" "xorg"
option "XkbModel" "pc101"
option "XkbLayout" "us,il,ru" << Appended ",ru" to the XkbLayout options.
option "XkbOptions" "grp:switch,grp:alt_shift_toggle,grp_led:scroll"

Does anybody know where I can buy a trilingual (English/Hebrew/Russian)
(English, עברית, руский) PS/2 keyboard?

ivri 11-08-2009 05:00 AM

How to generate period "." in my Russian keyboard layout
 
My Russian keyboard "claims" to generate period "." by using the key next to the "right shift". This generates a forward slash "/". In order to generate a period, I have to type "shift 7" which is marked "?" on my keyboard.

Is my keyboard marked incorrectly, is the keyboard layout file wrong? Can somebody please tell me what is going on?

arubin 11-08-2009 06:07 AM

I have been using Hebrew as an option for a while and I have never had to edit a xorg file.

I installed the kde hebrew package from the installation dvd.
Under System settings/Regional and Language, enable keyboard layouts and select my particular keyboard

Then add the Hebrew layout. Switching between Hebrew and English input is simply a matter of clicking the icon bottom right.

Using the Keyboard Layouts in System Settings might help you solve your other problems.

ivri 11-08-2009 08:36 PM

As I am almost fluent in English, Hebrew, and Russian, I wanted
to set up my computer so as to be able to toggle between all
three keyboards. Modifying /etc/X11/xorg.conf was sufficient
for me to do this.

I do not use KDE, I use fvwm2. My browser is SeaMonkey A.K.A.
Mozilla, and the right hand "scroll" keeps colliding with the
"Bomb" Icon of /etc/X11/fvwm2 I modified the fvwm2 file so that
the "Bomb" calls a "Dummy" procedure rather than the "Destroy"
procedure. I left the icon in place so that if I accidentally
hit something while scrolling, I hit the now "harmless" Bomb.
Using the primitive desktop fvwm2 means that I do not have the
ready-made keyboard layouts for many languages. I do not mind
the trivial hack of /etc/X11/xorg.conf to configure in Hebrew
and Russian keyboard layouts.

- Yakov

p.s. Can someone please tell me how to "Thank" someone on "LQ"?

arubin 11-09-2009 02:33 AM

To thank someone click on the blue 'thumbs up' at the lower right of the message


All times are GMT -5. The time now is 07:46 AM.