LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Headphones (http://www.linuxquestions.org/questions/slackware-14/headphones-880206/)

michijo 05-11-2011 10:21 PM

Headphones
 
The headphones play sound and the speakers play sound at the same time. The speakers dont become muted when headphones jacked. This is not a big problem for me as I dont use headphones too often, but for the sake of functionality, I tried a few things, which I know worked in the past in Debian, namely the moprobe addition:

http://ubuntuforums.org/showpost.php...34&postcount=2

Of course in Slackware this is in /etc/modprobe.d/sound or sound.conf. I added what I think is my hda options, but they seem not to work. I also tried renaming sound to sound.conf. No luck. My module is just:

0 snd_hda_intel

I tried adding:

options snd_hda_intel index=1

afreitascs 05-11-2011 11:21 PM

Quote:

Originally Posted by michijo (Post 4353857)
The headphones play sound and the speakers play sound at the same time. The speakers dont become muted when headphones jacked. This is not a big problem for me as I dont use headphones too often, but for the sake of functionality, I tried a few things, which I know worked in the past in Debian, namely the moprobe addition:

http://ubuntuforums.org/showpost.php...34&postcount=2

Of course in Slackware this is in /etc/modprobe.d/sound or sound.conf. I added what I think is my hda options, but they seem not to work. I also tried renaming sound to sound.conf. No luck. My module is just:

0 snd_hda_intel

I tried adding:

options snd_hda_intel index=1

Happens to me too, but (sorry) do not know the solution ...

thach.trung.ngoc 05-12-2011 12:41 AM

It happened to me when I bought my toshiba NB200. But the issue had gone away when upgrading kernel (back then I was using slackware 13 - current). Maybe this kernel is not yet supported your hardware.

Sometimes, your speaker is not on by default. Please use alsamixer to double check.

allend 05-12-2011 01:47 AM

You may be able to fix this by adding a model option to the snd-hda-intel kernel module if your system uses Intel-HDA for audio.
Please post the make and model of your machine as well as the audio codec chip type (which you can get from alsamixer or else just post the output of 'cat /proc/asound/cards').

michijo 05-12-2011 12:06 PM

Realtek HDA
 
Quote:

Originally Posted by allend (Post 4353948)
You may be able to fix this by adding a model option to the snd-hda-intel kernel module if your system uses Intel-HDA for audio.
Please post the make and model of your machine as well as the audio codec chip type (which you can get from alsamixer or else just post the output of 'cat /proc/asound/cards').

From cat /proc/asound/cards I get:

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfdff8000 irq 24

My chip is a 'Realtek ALC883'.

allend 05-12-2011 08:40 PM

If you have the kernel source package installed then you will have a file /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt. In that file you will see that there a large number of models that can be used for the ALC883 chip. Try adding a line to your /etc/modprobe.d/sound.conf
Code:

options snd-hda-intel model=<some suitable model>
where <some suitable model> is the model name from HD-Audio-Models.txt.

You should then reboot or else do 'modprobe -r snd-hda-intel' followed by 'modprobe snd-hda-intel' to set the new model. (You can check this by 'cat /sys/class/sound/hw*/modelname')
Run 'alsaconf' and then 'alsamixer' to check that the mixer settings are OK.
Save the settings with 'alsactl store'.

michijo 05-14-2011 10:28 PM

model types
 
Quote:

Originally Posted by allend (Post 4354825)
If you have the kernel source package installed then you will have a file /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt. In that file you will see that there a large number of models that can be used for the ALC883 chip. Try adding a line to your /etc/modprobe.d/sound.conf
Code:

options snd-hda-intel model=<some suitable model>
where <some suitable model> is the model name from HD-Audio-Models.txt.

You should then reboot or else do 'modprobe -r snd-hda-intel' followed by 'modprobe snd-hda-intel' to set the new model. (You can check this by 'cat /sys/class/sound/hw*/modelname')
Run 'alsaconf' and then 'alsamixer' to check that the mixer settings are OK.
Save the settings with 'alsactl store'.

I tried about 5 of those model types without luck. There are a lot, but no specific matches. Ill keep trying more of them over time. Ive had similar trouble before in Debian and had to try a few before one worked.

allend 05-15-2011 12:06 AM

Try googling 'snd-hda-intel" with your make and model. Perhaps someone has already found an answer.

trxdraxon 05-15-2011 12:42 AM

I know this question has been answered on this forum before as it helped me. Unfortunatly I am on my phone and search isn't cooperating very well. Just search for headphone or headphone jack and you should find it. I am pretty sure I have the link or a link saved on my work PC I can post on Monday if you haven't fixed it by then.

michijo 05-20-2011 09:59 PM

No Luck
 
Something strange maybe going on. Still sound from speakers and headphones at the same time.

I was looking at this page: http://alsa.opensrc.org/Hda and tried various things.

My computer has 2 jacks in front, 3 in back. The back has 1 in and 1 out, and also an extra mic. The front has a mic and a headphones. I keep wanting the front headphones more than anything to work.

On this Alsa page it shows 5stack as "5-jack in back, 2-jack in front". Does that mean 5 jacks literally or is that a certain family of jack? Nothing really matches mine.

allend 05-21-2011 09:15 AM

So your computer has Line In, Line Out, Headphones, Front Mic and Rear Mic. This is a 3 stack setup (no surround sound connections).
You say you had this working in Debian, so it would appear to be a configuration problem.
Again, please tell us the make and model of your computer.

michijo 05-22-2011 11:01 AM

3 stack
 
Quote:

Originally Posted by allend (Post 4362818)
So your computer has Line In, Line Out, Headphones, Front Mic and Rear Mic. This is a 3 stack setup (no surround sound connections).
You say you had this working in Debian, so it would appear to be a configuration problem.
Again, please tell us the make and model of your computer.

Incidentally, 3 stack is the one I thought would work, so its in my sound.conf already like:

options snd_hda_intel model=3stack

I also tried

options snd-hda-intel model=3stack

Problem still there. My computer is a 4 year old Gateway GT5468.

allend 05-22-2011 12:45 PM

Have you tried the "3stack-2ch-dig" model?

Looking at the code in /usr/src/linux-2.6.37.6/sound/pci/hda/patch_realtek.c suggests it is a possibility suitable for you.

michijo 05-22-2011 01:12 PM

aliases
 
Quote:

Originally Posted by allend (Post 4363778)
Have you tried the "3stack-2ch-dig" model?

Looking at the code in /usr/src/linux-2.6.37.6/sound/pci/hda/patch_realtek.c suggests it is a possibility suitable for you.

I tried most of them like that. Just a thought, but maybe its what is already in the sound.conf rather than something to add. These two lines were in my sound.conf by default.

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

I merely included the 3stack options after them.

allend 05-22-2011 08:03 PM

Just adding the lines after the alias lines should be OK.

Do you have a file with a name starting with "codec" in /proc/asound/card0/? If so, please post the contents.
My thought is that your headphones are switched on and off using a different pin to that in the models. Perhaps this output will help.


All times are GMT -5. The time now is 08:59 PM.