LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-12-2011, 07:54 AM   #1
GasPipe
Member
 
Registered: Jul 2009
Location: Finland
Distribution: Slackware64-current
Posts: 55

Rep: Reputation: 19
HDMI audio with Slackware64-current


Hi,

I installed Slack64-current this morning into my HTPC and now I'm trying to get HDMI audio working.
OK, I got it to work but KMix doesn't show any volume controls. I have unmuted all four S/PDIF channels from alsamixer.

I have added these lines into ~/.asoundrc:
Code:
pcm.!default {
     type hw
     card 0
     device 7
}
I have installed Nvidia proprietary drivers for my GPU.

My graphics card is GeForce GT220.

Any suggestions how I can get KMix to show up channels? Thanks!
 
Old 10-12-2011, 08:32 AM   #2
jayfree
Member
 
Registered: Oct 2009
Location: NJ
Distribution: fedora 20 and rawhide
Posts: 47

Rep: Reputation: 8
Quit Kmix and try entering
Quote:
KMIX_PULSEAUDIO_DISABLE=1 kmix
in a terminal window, see what you get.

If that does what you want you have to make that variable permanent something like adding
Quote:
export KMIX_PULSEAUDIO_DISABLE=1
to your ~/.bashrc file. Pulseaudio is different, it only shows volume sliders for what is playing.
 
Old 10-12-2011, 09:36 AM   #3
GasPipe
Member
 
Registered: Jul 2009
Location: Finland
Distribution: Slackware64-current
Posts: 55

Original Poster
Rep: Reputation: 19
Thank you for answer.

Unfortunately that didn't work out:
Code:
bash-4.1$ KMIX_PULSEAUDIO_DISABLE=1 kmix
grepHelper: File does not exists:  "/proc/asound/card0/pcm0p/info" 
kmix(3693): Cannot load profile  "ALSA.HDA_NVidia.1.default"  . It was removed by the user, or the KMix config file is defective. 
kmix(3693): Cannot load profile  "ALSA.HDA_NVidia.1.default"  . It was removed by the user, or the KMix config file is defective. 
bash-4.1$ kmix: Fatal IO error: client killed
QEventLoop: Cannot be used without QApplication
Unable to start Dr. Konqi
 
Old 10-12-2011, 10:14 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
See:
http://www.linuxquestions.org/questi...2/#post4032980
 
Old 10-12-2011, 11:51 AM   #5
GasPipe
Member
 
Registered: Jul 2009
Location: Finland
Distribution: Slackware64-current
Posts: 55

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by H_TeXMeX_H View Post
That didn't help.
As I said earlier, I have the audio, aplay lists my card correctly and I can listen to for example Spotify.

The only thing I'm missing here is the controls from KMix. There's no channels at all.

I raise here a second question about nvidia drivers:
I'm using Twinview with following setup:
24" 1920x1080 LCD monitor
32" 1360x768 LCD TV

I'm using the 24" monitor as a primary screen and TV as secondary screen, left of the monitor. I have arranged the TV screen to be in the middle compared to the monitor. I know, I'm a pretty horrible at explaining things so I attached a screenshot.
As you can see there's this black space above and below the TV screen. Although it didn't show in the TV screen. But I know it's there becuase my mouse cursor vanishes there from time to time.
This is kind of annoying so I'm asking is there any way I can restrict the mouse cursor for going to the black zone of screen?

And then there's this problem:
I have connected my screens like this:
GPU(HDMI) -> A/V receiver -> TV
GPU(DVI) -> Monitor

If I power on my A/V receiver but not my TV the system doesn't recognize audio at all. So if I want to listen some music and work with my monitor at the same time, that's not working if I don't power on my TV and restart X server. That's a big downside compared to windows. But I like to hope that there is also fix for this problem. :-)
Attached Images
File Type: jpg tv_screen.jpg (39.3 KB, 29 views)
 
Old 10-12-2011, 01:50 PM   #6
jayfree
Member
 
Registered: Oct 2009
Location: NJ
Distribution: fedora 20 and rawhide
Posts: 47

Rep: Reputation: 8
Maybe you should delete that .asound file and configure sound through Phonon, I believe most systems do not need that file anyway, I know my system(s) don't have that file.
 
Old 10-12-2011, 08:19 PM   #7
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
You should not get controls for HDMI, as there is not hardware level volume control. HDMI simply passes sound. If the application your are using has software volume level control, you can use that application to control the volume. Kmix, alsamixer, xfce mixer --- are hardware mixers. Otherwise just use the volume control on your receiver, TV, ....

About your Nvidia driver question -
It's working as expected. You have two different resolutions defined. Either match the resolutions, or use separate X screens. Twin View is Clone View. Considering it's a Clone, the dead space is expected. Sucks I know
 
1 members found this post helpful.
Old 10-12-2011, 11:35 PM   #8
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,867
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
Nvidia's HDMI audio should be supported by the latest version of ALSA (and the kernel). However the setup might have some issues...

Double check your install and configuration against the official documents from Nvidia here:
ftp://download.nvidia.com/XFree86/gp...dmi-audio.html

Last edited by ReaperX7; 10-12-2011 at 11:43 PM.
 
0 members found this post helpful.
Old 10-13-2011, 02:17 AM   #9
GasPipe
Member
 
Registered: Jul 2009
Location: Finland
Distribution: Slackware64-current
Posts: 55

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by disturbed1 View Post
You should not get controls for HDMI, as there is not hardware level volume control. HDMI simply passes sound. If the application your are using has software volume level control, you can use that application to control the volume. Kmix, alsamixer, xfce mixer --- are hardware mixers. Otherwise just use the volume control on your receiver, TV, ....
Ok, that makes sense. So there's no way to control master audio using software, like in windows?

Quote:
Originally Posted by disturbed1 View Post
About your Nvidia driver question -
It's working as expected. You have two different resolutions defined. Either match the resolutions, or use separate X screens. Twin View is Clone View. Considering it's a Clone, the dead space is expected. Sucks I know
Well I can't match the resolutions if I want to be able to watch HD material without scaling and I sure want!
I tried before using separate X screens but there's this problem that I can't seaminglessly move windows from one screen to another.

So I guess there's still not that kind of extended desktop mode like in windows for linux?

Quote:
Nvidia's HDMI audio should be supported by the latest version of ALSA (and the kernel). However the setup might have some issues...

Double check your install and configuration against the official documents from Nvidia here:
ftp://download.nvidia.com/XFree86/gp...dmi-audio.html
Thanks for the link. It contains information that answers a couple of my questions:

Quote:
HDMI audio does not work when X is not running and active on the VT; previously, the document stated that it simply may not work.
Got that right...

Quote:
Noted that no monitor is required; an A/V receiver is sufficient.
In my experience A/V receiver is not sufficent.
 
Old 10-13-2011, 02:52 AM   #10
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Quote:
Originally Posted by GasPipe View Post
Ok, that makes sense. So there's no way to control master audio using software, like in windows?
If the application uses software volume control, then that application can control the volume of its output. For an example, we have MythTV connected to our TV through HDMI. MythTV has the option for software volume control or hardware volume control. When I choose software volume control, +/- controls the volume. With hardware volume control, +/- goes through the motions, but volume is not changed. Many applications do support software volume control, though you usually need to fiddle with an option or 2. Haven't personally investigated enough applications. Our PCs that utilize HDMI are connected to single TVs, and we allow the TV to control the volume.

Quote:
Well I can't match the resolutions if I want to be able to watch HD material without scaling and I sure want!
I tried before using separate X screens but there's this problem that I can't seaminglessly move windows from one screen to another.

So I guess there's still not that kind of extended desktop mode like in windows for linux?
AFAIK, this was the way it was. I could be (hopefully) wrong.
You might get a better answer at www.nvnews.net.
 
1 members found this post helpful.
Old 10-13-2011, 03:37 AM   #11
GasPipe
Member
 
Registered: Jul 2009
Location: Finland
Distribution: Slackware64-current
Posts: 55

Original Poster
Rep: Reputation: 19
Thanks disturbed1!

I'm using Spotify to listen to music and they have this preview version for linux. Unfortunately the volume control bar isn't working (I'm guessing they are using pulseaudio) and the application is crashing like once per hour. They are only offering debian and fedora packages :-(
I used to use wine for spotify but I don't want to install multilib anymore. Of course I could use something like despotify because I'm paying 10€ per month for premium...

I'm marking this thread as SOLVED although it kind of is not. If I make something to work, I'll let you know.
 
  


Reply

Tags
alsa, audio, hdmi, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HDMI Audio doesn't work - Debian Squeeze (Intel HDMI) felipefv Linux - Hardware 8 02-06-2012 09:47 AM
ATI Radeon $200 onboard HDMI audio issue on slackware64/kde4 Sm0k3 Slackware 2 12-24-2009 11:15 AM
HDMI Audio with 12.2 Woodsman Slackware 27 09-04-2009 10:53 PM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 06:50 PM
HDMI Audio with Current/13.0 Woodsman Slackware 2 08-24-2009 01:40 PM


All times are GMT -5. The time now is 09:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration