LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2009, 09:52 AM   #1
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 298

Rep: Reputation: 50
hda intel soundcard no sound


I have an hp laptop
hp pavilion dv4-1199ef

Here's the info about the sound card detected by the system

Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

I can't get any sound at all. Whenever I try to listen to a sound file (*.ogg, *.mp3, *.wav)
the app (any) remains silent and doesn't display any error message.

I recently built linux-2.6.29.4 with the hda_intel as modules
I looked at the doc in the Documentation/sound/alsa of the
kernel source tree to try to find the model closest to my
laptop

I created a file
/etc/modprobe.d/alsa-base.conf

# cat /etc/modprobe.d/alsa-base.conf
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-m4
options snd-hda-intel enable_msi=1

(before that I had tried model=hp, but it didn't
work, and in the doc I read it said hp-m4 was for the
hp dv laptops)

and, there's just one card
# cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xdf300000 irq 11

and still no sound
 
Old 05-30-2009, 11:33 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
What version of slackware are you running ? I would make sure of two things: run 'alsaconf' to setup the card, and make sure '/etc/rc.d/rc.alsa' is executable.

I have a similar sound card (rev 02) and it works fine, however it's not an HP laptop.

This may also help, possibly:
http://www.linuxquestions.org/questi...2/#post3496597
 
Old 05-31-2009, 01:35 AM   #3
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
vonbiber,

As you seem to know already, the key issue with the snd-hda-intel driver is to select the model=xxxx option to match your computer's audio codec.

Unfortunately, I've not been able to find the exact part number of the audio codec used in your hp pavilion dv4-1199ef computer. It's referred to as an "IDT High Definition Audio Codec", but that didn't seem to help me find an appropriate model option for the snd-hda-intel driver.

As a practical workaround, you can use USB speakers or headphones for audio. If you choose to do this, it will simplify the ALSA configuration issues with multiple sound devices if you either disable your onboard audio card in the BIOS settings, or blacklist the snd-hda-intel driver.
 
Old 05-31-2009, 05:19 AM   #4
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 298

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by H_TeXMeX_H View Post
What version of slackware are you running ? I would make sure of two things: run 'alsaconf' to setup the card, and make sure '/etc/rc.d/rc.alsa' is executable.

I have a similar sound card (rev 02) and it works fine, however it's not an HP laptop.

This may also help, possibly:
http://www.linuxquestions.org/questi...2/#post3496597
slackware12.2
/etc/rc.d/rc.alsa is executable

I even built on another partition (still slackware12.2) linux-2.6.29.4
and checked all these things above.

I downloaded archives from the alsa web site (latest version 1.0.20)
to look at it. Didn't build the packages.
Looking at the docs in alsa-driver archive I noticed there were more
models than in the corresponding doc in Documentation/sound/alsa of
the kernel source tree
There's for instance 'hp-dv5' which could include the dv4 series
I didn't try to update my version of alsa (1.0.17) because there
might be side effects
Hopefully, there's gonna be a fix in a future version of the kernel
(perhaps in linux-2.6.30) so I'll keep building new kernels
 
Old 05-31-2009, 05:25 AM   #5
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 298

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by DavidHindman View Post
vonbiber,

As you seem to know already, the key issue with the snd-hda-intel driver is to select the model=xxxx option to match your computer's audio codec.

Unfortunately, I've not been able to find the exact part number of the audio codec used in your hp pavilion dv4-1199ef computer. It's referred to as an "IDT High Definition Audio Codec", but that didn't seem to help me find an appropriate model option for the snd-hda-intel driver.

As a practical workaround, you can use USB speakers or headphones for audio. If you choose to do this, it will simplify the ALSA configuration issues with multiple sound devices if you either disable your onboard audio card in the BIOS settings, or blacklist the snd-hda-intel driver.
I tried the closest likely model (hp-m4) that I found by reading
the docs in the kernel source tree
I noticed that in the alsa-driver package there were more models
including 'hp-dv5' which could fit the dv4 series as well
perhaps it's gonna be included in a future kernel release

I had tried the headphones but I didn't disable the audio card
I might try that as a last resort
 
Old 06-02-2009, 08:22 AM   #6
Martinezio
Member
 
Registered: May 2009
Location: Warsaw, Poland
Distribution: Slackware64-current
Posts: 191

Rep: Reputation: 32
Did You try to unmute Your sound card channels? By default, all channels are muted and You need to use alsamixer, or any other mixer software to setup the channels responsible for playing what You need, especially PCM (or Master) volume. Try also to setup the volume for front/rear and side channels, or surround channel.

Regards
 
Old 06-03-2009, 01:54 AM   #7
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 298

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by Martinezio View Post
Did You try to unmute Your sound card channels? By default, all channels are muted and You need to use alsamixer, or any other mixer software to setup the channels responsible for playing what You need, especially PCM (or Master) volume. Try also to setup the volume for front/rear and side channels, or surround channel.

Regards
yeah, I used alsamixer and and all the levels that could
be set are around 70

one thing that I don't understand is
# cat /proc/asound/cards |tail -n2
shows '... irq 11' on my installed slackware

while the same command in 2 live linux that I use
(slax and grml)
shows a different irq value (irq 22)

sound doesn't work on these either but in slax
this
# cd /usr/share/sounds; aplay -vv pop.wav
does produce a sound
(not grml or slackware)
 
Old 06-03-2009, 02:19 AM   #8
Martinezio
Member
 
Registered: May 2009
Location: Warsaw, Poland
Distribution: Slackware64-current
Posts: 191

Rep: Reputation: 32
Quote:
Originally Posted by vonbiber View Post
yeah, I used alsamixer and and all the levels that could
be set are around 70
Try to set PCM on 100%. I don't know why, but the behaviour of mixer looks logaritmic to me, not proportional.

Quote:
Originally Posted by vonbiber View Post
one thing that I don't understand is
# cat /proc/asound/cards |tail -n2
shows '... irq 11' on my installed slackware

while the same command in 2 live linux that I use
(slax and grml)
shows a different irq value (irq 22)

sound doesn't work on these either but in slax
this
# cd /usr/share/sounds; aplay -vv pop.wav
does produce a sound
(not grml or slackware)
What alsa drivers and libraries You have?
I'm using currently ALSA 1.0.20 with Linux 2.6.29.4 kernel and there is no troubles with the sound, but I use nForce HD-Audio codec...

Last edited by Martinezio; 06-03-2009 at 02:42 AM.
 
Old 06-03-2009, 03:01 AM   #9
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 298

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by Martinezio View Post
Try to set PCM on 100%. I don't know why, but the behaviour of mixer looks logaritmic to me, not proportional.

What alsa drivers and libraries You have?
I'm using currently ALSA 1.0.20 with Linux 2.6.29.4 kernel and there is no troubles with the sound, but I use nForce HD-Audio codec...
1. ok, I just
# alsamixer
set PCM to 100%, then
# alsactl store
I'll seet what happens when I reboot

2.
alsa-lib-1.0.17a
alsa-oss-1.0.17
alsa-utils-1.0.17

on the partition I'm using right now
linux-2.6.29.3

on another partition, same alsa and
linux-2.6.29.4

I haven't tried yet to build newer alsa packages (slackware)
then replace the current ones
because I'm afraid there might be side effects (other packages
involved)
 
Old 06-03-2009, 07:42 AM   #10
Martinezio
Member
 
Registered: May 2009
Location: Warsaw, Poland
Distribution: Slackware64-current
Posts: 191

Rep: Reputation: 32
Well, I always try to use newest software and if the software is marked as stable, there is no side efects... Especially with drivers Newest driver provide more compatibility...
As for the ALSA software, check alsa-driver first:

here is ./configure --help output:

Code:
root@service1:/tmp/alsa/alsa-driver-1.0.20# ./configure --help
`configure' configures this package to adapt to many kinds of systems.

Usage: ./configure [OPTION]... [VAR=VALUE]...

[snip]

  --with-cards=<list> compile driver for cards and options in <list>;                   
                          cards may be separated with commas;                           
                          'all' compiles all drivers;                                   
                          Possible cards are:
                            [...], hda-intel, hdsp, hdspm, [...]

  --with-card-options=<list> enable driver options in <list>;
                          options may be separated with commas;
                          'all' enables all options;
                          Possible options are:
                            [...], hda-hwdep, hda-reconfig,
                            hda-input-beep, hda-codec-realtek,
                            hda-codec-analog, hda-codec-sigmatel,
                            hda-codec-via, hda-codec-atihdmi,
                            hda-codec-nvhdmi, hda-codec-intelhdmi,
                            hda-codec-conexant, hda-codec-cmedia,
                            hda-codec-si3054, hda-generic, hda-power-save,
                            [...]
Maybe one of these drivers and options is suitable for You HD codec...
 
Old 06-03-2009, 10:01 AM   #11
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 298

Original Poster
Rep: Reputation: 50
[QUOTE=Martinezio;3561606]Well, I always try to use newest software and if the software is marked as stable, there is no side efects... Especially with drivers Newest driver provide more compatibility...
As for the ALSA software, check alsa-driver first:

here is ./configure --help output:

Code:
root@service1:/tmp/alsa/alsa-driver-1.0.20# ./configure --help
`configure' configures this package to adapt to many kinds of systems.

...
                          Possible cards are:
                            [...], hda-intel, hdsp, hdspm, [...]

  --with-card-options=<list> enable driver options in <list>;
                          options may be separated with commas;
                          'all' enables all options;
                          Possible options are:
                            [...], hda-hwdep, hda-reconfig,
                            hda-input-beep, hda-codec-realtek,
                            hda-codec-analog, hda-codec-sigmatel,
                            hda-codec-via, hda-codec-atihdmi,
                            hda-codec-nvhdmi, hda-codec-intelhdmi,
                            hda-codec-conexant, hda-codec-cmedia,
                            hda-codec-si3054, hda-generic, hda-power-save,
                            [...]
in slackware packages source (on my dvd)
grep alsa /mnt/dvd/source/FILE_LIST
showed the presence of alsa in 4 packages
alsa-lib
alsa-oss
alsa-utils
aumix

somewhere in there I saw some diff files
I don't know if I can figure out the diff part while writing
SlackBuild scripts for the newer versions of alsa
Besides I didn't see alsa-driver in the slackware packages
(I suppose the one used was
the one that came with the kernel sources)

I might give it a try. I have another partition that I just use for
testing. Or wait for eventually there's gonna be a kernel release
where this is going to be fixed

I already have all the codecs shown above built in the kernel
 
Old 06-04-2009, 01:21 AM   #12
Martinezio
Member
 
Registered: May 2009
Location: Warsaw, Poland
Distribution: Slackware64-current
Posts: 191

Rep: Reputation: 32
Yes, I know, that this package isn't available on Slackware installation disc. This is part of the kernel, but I don't know, what version of alsa-driver is currently joined in linux-2.6.29.4. Before building those drivers from source available at www.alsa-project.org You must have properly configured Your kernel's source in /usr/src/linux folder - build process first jumps into this source, and then build drivers in src of alsa-driver using dynamic path.

Give it a shot in a test environment and see, if this helps You I think, You have nothing to loose :>

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound with front connector after kernel upgrade....Intel HDA onboard sound aus9 Debian 2 01-21-2009 02:43 AM
NForce sound card found & snd-hda-intel driver loaded, no sound Rod Butcher Linux - Hardware 8 03-05-2008 07:30 AM
HDA intel Sound Card Sounds problems with intel sound card on Ubuntu zengingok Linux - Hardware 9 08-17-2007 10:52 AM
no sound; configuring hda-intel sound card in suse 10.1 crashes X MamaWombat Suse/Novell 1 05-30-2006 10:42 PM
Sound/Multi-channels on an HDA-Intel/C-Media CMI9880 soundcard? newbuntu Linux - Hardware 6 08-09-2005 08:05 PM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration