LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-26-2012, 02:13 PM   #1
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Rep: Reputation: Disabled
hd device remounted with commit=600


Hi everybody,
I'm using Slackware 14 on a laptop, with xfce as DE. I noticed that every time I start an X session, the option "commit=600" is added to the mount parameters specified in fstab for my root device. What is responsible of such a change? I experimented it when battery powered, I haven't tried on AC yet.

thanks a lot!!
 
Old 12-27-2012, 10:26 AM   #2
bijo505
Member
 
Registered: Nov 2012
Location: Bangalore
Distribution: Fedora & Ubuntu
Posts: 77

Rep: Reputation: 18
Hi,

From the mount man...

"commit=nrsec
Sync all data and metadata every nrsec seconds. The default value is 5 seconds. Zero means default"

Have a look at this URL too
http://aptosid.com/index.php?name=PN...ewtopic&t=1072

--
Thanks,
Bijo
 
Old 12-27-2012, 10:55 AM   #3
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
Hi,

thanks, but I know what that option does. What I don't know is which process (re)sets the mount options (remounting my root disc), adding commit as a parameter.
My defaults in fstab are:
defaults,noatime,discard (it's a ssd).
When I run xfce, they suddenly become
defaults,noatime,discard,commit=600

 
Old 01-01-2013, 12:17 PM   #4
LukenShiro
LQ Newbie
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware64 current & 14.0
Posts: 4

Rep: Reputation: 2
It depends on /usr/lib64/pm-utils/power.d/journal-commit (from package pm-utils).
You can override it in e.g. /etc/pm/config.d/_my-sample-file_ with two entries:
"""
JOURNAL_COMMIT_TIME_AC=<value>
JOURNAL_COMMIT_TIME_BAT=<value>
"""
 
Old 01-03-2013, 11:26 AM   #5
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
Hi! yes, that's definetly the culprit. Thanks a lot for your answer, I'll go messing around with pm-utils
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cvs [commit aborted]: 'root' is not allowed to commit files rakesh@linuxforum Linux - Newbie 7 09-26-2013 03:53 PM
[SOLVED] Why root is remounted with commit=0 (=600 specified in fstab) at the end of start-up? *Dark Dragon* Debian 2 01-11-2012 10:06 AM
cvs [commit aborted]: 'root' is not allowed to commit files r_ramya06 Linux - Newbie 5 07-08-2008 09:04 AM
ext3 commit interval on root device clvic Linux - General 4 05-22-2008 04:07 AM
tmpfs is remounted read only vavoem Debian 2 04-11-2006 12:41 PM


All times are GMT -5. The time now is 02:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration