LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-19-2013, 05:06 PM   #46
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled

Had you read http://docs.slackware.com/start?id=s...e_your_network then this whole thread would not have been necessary.

Eric
 
1 members found this post helpful.
Old 02-20-2013, 01:13 PM   #47
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,110

Rep: Reputation: 810Reputation: 810Reputation: 810Reputation: 810Reputation: 810Reputation: 810Reputation: 810
Quote:
Originally Posted by stf92 View Post
Yes, I did that. I also reset the modem, the router and the machines several times: no use. I in A I do

ifconfig eth0 192.168.0.2

then all is fine. But when I reboot, I am again 192.168.0.100!
Don't forget to take the "ifconfig" out of your file in /etc/rc.d -- if you don't, it may come back to haunt you sooner or later...
 
Old 02-20-2013, 02:25 PM   #48
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 350

Rep: Reputation: 56
Just to complicate matters further, it is totally possible to continue to use dhcpcd (the DHCP Client Daemon) and assign static IP addresses. You just have to configure /etc/dhcpcd.conf accordingly. I have found that approach superior to /etc/rc.d/rc.inet1.conf on at least one occasion.
 
Old 02-23-2013, 05:35 PM   #49
eloi
Member
 
Registered: Nov 2010
Posts: 215

Rep: Reputation: 56
Check router ip range

@stf92

I know that this thread is marked as solved but I have the impression that some
concepts are not clear enough.

I assume you've already understood that the dynamic IP provided by your ISP is
the external IP. What you are configuring is your LAN.

Router web interfaces are a bit confusing. You should not disable dhcp in your
router. Just do not use it (client) in your machines. Your router will use
dhcp client to connect to your ISP and dhcp server to assign IPs to your LAN
machines. Perhaps it will let you pre define some "static leases" where you
associate the MAC address of each network interface with a static IP (mine let
me add the host name of each machine too).

Take in care that routers generally ask you to define a "range" of ips to
assign, so if that range is 192.168.0.100 - 192.168.0.200 and you put
192.168.0.2 in rc.inet1.conf it will not work (probably what happened to
you).

What you showed on your first post for rc.inet1.conf is OK (unless 192.168.0.2
is not in the router's pre defined range like I've explained above).

You can add to /etc/resolv.conf:

Code:
search local
nameserver 192.168.0.1
to ask names to your router or:

Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
if you want your machine uses google's. Should work in both cases.

You can add to /etc/hosts in both machines (I have a
linux embeded in my router so I ssh access it and edit /etc/hosts with the same
values).

Code:
127.0.0.1	localhost
192.168.0.1	routername.local	routername
192.168.0.100	machine1.local		machine1
192.168.0.101	machine2.local		machine2

Your router configuration is what you should investigate first.

-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"domain-name" and "host-name" options in dhcpd.conf m4rtin Linux - Server 3 09-20-2012 09:21 AM
xorg.conf : Explanation of "Viewport" and "Virtual" uncle-c Linux - Newbie 1 01-24-2011 12:04 PM
Error for wireless request "Set Nickname" (8B1C) -- /etc/rc.d/rc.inet1.conf hellbillyJoker Linux - Networking 1 04-06-2010 08:24 PM
Problems configuring "xorg.conf" with "ATI FGLRX" BlueSpirit Slackware 3 09-16-2006 03:01 PM
error "Set Frequency" (8b04) : when restarting rc.inet1 tux31337 Linux - Wireless Networking 1 02-13-2006 04:47 PM


All times are GMT -5. The time now is 08:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration