LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-03-2012, 06:51 PM   #16
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Original Poster
Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848

Quote:
Originally Posted by Darth Vader View Post
Still, how about to show me the complete dump of dmesg?

I'm curious if the modem is really switched from "installation" mode to "working mode"...

Idea is if your modem have an builtin software presented for installation, is very posible to have two working modes.
Well, here it is.
Attached Files
File Type: txt dmesg.txt (58.7 KB, 6 views)
 
Old 08-03-2012, 07:03 PM   #17
Darth Vader
Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 593

Rep: Reputation: 108Reputation: 108
Quote:
Originally Posted by markush View Post
Well, here it is.
Yeah, your modem is directly supported by usb_modeswitch as device 12d1:1446 and it is switched well.
 
1 members found this post helpful.
Old 08-04-2012, 01:10 AM   #18
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 766

Rep: Reputation: 92
Try this for a possible solution. -->http://ubuntuforums.org/showthread.php?t=1583103

But preferably NM
 
1 members found this post helpful.
Old 08-04-2012, 10:20 AM   #19
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Try adding this to the pppd chat script.
Code:
AT+CGDCONT=1,"IP","wap.eplus.de"
and changing the password to 'wap'
The user name and password that you supplied in post #1 appear to relate to E-Plus i-mode access.
For use with your modem, you need to use the General Internet access settings.http://www.areamobile.de/static/zugang/e-plus.php
or, in English http://translate.googleusercontent.c...8lSkwhii2ucQ#2
 
1 members found this post helpful.
Old 08-04-2012, 10:56 AM   #20
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Original Poster
Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by allend View Post
Try adding this to the pppd chat script.
Code:
AT+CGDCONT=1,"IP","wap.eplus.de"
and changing the password to 'wap'
The user name and password that you supplied in post #1 appear to relate to E-Plus i-mode access.
For use with your modem, you need to use the General Internet access settings.http://www.areamobile.de/static/zugang/e-plus.php
or, in English http://translate.googleusercontent.c...8lSkwhii2ucQ#2
Hi allend,

there are several providers who use the eplus net. I'm using AldiTalk which uses the string "internet.eplus.de" http://www.alditalk.de/talk/download...-Anleitung.pdf. But it seems to be the case that one has only to provide this string in order to account the flatrate (30 days with max 5GB in this case), there is another string when one wants to account the 24h flatrate. But I found out, that I receive an errormessage when I provide this string once I have accounted the flatrate, it seems to be stored on the sim-card and is not necessary while authentication. (but I'm not sure).

But now I saw that they use different passwords. My problem is that I cannot seem to find out how far pppd goes when connecting. I have read about ppp and it seems to fail during authentication. I'd like to have more knowledge about scripting for pppd or chat respectively. Then I could make the scripts show me where they are. Now pppd and chat provide an errorcode which is explained in the manpages, but it is not clear where in the script pppd hung up.

Markus
 
Old 08-04-2012, 12:29 PM   #21
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Errors from pppd are logged in /var/log/syslog.
You can use a debug option to pppd that will give more detail.
Perhaps you also need to specify the protocol to use, probably CHAP or PAP. I could not find this specified in the .pdf that you posted, but it has been many years since my reading German course.

Last edited by allend; 08-04-2012 at 12:30 PM.
 
1 members found this post helpful.
Old 08-04-2012, 12:41 PM   #22
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 766

Rep: Reputation: 92
You seem to be using a password of 'gprs', when the pdf file you attached shows a password of 'eplus' Not saying that's in any way significant, just a bit odd.

Still plumping for kppp or NM from here
 
1 members found this post helpful.
Old 08-04-2012, 01:25 PM   #23
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Original Poster
Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hello vdemuth,

the automatical configuration of the Modem in Windows shows "gprs" as a password, I tried both, but it still doesn't work.

I've tried kppp, but pppd crashed with fatal error every time. Also I don't even for kppp know the appropriate settings for the modem.

I have no experience with NM, I will try to find some documentation.

Markus
 
Old 08-04-2012, 01:38 PM   #24
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
your connection is established. pppd would not get that far, if it wasn't.
in your peers/umts, try to enable hardware flow control ( crtscts ), remove noccp and nobsdcomp, you might need it.
Code:
Cannot determine ethernet address for proxy ARP
this line looks quite strange to me. try the noproxyarp option.

i'quite in a hurry atm, so i just took a quick glance at pppd(8)
 
1 members found this post helpful.
Old 08-04-2012, 02:06 PM   #25
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 490

Rep: Reputation: 207Reputation: 207Reputation: 207
This is how I connected using a Huawei e220 on OpenBSD. You might find some of the options helpful. The MTU may need to be set at something much lower than 1500 for starters.

3ireland.ie
Code:
/dev/cuaU0
crtscts
460800
modem
lock
noipdefault
defaultroute
persist
noauth
ipcp-restart 10
ipcp-accept-local
ipcp-accept-remote
0.0.0.0:10.64.64.64
deflate 0
bsdcomp 0
noccp
novj
novjccomp
nopcomp
mru 1440
connect 'chat -v -f /etc/ppp/three.chat'
3chat
Code:
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
ABORT "ERROR"
ABORT "NO ANSWER"
ABORT "BUSY"
TIMEOUT 60
'' "AT"
OK 'AT+CGDCONT=1,"ip","3ireland.ie"'
OK "ATDT*99#"
TIMEOUT 40
CONNECT \c

Last edited by gezley; 08-05-2012 at 12:05 AM.
 
1 members found this post helpful.
Old 08-04-2012, 03:06 PM   #26
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Original Poster
Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
I think I'm a big step further now. My latest settings are similar to gezley's

Code:
#/etc/ppp/peers/umts
hide-password                                                                     
noauth                                                                            
connect "/usr/sbin/chat -V -f /etc/ppp/umts.chat"                                 
debug                                                                             
/dev/ttyUSB0                                                                      
460800                                                                            
defaultroute                                                                      
noipdefault                                                                       
noproxyarp
crtscts
local
user "eplus"
password "gprs"
usepeerdns
connect-delay 10000
persist
Code:
# /etc/ppp/umts.chat
#OK READY-AT+CPIN=8687    # PIN has to be only once when the Modem is connected                                              
'' AT                                                                             
#'OK' 'AT+cgdcont=1,"IP","internet.eplus.de"'                                     
OK ATDT*99#
and here the output
Code:
thinkpad:~# pppd call umts debug nodetach
AT                                                                      
OKScript /usr/sbin/chat -V -f /etc/ppp/umts.chat finished (pid 3704), status = 0x0
Serial connection established.
using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x864c077d> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap MD5> <magic 0x10d2e01> <pcomp> <accomp>]
sent [LCP ConfAck id=0x0 <asyncmap 0x0> <auth chap MD5> <magic 0x10d2e01> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x864c077d> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x864c077d]
rcvd [LCP DiscReq id=0x1 magic=0x10d2e01]
rcvd [CHAP Challenge id=0x1 <52050fd3beb6267f28b5a7c6fcba662c>, name = "UMTS_CHAP_SRVR"]
sent [CHAP Response id=0x1 <76de2e4f872b76519e1fc5422df40711>, name = "eplus"]
rcvd [LCP EchoRep id=0x0 magic=0x10d2e01 86 4c 07 7d]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP ProtRej id=0x2 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
rcvd [IPCP ConfNak id=0x2 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x3 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
rcvd [IPCP ConfNak id=0x3 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x4 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
rcvd [IPCP ConfReq id=0x0]
sent [IPCP ConfNak id=0x0 <addr 0.0.0.0>]
rcvd [IPCP ConfRej id=0x4 <compress VJ 0f 01> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x5 <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
rcvd [IPCP ConfReq id=0x1]
sent [IPCP ConfAck id=0x1]
rcvd [IPCP ConfNak id=0x5 <addr 10.128.53.15> <ms-dns1 212.23.97.3> <ms-dns2 212.23.97.2>]
sent [IPCP ConfReq id=0x6 <addr 10.128.53.15> <ms-dns1 212.23.97.3> <ms-dns2 212.23.97.2>]
rcvd [IPCP ConfAck id=0x6 <addr 10.128.53.15> <ms-dns1 212.23.97.3> <ms-dns2 212.23.97.2>]
Could not determine remote IP address: defaulting to 10.64.64.64
local  IP address 10.128.53.15
remote IP address 10.64.64.64
primary   DNS address 212.23.97.3
secondary DNS address 212.23.97.2
Only problem was that I still cannot connect to the internet. I've included the namservers and additionally 8.8.8.8 in my /etc/resolv.conf and it seems that the nameresolution works. I can't ping any remote adresses, neither via name nor via IP, but when I ping a name, the IP-adress is shown (even for sites which I didn't use for a long time, so they should not be in the cache.

The output of route is this one
Code:
thinkpad:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *               0.0.0.0         U     0      0        0 ppp0
10.64.64.64     *               255.255.255.255 UH    0      0        0 ppp0
and a part of netstat -na
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 0.0.0.0:37              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:6000            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:113             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
tcp6       0      0 :::6000                 :::*                    LISTEN     
tcp6       0      0 :::22                   :::*                    LISTEN     
udp        0      0 0.0.0.0:512             0.0.0.0:*                          
udp        0      0 0.0.0.0:37              0.0.0.0:*                          
udp        0      0 0.0.0.0:631             0.0.0.0:*
It seems that I'm still missing something. I cannot browse any websites and Thunderbird (mail) doesn't work either. I can even not get websites via their IP.

What's wrong? Is the route for a Point-to-Point-connection valid?

Markus
 
Old 08-04-2012, 03:21 PM   #27
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 490

Rep: Reputation: 207Reputation: 207Reputation: 207
Quote:
Originally Posted by markush View Post
It seems that I'm still missing something. I cannot browse any websites and Thunderbird (mail) doesn't work either. I can even not get websites via their IP.

What's wrong? Is the route for a Point-to-Point-connection valid?

Markus
I seem to remember having to enable packet forwarding in the kernel. Perhaps this is your problem?
 
1 members found this post helpful.
Old 08-04-2012, 04:13 PM   #28
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Original Poster
Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, I have enabled packet-forwarding now. But it occured another problem (which I had already once yesterday:
Code:
thinkpad:~# pppd call umts debug nodetach
AT
OK
AAT+CPIN=xxxx
OKScript /usr/sbin/chat -V -f /etc/ppp/umts.chat finished (pid 2071), status = 0x0
Serial connection established.
using channel 4
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
LCP: timeout sending Config-Requests
Connection terminated.
Receive serial link is not 8-bit clean:
Problem: all had bit 7 set to 0
Modem hangup
^CTerminating on signal 2
There seems to be still a problem with the chat-script (referring to the Linux-ppp Howto http://tldp.org/HOWTO/PPP-HOWTO/x419.html)

Markus
 
Old 08-04-2012, 05:53 PM   #29
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
Code:
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xe786b39> <pcomp> <accomp>]
LCP: timeout sending Config-Requests
look at the 'passive' option
Quote:
Originally Posted by pppd(8)
passive
Enables the "passive" option in the LCP. With this option, pppd
will attempt to initiate a connection; if no reply is received
from the peer, pppd will then just wait passively for a valid
LCP packet from the peer, instead of exiting, as it would with‐
out this option.
Quote:
Only problem was that I still cannot connect to the internet. I've included the namservers and additionally 8.8.8.8 in my /etc/resolv.conf and it seems that the nameresolution works.
use 8.8.8.8 as the first entry, maybe iptables prevents you from accessing the internet. you could try to set all policies to 'accept' for testing purposes
 
1 members found this post helpful.
Old 08-04-2012, 11:37 PM   #30
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
The chat script that I use for my Huawei E160E USB modem is very similar to that which gezley posted. http://www.linuxquestions.org/questi...4/#post4213848
I used to use this all the time, until NetworkManager came into -current.
You should uncomment the line
Code:
#'OK' 'AT+cgdcont=1,"IP","internet.eplus.de"'
in your chat script as you need to specify the Access Point Name.

Do you see an interface created when you connect in the output of 'ifconfig'?
Also, when you connect the connection information is saved in /etc/ppp/resolv.conf, whereas programs will look at /etc/resolv.conf. You said that you have created a symlink from /etc/ppp/resolv.conf to /etc/resolv.conf, but I have not tested this technique. I always used to manually copy /etc/ppp/resolv.conf to /etc/resolv.conf once the connection was made.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
usbmod: what is it for? (net access via USB-modem / UMTS) JZL240I-U Linux - Networking 8 09-07-2010 05:42 AM
Cannot connect usb cellphone modem to internet Rodemire Linux - Networking 4 02-15-2009 04:59 PM
ADSL USB Modem / Router connecting ( through USB ) but cannot connect to internet DJ Shaji Linux - Networking 1 03-28-2008 03:24 AM
Connect to internet with USB external modem rssguy Linux - Newbie 5 04-28-2005 07:58 PM
can't connect internet with adsl usb modem arthur_mueller Slackware 1 12-23-2003 01:48 AM


All times are GMT -5. The time now is 09:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration