LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Poll: Have you set up your Slackware to use UTF-8?
Poll Options
Have you set up your Slackware to use UTF-8?

You must log in and have one post to vote in this poll. If you don't have an account, you can register here.
Results will be available after the polls close.

The nominees are:

Yes
No

Reply
 
Search this Thread
Old 12-12-2012, 09:42 AM   #31
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71

Quote:
Originally Posted by w1k0 View Post
irgunII,

1) Edit your /etc/lilo/conf, replace:

Code:
append=" vt.default_utf8=0"
with:

Code:
append=" vt.default_utf8=1"
and rerun lilo command.

2) Edit your /etc/rc.d/rc.font and put there the line:

Code:
setfont -v lat2-16.psfu.gz
After reboot everything should work well.

(Midnight Commander in the mode you described looks and works horrible.)
That seems to have done the trick! Thanks, w1k0!
 
Old 12-12-2012, 12:21 PM   #32
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,241

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by Didier Spaier View Post
Maybe we should setup another poll to find out to which categories readers of this forum fall into?
Interesting idea (assuming that the users would be willing to vote).

***

By the way: maybe someone knows how LinuxQuestion.org counts the views:

1. If I enter the same post 100 times it counts each entrance.

2. If I enter the same post using the same IP number it counts that as one entrance but if I enter the same post using 10 different IP numbers it counts each IP number.

3. It doesnít matter how many times I enter the post because LQ sets the cookie and counts all my views of the same post as a one view.

Last edited by w1k0; 12-12-2012 at 12:42 PM. Reason: As I said I like to edit my posts...
 
Old 12-12-2012, 12:29 PM   #33
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,241

Rep: Reputation: 196Reputation: 196
irgunII,

You donít specified your location except for the vague ďDirectly above the center of the earthĒ so I couldnít match the best font file for you. In /usr/share/kbd/consolefonts directory thereís a lot of font files except lat2-16.psfu.gz. Maybe some other font would be better suitable for you than the font including Central European characters (ISO-8859-2 encoding called also Latin-2).
 
Old 12-12-2012, 12:45 PM   #34
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,661

Rep: Reputation: 1236Reputation: 1236Reputation: 1236Reputation: 1236Reputation: 1236Reputation: 1236Reputation: 1236Reputation: 1236Reputation: 1236
Maybe irgun should be spelled אִרְגּוּן

Even if my assumption is false that's a good example of how UTF-8 allows to deal with RTL and LTR languages in the same document

Be it true or false, that doesn't answer your question anyway.

Last edited by Didier Spaier; 12-12-2012 at 12:47 PM.
 
Old 12-12-2012, 06:28 PM   #35
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71
Quote:
Originally Posted by w1k0 View Post
irgunII,

You donít specified your location except for the vague ďDirectly above the center of the earthĒ so I couldnít match the best font file for you. In /usr/share/kbd/consolefonts directory thereís a lot of font files except lat2-16.psfu.gz. Maybe some other font would be better suitable for you than the font including Central European characters (ISO-8859-2 encoding called also Latin-2).
USA, but it seems to be working with the font you suggested. I don't go into init 3 much anymore except the once in a while to install an nvidia driver anyway, heh.
 
Old 12-12-2012, 06:32 PM   #36
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71
Quote:
Originally Posted by Didier Spaier View Post
Maybe irgun should be spelled אִרְגּוּן

Even if my assumption is false that's a good example of how UTF-8 allows to deal with RTL and LTR languages in the same document

Be it true or false, that doesn't answer your question anyway.
Heh heh...you hit the nail on the head. Good call! (except those who can read/write/speak Hebrew don't really use all the little 'dots' to help with the vowels, except for the young children in school ). It would have been kinda neat though if I could have entered my handle that way instead of phonetically like it is! lol
 
Old 12-12-2012, 09:53 PM   #37
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,241

Rep: Reputation: 196Reputation: 196
ארגון,

If youíd like to play with that one more time add at the end of /etc/rc.d/rc.local the following lines:

Code:
setfont -v iso08.16.gz
loadkeys il-heb.map
and run /etc/rc.d/rc.local in the console mode.

(The mentioned settings overwrite the settings from /etc/rc.d/rc.font and /etc/rc.d/rc.keymap files.)

Then press right Alt key with your right thumb and keeping it pressed try to type your name with the other fingers.

(I donít know if itís possible to write from right to left in the console mode.)

That font spoils the lines in Midnight Commander but in an non-harmful way. Maybe that configuration will keep you in the console mode for a while.

***

As I assume you know Hebrew. I maintain some application for Window Maker and the similar window managers. It recognizes the Western European languages (ISO-8859-1), the Central European languages (ISO-8859-2), and the languages using Cyrillic alphabet (ISO-8859-5). I wanted to implement also the Hebrew language (ISO-8859-8) but I donít know it so Iím afraid I can made that in a wrong way Ė for example design the characters in a non-optimal way.

Let me know if youíre willing to install my application and test it in order to report whether everything is all right or specify whatís wrong. You donít have to run Window Maker in order to test my application. It works in the other window managers and desktop environments as well.

***

(I hope I interpreted the string typed by Didier Spaier well.)
 
Old 12-13-2012, 03:18 AM   #38
a4z
Member
 
Registered: Feb 2009
Posts: 526

Rep: Reputation: 188Reputation: 188
is there any advantage in using setfont over unicode_start ?
 
Old 12-13-2012, 01:36 PM   #39
NonNonBa
Member
 
Registered: Aug 2010
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by w1k0 View Post
NonNonBa,

Over 1000 views and below 100 votes in your poll. Is it so hard to press the [Vote Now] button?
Maybe the Slackware community is very small, but utterly excited by this thread.

BTW, I have finally fixed the issues I had with xmessage. I just added these two lines in my .Xresources:

Code:
Xmessage*fontSet:                   -xos4-terminus-medium-r-normal-*-22-220-72-72-c-110-*
Xmessage*international:             true
A warning remains, but the message is displayed promptly with all my fancy French characters. Here I use terminus, but you can replace it with one of the font displayed by xlsfonts (ex. "-adobe-helvetica-medium-r-normal-*-14-100-100-100-p-76-"). Just feed the empty "--" field of this one with a "*", and run xrdb -l ~/.Xresources to make X to reload your settings.

This fix also seems to work with xfig (replace above "Xmessage*" by "xfig*"), but sadly not with xdvi. With this one the best I get is a slightly broken selection menu (unexplicably, it doesn't render the "*.dvi" "File Mask" string, all except this being fine) using these options (it doesn't accept them under the "xdvi" resource class):

Code:
xdvi -xrm "*international:true" -xrm "*fontSet:-xos4-terminus-medium-r-normal-*-22-220-72-72-c-110-*"
I still look for a way to make fbrun to accept accented character in input (it can handle them when they are passed with the "-text" option, but not in the interactive mode).

Quote:
Originally Posted by a4z
is there any advantage in using setfont over unicode_start ?
I think it's the same. With "vt.default_utf8" set to 1 or not set, the console is in UTF-8, so setfont will load the Unicode map of the given font.
 
Old 12-13-2012, 01:44 PM   #40
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 494

Rep: Reputation: 132Reputation: 132
YES

so no problems with š, Ų, Ś, ś, and Ý :P
 
Old 12-13-2012, 06:54 PM   #41
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 508

Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Or maybe they simply do not know the answer because:
(1) They do not remember if/how they set up the character encoding at time of installation.
(2) They do not know what UTF-8 means/is.
(3) They do not know what a character encoding is or that there are several ways to encode a character or that several character encodings are available in Slackware.
(4) They visit any new thread in this forum, just in case they would find something interesting for them or someone they could help.
(5) Another reason I can't think of right now.
Maybe they do know the answer but choose simply not to vote.
 
Old 12-13-2012, 07:31 PM   #42
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71
Quote:
Originally Posted by w1k0 View Post
ארגון,

If youíd like to play with that one more time add at the end of /etc/rc.d/rc.local the following lines:

Code:
setfont -v iso08.16.gz
loadkeys il-heb.map
and run /etc/rc.d/rc.local in the console mode.

(The mentioned settings overwrite the settings from /etc/rc.d/rc.font and /etc/rc.d/rc.keymap files.)

Then press right Alt key with your right thumb and keeping it pressed try to type your name with the other fingers.

(I donít know if itís possible to write from right to left in the console mode.)

That font spoils the lines in Midnight Commander but in an non-harmful way. Maybe that configuration will keep you in the console mode for a while.
Oh, no I was just saying it would have been kinda fun, but it'd be too much a PITA to actually use much anywhere as I'd either have anyone with a lick of sense throw e-mails in the trash without opening them thinking they were spam or worse, or the rest replying in e-mails or forums etc, what the heck those funny things were.

***

Quote:
Originally Posted by w1k0 View Post
As I assume you know Hebrew. I maintain some application for Window Maker and the similar window managers. It recognizes the Western European languages (ISO-8859-1), the Central European languages (ISO-8859-2), and the languages using Cyrillic alphabet (ISO-8859-5). I wanted to implement also the Hebrew language (ISO-8859-8) but I donít know it so Iím afraid I can made that in a wrong way Ė for example design the characters in a non-optimal way.

Let me know if youíre willing to install my application and test it in order to report whether everything is all right or specify whatís wrong. You donít have to run Window Maker in order to test my application. It works in the other window managers and desktop environments as well.

***

(I hope I interpreted the string typed by Didier Spaier well.)
Yep, you got the name correct without the vowels. Perfect.

My hebrew is really awfully poor (hell, my *english* is bad enough! lol). I've got dual-citizenship but only was there long enough to serve my 3 years in the Israeli army and I've not had to use the language since I came back to the states (didn't want to leave Israel but circumstances needed me back here and then I became disabled and haven't been able afford to go back since then) in '90.

I could at least try with what little I know/remember and still try to help...it'd be better than nothing, right? You'll have to explain in plain and simple terms how to work it and what you want me to do exactly...I'm no programmer or anything like that, just a simple user who likes Linux over M$ (I used M$ from ~'94 - '00 and got sick of it that fast).

If it'd be easier, here's my e-mail you can use afrotrap {aT] gee mail d0t c0m
 
1 members found this post helpful.
Old 12-14-2012, 07:28 AM   #43
joncoles
LQ Newbie
 
Registered: Feb 2004
Distribution: Ubuntu 12.10, Slackware 14.0
Posts: 11

Rep: Reputation: 0
Would like to use UTF-8, but how?

I made the wrong choice during installation. (Slaps forehead. Why did I care that vi wouldn't work? I wouldn't touch vi with a ten foot pole! That old-school hesitation about new-fangled UTF-8 gives me a sinking feeling this distro will be outdated in other ways.)

I'm now looking at the Unicode-HOWTO in /usr/doc. It's verbose and is mainly arm-waving aboput UTF-8 while pointing to tarballs for this and that individual application. (Tarballs?! Don't they have a yum or apt-get equivalent?) It all looks very complicated. Perhaps a complete reinstall (approx 45 minutes last time) would actually be the easier, faster way.

Has anyone found a straightforward way to select character encoding system-wide?
 
Old 12-14-2012, 07:37 AM   #44
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
Quote:
Originally Posted by joncoles View Post
Tarballs?! Don't they have a yum or apt-get equivalent?
Nope, and we don't want it.

Quote:
It all looks very complicated. Perhaps a complete reinstall (approx 45 minutes last time) would actually be the easier, faster way.

Has anyone found a straightforward way to select character encoding system-wide?
If you are able to change two lines (comment one and uncomment the other) in a text-file (/etc/profile.d/lang.sh) and if you are able to do that in less than 45 minutes then the reinstall is is not the easier or faster method.

Last edited by TobiSGD; 12-14-2012 at 09:20 AM. Reason: fixed typo
 
1 members found this post helpful.
Old 12-14-2012, 08:03 AM   #45
joncoles
LQ Newbie
 
Registered: Feb 2004
Distribution: Ubuntu 12.10, Slackware 14.0
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by TobiSGD View Post
If you are able to change two lines (comment one and uncomment the other) in a text-file (/etc(profile.d/lang.sh) and if you are able to do that in less than 45 minutes then the reinstall is is not the easier or faster method.
Thanks. The Unicode-HOWTO doesn't even mention lang.sh!

Could I have found this information myself somewhere in LinuxQuestions.org? I'm new to the site.
 
  


Reply

Tags
unicode


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Umlauts (Ų,š,Ł) does not shown right even if UTF-8 is set on Red Hat 6.3 Santiago mindgame71 Linux - Server 0 10-04-2012 02:57 AM
How to set Charset to UTF-8 in Apache for scripts? cooljai Linux - Software 0 05-15-2008 05:53 AM
The parameter --locale=xx_YY.utf-8 was not set in your /etc/default/dictd tony safari Linux - Software 0 03-18-2007 10:13 AM
Conversion from character set 'UTF-8' to @local error Postgre Slackware 2 09-11-2006 10:15 PM
Help needed with font installation on Debian 3.1 with locale all set to en_US.UTF-8 PhantmShado Linux - Software 1 02-20-2006 04:50 PM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration