LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

View Poll Results: Have you set up your Slackware to use UTF-8?
Yes 88 77.19%
No 26 22.81%
Voters: 114. You may not vote on this poll

Reply
 
LinkBack Search this Thread
Old 12-08-2012, 07:58 PM   #16
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145

I think it's wise for slackware to not have utf8 set as the default encoding because the installer does not guarantee utf8 support to be installed.

I was very lazy in migrating to utf8. Some important programs, such as xfig, still work better in GBK environment than in utf8. But I had no other choice when I started to face the CJK complexity, then cyrillic and european characters. Although GB18030 is a unicode encoding, most programs work better in utf8 than in GB18030.

Last edited by guanx; 12-08-2012 at 07:59 PM. Reason: typo
 
Old 12-08-2012, 10:27 PM   #17
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 187Reputation: 187
As I supposed GNU FreeFont 20120503 causes the similar though not the same problems with my laser printer as the previous version of these fonts.

Today I tested FreeSerif, FreeSans, and FreeMono typefaces in Regular, Bold, Italic, and BoldItalic shapes using the following character set including Polish and French glyphs:

Code:
ĄĆĘŁŃŚŹŻąćęłńśźż
I printed these sets of characters using Brother HL-5340D printer working with PPD file downloaded from the Brother website.

With old GNU FreeFont 20100919 that printer produces the invalid results for the following glyphs:

FreeSerif:
Regular: ĆŃŚŹćńśź
Bold: none
Italic:
BoldItalic:

FreeSans:
Regular: ĆŃŚŹćńśź
Bold:
Italic: ĆŃŚŹćńśź
BoldItalic: ĆŃŹćńź

FreeMono:
Regular: ĆŃŚŹ
Bold: ĆŃŚŹćńśź
Italic: none
BoldItalic: ĆŃŚŹćńśź

With old GNU FreeFont 20100919 repaired automatically using the method mentioned in post #14 that printer produces the invalid results for the following glyphs:

FreeSerif:
Regular:
Bold: none
Italic:
BoldItalic:

FreeSans:
Regular:
Bold:
Italic:
BoldItalic:

FreeMono:
Regular:
Bold:
Italic:
BoldItalic: none

With new GNU FreeFont 20120503 that printer produces the invalid results for the following glyphs:

FreeSerif:
Regular:
Bold: none
Italic:
BoldItalic:

FreeSans:
Regular:
Bold:
Italic:
BoldItalic:

FreeMono:
Regular: ĆŃŚŹ
Bold: ĆŃŚŹćńśź
Italic: none
BoldItalic: ĆŃŚŹćńśź

As you see many glyphs are repaired in those fonts since version 20100919.

I didn’t test my method of repairing the glyphs with the new GNU FreeFont 20120503 yet so I can’t guarantee the results will be the same as with the previous version of these fonts.

Last edited by w1k0; 12-09-2012 at 12:09 PM. Reason: typo
 
Old 12-09-2012, 04:33 AM   #18
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 462

Rep: Reputation: Disabled
Yes. I have encountered no problems with UTF-8.
 
Old 12-09-2012, 09:29 AM   #19
NonNonBa
Member
 
Registered: Aug 2010
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by guanx View Post
I think it's wise for slackware to not have utf8 set as the default encoding because the installer does not guarantee utf8 support to be installed.
Well, it doesn't need it. Even when you use an UTF-8 locale, you can set it to "C" or "POSIX" in your scripts to stick them with ASCII (it is even advised if you don't want they break due to some localization issue).

Personnaly, I was a bit like you, seeing no urgency to migrate. I did it when I tryed git for a private project where the logs were in French (git uses UTF-8 as default, you can choose another encoding, but there's then no way to change it in the future of the project). I finally abandoned git, but UTF-8 remained. Of course I won't go back, but I continue to think iso-8859-15, while not being as perfect as UTF-8, allows to write a very decent French.

I like text files and have many of them, so the migration was a bit tricky. Plus, I was then a bit new to this kind of issues. The main gain was with LateX or HTML: no more need to escape all special characters. Regarding to the inconvenients, very few: things like xdvi or xmessage are slowed (they take several seconds before starting), and there's of course some mess with the manuals. For xmessage, I use it rarely but set it in locale C to fix the problem. For xdvi, I stopped to use it to produce PDF exclusively (it's the same printing-wise, and PDF is in all the cases better to share documents). For the manuals, I found no magic solution, but I however prefer to refer to the English man-pages which are generally the most up-to-date.

@Didier Spaier: De rien (you're welcome)!
 
Old 12-09-2012, 10:40 AM   #20
a4z
Member
 
Registered: Feb 2009
Posts: 277

Rep: Reputation: 111Reputation: 111
installed terminus font and have in rc.font
unicode_start ter-v16n
gives a nice terminal font an no problems since many years
 
Old 12-09-2012, 10:48 AM   #21
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by NonNonBa View Post
Well, it doesn't need it. Even when you use an UTF-8 locale, you can set it to "C" or "POSIX" in your scripts to stick them with ASCII (it is even advised if you don't want they break due to some localization issue).
...
Unfortunately not all of the programs in the system is written by me. So I can't do it actually.
 
Old 12-09-2012, 12:05 PM   #22
NonNonBa
Member
 
Registered: Aug 2010
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by guanx View Post
Unfortunately not all of the programs in the system is written by me. So I can't do it actually.
Yes, I was speaking only of the installer, which could stick with ASCII without impacting the charset of the default system as long as it is needed. Regarding to the system, which programs cause you trouble with UTF-8?
 
Old 12-09-2012, 10:31 PM   #23
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by NonNonBa View Post
... Regarding to the system, which programs cause you trouble with UTF-8?
Xfig for example. I had various problems with it since I migrated from GBK to UTF-8. In the end I decided to alias xfig to "LC_CTYPE=C xfig". A similar example is mathematica.

I also have to remove the localized man pages of the shadow package, etc. because they can't be displayed properly. Yes I know there are solutions but I'm too lazy to apply them and I'm not wishing to see these few localized man pages anyway.

There are other problems. But I can live with these. On the other hand, I cannot live with improperly displayed Japanese, Russian, and German strings under GBK. Nor can I accept the GB18030, though it's unicode, because too many things are broken under GB18030, including scim, which is essential to me.
 
Old 12-09-2012, 11:56 PM   #24
ahzthecat
Member
 
Registered: May 2010
Location: Japan
Distribution: Slackware 13.37, Slackware 14, Wind0z8, Ubuntu 12.10
Posts: 156

Rep: Reputation: 8
I use UTF-8 because I need to be able to display Japanese characters, and input them using scim/anthy (actually since Slack 14 I've been using iBus and anthy). I've had difficulty getting KDE to display kana so setting the locale to UTF-8 is one of the first things I do on a new install.

I'm actually having terminal/font display issues when using regular Terminal in KDE. I get odd text artifacts in sbo, among other things. Funny thing tho, if I use Konsole for my terminal, there are no problems (as of yet).
 
Old 12-10-2012, 03:37 AM   #25
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Yes -- because I'm internationally friendly and up-to-date sort of guy. And Bacula wants it which stopped me dithering way back when.

Actually the answer should be "maybe" rather than "yes". Is it an installation time option? My 14.0 OS installation log has no mention of it. I manually changed /etc/profile.d/lang.sh to have these two effective lines ...
Code:
export LANG=en_GB.UTF-8
export LC_COLLATE=C
... and use kernel parameter vt.default_utf8=0 (forgotten why, it disables UTF-8 on the virtual terminals).
 
Old 12-11-2012, 08:27 PM   #26
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. What else is there?
Posts: 304

Rep: Reputation: 40
I have it set to use it simply because I like to see foreign (to me) words the way they're *supposed* to look if I happen to go to a website or whatever.

AFAIK I've not had any problems because of it, *unless* it's what makes everything look like a garbled mess if I restart the system in init 3 (so I can use mc, for instance). Nothing can be read, but as I fiddle my way around in mc, things will sort of clear up where the cursor line is once I type or something (I hope that makes sense).

If it is because of the UTF8 thing, well, so long as I can still figure my way around at the prompt I'll leave it be.
 
Old 12-11-2012, 10:22 PM   #27
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 187Reputation: 187
irgunII,

1) Edit your /etc/lilo/conf, replace:

Code:
append=" vt.default_utf8=0"
with:

Code:
append=" vt.default_utf8=1"
and rerun lilo command.

2) Edit your /etc/rc.d/rc.font and put there the line:

Code:
setfont -v lat2-16.psfu.gz
After reboot everything should work well.

(Midnight Commander in the mode you described looks and works horrible.)
 
1 members found this post helpful.
Old 12-11-2012, 10:31 PM   #28
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 187Reputation: 187
NonNonBa,

Over 1000 views and below 100 votes in your poll. Is it so hard to press the [Vote Now] button?

Last edited by w1k0; 12-11-2012 at 10:34 PM. Reason: I like edit my posts...
 
Old 12-12-2012, 07:11 AM   #29
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Maybe 900 of them aren't slackware users and they were just being nosey to see what we were talking about.
 
Old 12-12-2012, 08:37 AM   #30
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,638

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Or maybe they simply do not know the answer because:
(1) They do not remember if/how they set up the character encoding at time of installation.
(2) They do not know what UTF-8 means/is.
(3) They do not know what a character encoding is or that there are several ways to encode a character or that several character encodings are available in Slackware.
(4) They visit any new thread in this forum, just in case they would find something interesting for them or someone they could help.
(5) Another reason I can't think of right now.

Maybe we should setup another poll to find out to which categories readers of this forum fall into?

PS. About categories, I can't refrain to quote the late Ann Landers:
Quote:
Women complain about sex more often than men. Their gripes fall into two major categories: (1) Not enough. (2) Too much.

Last edited by Didier Spaier; 12-12-2012 at 08:44 AM. Reason: PS added
 
  


Reply

Tags
unicode


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Umlauts (,,) does not shown right even if UTF-8 is set on Red Hat 6.3 Santiago mindgame71 Linux - Server 0 10-04-2012 01:57 AM
How to set Charset to UTF-8 in Apache for scripts? cooljai Linux - Software 0 05-15-2008 04:53 AM
The parameter --locale=xx_YY.utf-8 was not set in your /etc/default/dictd tony safari Linux - Software 0 03-18-2007 09:13 AM
Conversion from character set 'UTF-8' to @local error Postgre Slackware 2 09-11-2006 09:15 PM
Help needed with font installation on Debian 3.1 with locale all set to en_US.UTF-8 PhantmShado Linux - Software 1 02-20-2006 03:50 PM


All times are GMT -5. The time now is 11:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration