LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-28-2011, 02:11 PM   #16
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,013

Rep: Reputation: 83

Are you using the mouse on a reflective surface?

If so you may want to use an A4 pad of paper.

In the past I have found this to be the best mouse mat.
 
Old 11-28-2011, 03:48 PM   #17
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Are you using the mouse on a reflective surface?
No - that would be a bit daft for an optical device. Thanks for the suggestion.
 
Old 12-13-2011, 10:39 PM   #18
NightSky
Member
 
Registered: Sep 2001
Location: Texas :(
Distribution: Slackware64-13.37
Posts: 776

Rep: Reputation: 50
bgeddy,
I barely can control usb mouse movement, same mouse has worked great until last slackware64 stable version. Using Xfce 4.6.2 DM on PC. I noticed xfce4 mouse settings Automatically Uses "Virtual Core XTest" mouse option. Logictech USB is an option but when chosen, option reverts back. Do have the same situation with Xfce settings?

Mouse pointer acts as if it has MS! Driving me insane!

Hints/Changes - its recommended xorg.conf-vesa which is automatically generated no longer be edited manually. Any changes need to go into /etc/X11/xorg.conf.d which is empty?
Input hotplugging is no longer done using hal;
instead, it now uses udev for input device detection and keyboard mapping. Found an Archwiki for using udev

/usr/share/X11/xorg.conf.d/ is the "packaged" configuration directory; all
files ending with ".conf" in this directory are used by the X server
unless there is an identically-named file in the local sysadmin directory.
The local sysadmin config directory is /etc/X11/xorg.conf.d/ - all files
ending with ".conf" in this directory are parsed.

There are several default config files in /usr/share/X11/xorg.conf.d/:
* 10-evdev.conf
a "catchall" file for input devices using the evdev driver; this
should work for most hardware in the absence of a better driver
* 50-synaptics.conf
overrides the earlier 10-evdev.conf file and uses the synaptics
driver for all touchpads
* 50-wacom.conf
overrides the earlier 10-evdev.conf file and uses the wacom driver
for Wacom tablets
* 90-keyboard-layout.conf
this sample ("normal" en layout) keeps the "old" default of allowing Zap'ing the Xserver.
If you need to modify any of these defaults, then copy the relevant file
from /usr/share/X11/xorg.conf.d/ to /etc/X11/xorg.conf.d/ and edit the copy.

When I tried to paste an edited version for my old good mouse settings:
Option "Protocol" "Auto"
Option "Protocol" "IMPS/2"
Option "ZAxis Mapping" "4 5 6 7"
as snippet in /etc/X11/xorg.conf.d/ - startx would not open Xfce, so I just gave up till now.

I use a KVM Switch so Tried: uncomment the following line in /etc/modprobe.d/psmouse.conf:
#options psmouse proto=imps
Next, unload and reload the psmouse module (do this as root):
modprobe -r psmouse ; modprobe psmouse

From Dugan Make Mouse More Sensitive:http://duganchen.ca/writings/slackware/setup
Also changed usbhid.conf options usbhid mousepoll=2
Found this:http://www.smop.co.uk/blog/index.php...tech-g7-mouse/
In /etc/X11/xorg.conf:

Section “InputClass”
Identifier “evdev mouse”
MatchProduct “Logitech USB Receiver”
MatchIsPointer “true”
Option “ButtonMapping” “1 8 3 4 5 6 7 2″
EndSection
I don't know if it will help our situation. Please post your how you solve your mouse insanity. I'll do the same but I don't understand all the options so its trial and error.
 
Old 12-14-2011, 02:00 AM   #19
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,598
Blog Entries: 29

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
Originally Posted by bgeddy View Post
No - that would be a bit daft for an optical device.
I had the same problem before. Does this happen to your mouse even when it is
not touching the ground at all?
http://www.linuxquestions.org/questi...shaken-846535/
 
Old 12-14-2011, 04:21 AM   #20
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,317

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
I noticed in your Xorg.log output the lines...
Code:
[   100.207] (WW) Mouse0: No Device specified, looking for one...
[   100.219] (II) Mouse0: Setting Device option to "/dev/input/mice"
[   100.219] (--) Mouse0: Device: "/dev/input/mice"
...which means that the system chose the device that reports all events from all mice.

Do things improve if you actually use /dev/input/mouse0 instead?
 
Old 12-14-2011, 06:16 AM   #21
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
I would make a new 'xorg.conf' and add only what is necessary. I would add:

Code:
Section "Module"
	SubSection  "extmod"
		Option    "omit xfree86-dga"   # don't initialise the DGA extension
	EndSubSection
EndSection
For games, this will prevent strange mouse behavior.

Some other suggestions, some may have been stated before:

1) Use the mouse on a textured surface, not smooth.
2) Keep both the surface and bottom of the mouse clean. Sometimes an object, like a strand of hair or speck of dust will cling to it and cause strange movement of the pointer.
3) Plug the mouse into a different USB port. Check 'cat /proc/interrupts' for lots of interrupts on a single usb IRQ, the one with your mouse.
 
1 members found this post helpful.
Old 12-14-2011, 04:33 PM   #22
NightSky
Member
 
Registered: Sep 2001
Location: Texas :(
Distribution: Slackware64-13.37
Posts: 776

Rep: Reputation: 50
Code:
#:cp /usr/share/X11/xorg.conf.d/50-vmmouse.conf /etc/X11/xorg.conf.d/
#:vi /etc/X11/xorg.conf.d/50-vmmouse.conf
Placed this in vmmouse.conf and saved it. Xfce started normally this time:
Code:
Section "InputClass"
	Identifier	"evdev mouse"
	MatchIsPointer	"on"
	MatchTag	"Logitech USB Receiver"
	Driver		"evdev"
        Option "Protocol" "IMPS/2"
        Option "Zaxis Mapping" "4 5 6 7"
EndSection
Lowered Acceleration to 0.2 & threshold to 5 thinking mouse is too sensitive.
Xfce is still using vmmouse? Looking to see how to turn off the touchscreen and touch pad, don't have either maybe this will stabilize mouse.

Changed mouse pad from a cloth type to a kind of laminated Penguin. lol Mouse is tracking a straight line now! I'm happy.

Last edited by NightSky; 12-14-2011 at 09:22 PM. Reason: Thanks H_TexMex_H...Mouse Pad Change Did it
 
Old 12-14-2011, 05:32 PM   #23
impert
Member
 
Registered: Feb 2009
Posts: 275

Rep: Reputation: 53
Batteries?
 
Old 12-14-2011, 09:48 PM   #24
NightSky
Member
 
Registered: Sep 2001
Location: Texas :(
Distribution: Slackware64-13.37
Posts: 776

Rep: Reputation: 50
bgeddy
Why do u have /dev/psaux instead of /dev/mouse?
You also have an Identifier of Mouse0 mine is Mouse1, only have one mouse? /dev/psaux may be the ghost in your mouse. Hope so

Here is my Auto Generated xorg.conf-vesa and its working with a usb wireless Logitech S530 keyboard + mouse:
Code:
****************
# Core Pointer's InputDevice section
****************

Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

#    Option     "Protocol"      "Auto"

# The available mouse protocols types that you can set below are:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
    
Option "Protocol"    "IMPS/2"

# The mouse device.  The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

    Option "Device"      "/dev/mouse"
#   Option "Device"      "/dev/psaux"
#   Option "Device"      "/dev/ttyS0"
#   Option "Device"      "/dev/ttyS1"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"	"Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"		"9600"
#    Option "SampleRate"	"150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection
 
Old 12-16-2011, 11:04 PM   #25
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 174
Blog Entries: 1

Rep: Reputation: 36
Are you running multiple monitors? I had this problem before when running multiple screens(logic screens) with X server on different monitors, mouse start jumping around cross over between monitors. By using Nvidia's twinviews, or using Xinerama only, just running single screen over multiple monitors helped to remedy my mouse problem. And, I bought new mouse as well, my mouse is a usb mouse connecting with adapter to ps/2 port. Hope this will help you.

Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/mouse"
    Option         "Protocol" "ImPS/2"
    Option         "Buttons"  "3"
    Option         "ZAxisMapping" "4 5"
    Option         "AdaptiveDeceleration" "3"
    Option         "Emulate3Buttons" "no"
    Option         "SampleRate"  "110"
    Option         "Resolution"  "900"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse pointer moves up and down when mouse moved side to side hustla Slackware 6 10-29-2006 03:11 PM
mouse pointer moves up upon any mouse action in slackware 10.2 XavierKing Linux - General 2 07-20-2006 03:36 PM
Mouse moves up/down, not left/right Neoltlink Slackware 4 03-22-2006 05:22 PM
mouse wheel moves sideways pavodive Linux - Hardware 4 03-30-2005 12:39 AM
USB mouse moves up/down no right/left noahsatellite Linux - Hardware 4 09-13-2004 02:41 AM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration